You cannot access EFS files after you change the user password to a new password on a Windows XP Service Pack 2-based computer

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Article ID: 890951
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Symptoms

Consider the following scenario:
  1. You use a Microsoft Windows XP Service Pack 2 (SP2)-based computer.
  2. You log on to the computer as a local user.
  3. You receive a password expiry notification message.
  4. You change the password to a new password.
In this scenario, after you change the password, you cannot access the Encrypting File System (EFS) files on your computer. Additionally, you may notice that you can access the EFS files if you change the password back to the old password.

Cause

This problem occurs because the user profile for the current user is not loaded correctly after you change the password.

Resolution

This issue is resolved in Windows XP SP3.

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389 How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Windows XP Service Pack 2 (SP2).

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
   Date         Time   Version           Size     File name
   ----------------------------------------------------------
   10-Dec-2004  18:25  5.1.2600.2580     721,920  Lsasrv.dll 

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

This problem also affects applications that use Data Protection API (DPAPI). To prevent this, apply the hotfix described in this article. If you have already experienced the problem, change the password to the old password after you apply the hotfix. Then change the password to blank. After that, EFS will encrypt the files correctly even if users change their passwords.
For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

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Article ID: 890951 - Last Review: June 20, 2014 - Revision: 1.0
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbwinxppresp3fix kbfix kbbug KB890951

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