LPD print jobs do not run in a Windows 2000 Server cluster environment

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Article ID: 891010 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario. You have a spooler resource on a cluster node. The cluster node is running Microsoft Windows 2000 Server. In this scenario, client computers use the Line Printer Daemon (LPD) protocol to access shared printers. However, print jobs from the client computers do not run as expected.

Note You may not experience this problem when you use the Server Message Block (SMB) protocol or remote procedure call connections.

CAUSE

This problem occurs because of a race condition that occurs in the spooler resource. This race condition occurs if the spooler resource is frequently taken offline and then brought back online.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Windows 2000 Server Service Pack 3.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
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File nameFile versionFile sizeDateTimePlatformService branch
Basesrv.dll5.0.2195.695146,35217-Jun-200423:05x86Not Applicable
Faxui.dll0.2.0.2138,00001-Feb-200504:01x86Not Applicable
Gdi32.dll5.0.2195.6945231,18417-Jun-200423:05x86Not Applicable
Kernel32.dll5.0.2195.6946712,46417-Jun-200423:05x86Not Applicable
Localspl.dll5.0.2195.7020258,83201-Feb-200504:01x86Not Applicable
Mf3216.dll5.0.2195.689837,13624-Mar-200402:17x86Not Applicable
Mpr.dll5.0.2195.682454,54424-Mar-200402:17x86Not Applicable
Msgina.dll5.0.2195.6928335,12017-Jun-200423:05x86Not Applicable
Rdpwd.sys5.0.2195.689290,26424-Mar-200402:17x86Not Applicable
Sp3res.dll5.0.2195.70236,282,75228-Jan-200505:49x86Not Applicable
Spoolss.dll5.0.2195.702680,14401-Feb-200504:01x86Not Applicable
User32.dll5.0.2195.6897403,21624-Mar-200402:17x86Not Applicable
Userenv.dll5.0.2195.6794385,80805-Aug-200322:14x86Not Applicable
Win32k.sys5.0.2195.69661,632,62410-Aug-200403:51x86Not Applicable
Win32spl.dll5.0.2195.668197,04019-Jun-200320:05x86Not Applicable
Winlogon.exe5.0.2195.6970182,54424-Aug-200422:59x86Not Applicable
Winsrv.dll5.0.2195.6946244,49617-Jun-200423:05x86Not Applicable
Kernel32.dll5.0.2195.6946712,46417-Jun-200423:05x86UNIPROC
Win32k.sys5.0.2195.69661,632,62410-Aug-200403:51x86UNIPROC
Winsrv.dll5.0.2195.6946244,49617-Jun-200423:05x86UNIPROC

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the description of the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 891010 - Last Review: October 9, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbautohotfix kbbug kbfix kbhotfixserver kbqfe KB891010

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