You cannot save or delete a recurring appointment in Exchange 2000

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Article ID: 891082 - View products that this article applies to.
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Symptoms

When you try to save or delete a recurring appointment in Microsoft Exchange 2000 Server, the appointment is not saved or deleted. You also receive one or more of the following error messages:
Out Of Memory
Additionally, error events that are similar to the following error events are logged in the Application log:

Event Type: Error
Event Source: EXCDO
Event Category: General
Event ID: 8207
Date: Date
Time: Time
User: N/A
Computer: Server_Name
Description: Calendaring agent failed with error code 0x8007000e while deleting appointment. For more information, click http://search.support.microsoft.com/search/?adv=1.

Note The description in this event varies depending on whether you tried to save or whether you tried to delete the appointment.

Event Type: Error
Event Source: EXCDO
Event Category: General
Event ID: 8199
Date: Date
Time: Time
User: N/A
Computer: Server_Name
Calendaring agent failed in message save notification with error 0x8007000e on username@domain.com: /Calendar/appt10636659.eml. For more information, click <http://www.microsoft.com/contentredirect.asp>.

Event Type: Error
Event Source: EXCDO
Event Category: General
Event ID: 8206
Date: Date
Time: Time
User: N/A
Computer: Server_Name
Calendaring agent failed with error code 0x8007000e while saving appointment. For more information, click <http://www.microsoft.com/contentredirect.asp>.
Data:
0000: 48 72 53 61 76 69 6e 67 HrSaving
0008: 41 70 70 74 3a 3a 43 45 Appt::CE
0010: 78 70 53 74 61 74 75 73 xpStatus
0018: 3a 3a 48 72 53 61 76 65 ::HrSave
0020: 4d 61 73 74 65 72 20 66 Master f
0028: 6f 72 20 6d 6f 64 69 66 or modif
0030: 69 63 61 74 69 6f 6e 73 ications
0038: 20 66 61 69 6c 65 64 2e failed.
0040: 20 4d 61 69 6c 62 6f 78 Mailbox

Cause

This problem occurs when the following conditions are true:
  1. There are too many recurring appointments in the calendar of one mailbox.
  2. You used Microsoft Outlook Web Access or any Document Authoring and Versioning (DAV) tool to access the calendar at least one time.
The RMTable property limits the number of appointments to 1360 appointments or to 32 kilobytes of appointment data. When the limit has been reached, the RMTable property cannot be opened. Therefore, new appointments cannot be saved, and existing appointments cannot be deleted.

Resolution

After you install this hotfix, you can delete old recurring appointments so that the number of recurring appointments in the calendar is below the limit. After you delete the old recurring appointments, you can save new recurring appointments.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Because of file dependencies, this update requires Microsoft Exchange 2000 Server Service Pack 3 (SP3) and the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
870540 Availability of the August 2004 Exchange 2000 Server post-Service Pack 3 update rollup

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previous hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time item in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   08-Feb-2005  03:59  6.0.6617.44     3,919,872  Cdoex.dll        
   08-Feb-2005  03:59  6.0.6617.44     3,596,288  Excdo.dll        
   
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
301378 How to obtain the latest Exchange 2000 Server service pack

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 891082 - Last Review: October 26, 2013 - Revision: 6.0
Applies to
  • Microsoft Exchange 2000 Server Standard Edition
Keywords: 
kbnosurvey kbarchive kbautohotfix kbqfe kbhotfixserver kbfix kbexchange2000presp4fix kbbug KB891082

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