Help and Support
 

powered byLive Search
Hotfix Download Available

FIX: A custom application that uses context activation stops responding in Windows XP with Service Pack 1 or Service Pack 2

Article ID:891117
Last Review:August 29, 2007
Revision:4.1
On This Page

SYMPTOMS

In Microsoft Windows XP with Service Pack 1 (SP1) or Service Pack 2 (SP2), when you start a custom application that uses context activation, the application may stop responding (crash).

Back to the top

CAUSE

This problem occurs if the QueryPathOfRegTypeLib function does not correctly return the fully qualified file name for a type library that was specified in the manifest file.

Back to the top

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
  Date         Time   Version        Size     File name
  --------------------------------------------------------   
  14-Dec-2004  19:31  5.1.2600.2580   65,024  Asycfilt.dll     
  14-Dec-2004  19:31  5.1.2600.2580  549,376  Oleaut32.dll     
  14-Dec-2004  19:31  5.1.2600.2580   83,456  Olepro32.dll     
  14-Dec-2004  00:52  5.1.2600.2580   16,896  Stdole2.tlb
  30-Nov-2004  23:05  2.10.3027.1      7,168  Stdole32.tlb

Back to the top

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Back to the top

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates
For more information about the hotfix for Windows XP Service Pack 1, click the following article number to view the article in the Microsoft Knowledge Base:
895322 (http://support.microsoft.com/kb/895322/) FIX: A custom program that uses context activation may unexpectedly stop responding on a computer that is running Windows XP with Service Pack 1

Back to the top


APPLIES TO
Microsoft Windows XP Service Pack 1, when used with:
  Microsoft Windows XP Home Edition
  Microsoft Windows XP Professional
  Microsoft Windows XP Home Edition
  Microsoft Windows XP Professional

Back to the top

Keywords: 
kbautohotfix kbwinxpsp3fix kbwinxppresp3fix kbbug kbfix kbqfe kbhotfixserver KB891117

Back to the top

Article Translations

 

Other Support Options

  • Need More Help?
    Contact a Support professional by Email, Online or Phone.
  • Customer Service
    For non-technical assistance with product purchases, subscriptions, online services, events, training courses, corporate sales, piracy issues, and more.
  • Newsgroups
    Pose a question to other users. Discussion groups and Forums about specific Microsoft products, technologies, and services.