Recebe o "Ocorreu um erro. Para obter mais informações, contacte o administrador do sistema"erro mensagem quando tenta visualizar informações de vendas para uma conta no Microsoft CRM

Traduções de Artigos Traduções de Artigos
Artigo: 891192 - Ver produtos para os quais este artigo se aplica.
Este artigo foi arquivado. Este artigo é oferecido "tal como está" e deixará de ser actualizado.
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Sintomas de utilizador final

Quando tenta visualizar informações de vendas para uma conta no Microsoft CRM, receberá a seguinte mensagem de erro:
Erro:

Ocorreu um erro. Para mais informações, contacte o administrador de sistema.
Se estiver a utilizar Microsoft SQL Server 2000 Service Pack 3 (SP3) crie 8.00.760 ou 8.00.818, poderá receber a seguinte mensagem de erro:
Servidor encontrou uma mensagem de erro de excesso de pilha durante o tempo de compilação

Sintomas de programador

Se tiver activado o modo DevErrors no ficheiro Web.config para que possa ver mensagens de erro detalhadas, receberá a seguinte mensagem de erro:
Erro interno do processador de consultas: O processador de consultas ficou sem espaço na pilha durante a optimização de consulta.

Detalhes do erro:
Obter detalhes sobre este erro não foram fornecidos pela plataforma.

Número do erro:
0x80040E14

Ficheiro de origem:
Não disponível

Número de linha:
Não disponível

Query String: /_grid/grid_data.aspxsortCol=name&sorDir=ascend&viewed={00000000-0000-0000-00AA-000010001203}&api=CRMAccount.RetrieveAllOpportunities&filter=&oId={598F7FC6-10BD-4674-9D3E-E941D7F07AA6}&oType=1&pageNum=1

Erro de registo de eventos de aplicação do Microsoft CRM Server

Quando visualiza o registo de eventos de aplicações do Microsoft CRM Server, verá a seguinte mensagem de erro:

Relatório de erros Platform MSCRM:--------------------------------------------------------------------------------------------------------erro: erro interno de processador de consultas: O processador de consultas ficou sem espaço na pilha durante a optimização de consulta.

Mensagem de erro: Erro de processador de consulta interno: O processador de consultas ficou sem espaço na pilha durante a optimização de consulta.

Detalhes do erro: Detalhes sobre este erro não foram fornecidos pela plataforma.

Ficheiro de origem: Não disponível

Número de linha: Não disponível
Informações de rastreio da pilha: no System.Web.UI.Page.HandleError (excepção electrónico)
em System.Web.UI.Page.ProcessRequestMain()
em System.Web.UI.Page.ProcessRequest()
em System.Web.UI.Page.ProcessRequest (HttpContext contexto)
em System.Web.CallHandlerExecutionStep.System.Web.HttpApplication+IExecutionStep.Execute() no System.Web.HttpApplication.ExecuteStep (IExecutionStep passo, boleano & completedSynchronously)

Para mais informações, consulte o Centro de ajuda e suporte em http://support.microsoft.com.

Causa

Este problema ocorre se mais de 8.000 contactos associados uma conta.

Como contornar

Não é possível ver as vistas associadas para as oportunidades, as aspas, as encomendas e as facturas para uma única conta que tenha mais de 8.000 contactos. No entanto, pode utilizar uma das seguintes medidas para contornar este problema.

Solução 1

Utilize pontos de entrada de dados alternativos para criar, actualizar e eliminar oportunidades, cotações, encomendas e facturas para qualquer registo de conta que tenha mais de 8.000 contactos. Pontos de entrada de dados alternativos incluem o seguinte:
  • O formulário de oportunidade
  • O formulário de cotação
  • O formulário de encomenda
  • O formulário de factura do Microsoft CRM
Para relatórios, pode utilizar os relatórios de ordem, os relatórios de proposta, os relatórios de oportunidade e os relatórios de factura na aplicação do Microsoft CRM.

Solução 2

Configurar várias contas para a conta que tenha mais de 8.000 contactos. Por exemplo, se tiver uma conta com o nome Company_A, pode criar contas que são denominadas Company_A1, Company_A2 e Company_A3. Por fornecer informações sobre melhor, é possível utilizar a primeira conta (Company_A1 neste exemplo) como conta principal para as outras contas CRM para esta empresa. Depois de estabelecer contas adicionais e a relação principal/subordinado ou relações, tem de mover um subconjunto dos contactos da conta principal para cada conta de criança. Em seguida, é possível eliminar a conta que tenha mais de 8.000 contactos. Para evitar o problema descrito neste artigo, certifique-se de que nenhuma conta tem mais de 8.000 contactos.

Ponto Da Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na secção "Aplica-se a".Este problema está agendado para ser corrigido no Microsoft CRM 2005.

Mais Informação

Passos para reproduzir o comportamento

  1. Abra uma conta que tenha mais de 8.000 contactos.
  2. No painel esquerdo, clique em vendas .
Recebe a mensagem de erro mencionada na secção "Sintomas".

Referências

Para obter informações adicionais sobre o modo de DevErrors, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
857192Como utilizar o ficheiro Web.config para mostrar mais mensagens de erro no Microsoft Business Solutions CRM (Microsoft CRM)

Propriedades

Artigo: 891192 - Última revisão: 10 de fevereiro de 2014 - Revisão: 2.0
A informação contida neste artigo aplica-se a:
  • Microsoft CRM 1.2
  • Microsoft Business Solutions CRM 1.0
Palavras-chave: 
kbnosurvey kbarchive kbmt kbmbsmigrate kbbug KB891192 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 891192

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com