Article ID: 891387 - Last Review: June 2, 2006 - Revision: 1.7

You may receive an error message when you click the Settings tab on the Display Properties dialog box in Windows XP

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SYMPTOMS

When you open the Display Properties dialog box and then click the Settings tab in Microsoft Windows XP, you may receive the following error message:
The currently selected graphics display driver cannot be used. It was written for a previous version of Windows, and is no longer compatible with this version of windows. The system has been started using the default VGA driver. Please contact your hardware manufacturer to get an updated driver, or select one of the Microsoft provided drivers.
You may receive this error message if the following sequence of events occurs:
  1. You are using a portable computer that is connected to a docking station, and you are using an external monitor.
  2. You turn on the extended desktop function on the external monitor.
  3. You change the rotation setting on the external monitor by using your video adapter's display settings.
  4. You disconnect the portable computer from the docking station.
  5. You open the Display Properties dialog box and then click the Settings tab.

CAUSE

This problem may occur if the following sequence of events occurs:
  1. You use a third-party program to change the rotation of the external display that is connected to the docking station.
  2. You remove the portable computer from the docking station.
When this sequence of events occurs, the user profile is changed, and a mode that matches the display rotation cannot be located in the undocked profile.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Microsoft Windows XP. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
322389  (http://support.microsoft.com/kb/322389/ ) How to obtain the latest Windows XP service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language. The English version of this Hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP, 32-bit versions
   Date         Time   Version        Size     File name
   ------------------------------------------------------------------
   22-Mar-2005  22:21  6.0.2800.1650  384,000  Themeui.dll
Windows XP Professional x64 Edition
   Date         Time   Version        Size     File name     Platform
   ------------------------------------------------------------------
   22-Mar-2005  22:21  6.0.2800.1650  939,520  Themeui.dll   IA-64
   22-Mar-2005  22:21  6.0.2800.1650  384,000  Wthemeui.dll  x86
   25-Feb-2005  03:50  6.1.22.4       639,712  Updspapi.dll  IA-64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site:
http://www.microsoft.com/windowsxp/64bit/default.mspx (http://www.microsoft.com/windowsxp/64bit/default.mspx)
For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:
http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx (http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx)

APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional x64 Edition
Keywords: 
kbautohotfix kberrmsg kbwinxpsp2fix kbwinxppresp2fix kbfix kbbug kbqfe kbhotfixserver KB891387