The Microsoft Systems Management Server Scheduler component cannot schedule a master send request

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Article ID: 891565 - View products that this article applies to.
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SYMPTOMS

The Microsoft Systems Management Server (SMS) Scheduler component cannot schedule a master send request. This symptom occurs in large SMS hierarchies that have many primary and secondary sites. Additionally, the following error message entry is reported in the SMS\Logs\Sched.log file on the SMS Site Server computer:
~ Cannot open file \\SMSServer\SMS_xxx\inboxes\schedule.box\tosend\0000000n.Ixx. Cause is 2 $$<SMS_SCHEDULER> ~The CRoutingInst::MakeInstructionFile function failed with SMS error 2. $$<SMS_SCHEDULER> ~An error occurred when creating the routing instruction. $$<SMS_SCHEDULER>
This error message entry occurs every time that the SMS Scheduler tries to schedule the send request. Therefore, the list of slave requests for the master request may increase.

CAUSE

This problem occurs because the instruction file for the master send request is deleted. When the instruction file is deleted, the SMS Scheduler converts the accompanying slave send request to a master send request. However, the new master send request cannot be correctly scheduled because the instruction file does not exist.

RESOLUTION

SMS 2003 service pack information

To resolve this problem, obtain the latest service pack for Systems Management Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
885643 How To obtain the latest Systems Management Server 2003 service pack

SMS 2.0 hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

Systems Management Server 2.0 Service Pack (SP) 5 is required to install this hotfix.

Restart requirement

You do not have to restart the computer after you apply this software update.

Hotfix replacement information

This hotfix does not replace any other software updates. The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   ------------------------------------------------------------------------------
   29-Apr-2005  21:01  2.0.1493.5202   1,110,248  Sms2.0-sp5-kb891565-x86-enu.exe  
   25-Feb-2003  17:30  2.0.1493.5202   1,634,208  Basesvr.dll

Hotfix installation instructions

This hotfix updates the SMS Scheduler component. This hotfix must be applied to all SMS site servers in the SMS hierarchy.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Systems Management Server 2003 Service Pack 2.

MORE INFORMATION

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 891565 - Last Review: October 9, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Systems Management Server 2.0 Service Pack 5
  • Microsoft Systems Management Server 2003
Keywords: 
kbautohotfix kbqfe kbHotfixServer kbfix kbbug KB891565

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