Una sesión de servicios de Terminal Server en un equipo basado en Windows 2000 deja de responder si un usuario cierra sesión después de que el usuario sale de un programa de Windows de 16 bits

Seleccione idioma Seleccione idioma
Id. de artículo: 891577 - Ver los productos a los que se aplica este artículo
Este artículo se ha archivado. Se ofrece "tal cual" y no se volverá a actualizar.
importante este artículo contiene información acerca de cómo modificar el Registro. Antes de modificar el Registro, asegúrese de hacer una copia de seguridad del mismo y de que sabe cómo restaurarlo si ocurre algún problema. Para obtener información sobre cómo realizar una copia de seguridad, restaurar y modificar el Registro, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
256986Definición del Registro de Microsoft Windows
Expandir todo | Contraer todo

En esta página

Síntomas

Un usuario inicia sesión a un equipo basado en Microsoft Windows 2000 a través de una sesión de servicios de Terminal Server y, a continuación, ejecuta un programa de Windows de 16 bits. Después de que el usuario sale del programa de Windows de 16 bits, no se cierra el proceso de NTVDM.exe. En su lugar, el proceso de NTVDM.exe sigue ejecutándose. Si la opción de suplantar la configuración desde el perfil de usuario y el Asistente de administrador de conexión de cliente está configurada en el servidor, la sesión de Terminal Services puede dejar de responder (se bloquea) cuando el usuario cierra sesión. Experimenta estos síntomas después de instalar una actualización de seguridad en el equipo basado en Windows 2000. Esta actualización de seguridad se documenta en el siguiente artículo de Microsoft Knowledge Base:
840987MS04-032: Actualización de seguridad para Microsoft Windows

Causa

Este problema se produce porque los procesos de 16 bits se ejecutan bajo un proceso NTVDM.exe compartido. El proceso de Windows en Windows (WOW) compartido no anular el registro propio cuando el proceso WOW procesa el mensaje salga del programa de Windows de 16 bits.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Si no aparece en esta sección, enviar una solicitud al servicio de cliente de Microsoft y soporte para obtener la revisión.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Esta revisión requiere Windows 2000 Service Pack 4 (SP4).

Requisito de reinicio

Una vez aplicado este hotfix, debe reiniciar el equipo.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
Date         Time   Version          Size     File name
----------------------------------------------------------
20-Dec-2004  17:29  5.0.2195.7011     46,352  Basesrv.dll      
21-Sep-2003  08:45  5.0.2195.6824    236,304  Cmd.exe  
18-Jun-2004  07:05  5.0.2195.6945    231,184  Gdi32.dll 
18-Jun-2004  07:05  5.0.2195.6946    712,464  Kernel32.dll  
24-Mar-2004  10:17  5.0.2195.6898     37,136  Mf3216.dll   
24-Mar-2004  10:17  5.0.2195.6824     54,544  Mpr.dll      
18-Jun-2004  07:05  5.0.2195.6928    335,120  Msgina.dll 
24-Mar-2004  10:17  5.0.2195.6892     90,264  Rdpwd.sys   
24-Mar-2004  10:17  5.0.2195.6897    403,216  User32.dll    
06-Aug-2003  06:14  5.0.2195.6794    385,808  Userenv.dll 
10-Aug-2004  11:51  5.0.2195.6966  1,632,624  Win32k.sys  
25-Aug-2004  06:59  5.0.2195.6970    182,544  Winlogon.exe    
18-Jun-2004  07:05  5.0.2195.6946    244,496  Winsrv.dll 

Solución

Advertencia si utiliza incorrectamente el Editor del Registro, puede causar serios problemas que tal vez requieran volver a instalar el sistema operativo. Microsoft no garantiza que pueda solucionar los problemas resultantes del uso incorrecto del Editor del Registro. Utilice el Editor del Registro bajo su responsabilidad.
Para evitar este problema, siga estos pasos en el servidor:
  1. Haga clic en Inicio , haga clic en Ejecutar , escriba regedit en el cuadro Abrir y, a continuación, haga clic en Aceptar .
  2. Busque y haga clic en la siguiente subclave del Registro:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WOW
  3. En el panel derecho, haga clic con el botón secundario del mouse en DefaultSeparateVDM y, a continuación, haga clic en Modificar .
  4. En el cuadro datos del valor , escriba y, a continuación, haga clic en Aceptar .
  5. Salga del Editor del Registro.
Nota Quizás tenga que reiniciar el servidor después de seguir estos pasos.

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener información adicional acerca del boletín de seguridad de Microsoft MS04-032, visite uno de los siguientes sitios Web de Microsoft: Para obtener información adicional acerca de cómo se denominan los paquetes de revisión, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
816915Nuevo esquema de nomenclatura de archivos para los paquetes de actualización de software de Microsoft Windows
Para obtener información adicional acerca de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 891577 - Última revisión: jueves, 23 de enero de 2014 - Versión: 1.7
La información de este artículo se refiere a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Palabras clave: 
kbnosurvey kbarchive kbmt kbautohotfix kbbug kbfix kbwin2000presp5fix kbhotfixserver kbqfe KB891577 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 891577

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com