Una sessione di Servizi Terminal in un computer basato su Windows 2000 si blocca se un utente si disconnette dopo che l'utente chiude un programma per Windows a 16 bit

Traduzione articoli Traduzione articoli
Identificativo articolo: 891577 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo è stato archiviato. L?articolo, quindi, viene offerto ?così come è? e non verrà più aggiornato.
importante in questo articolo sono contenute informazioni su come modificare il Registro di sistema (chiamato Registro di configurazione in Windows NT). Prima di modificare il Registro di sistema, eseguire una copia di backup e assicurarsi di sapere come ripristinarlo in caso di problemi. Per ulteriori informazioni su come eseguire il backup, ripristinare e modificare il Registro di sistema, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
256986Descrizione del Registro di sistema di Microsoft Windows
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Un utente accede a un computer basato su Microsoft Windows 2000 tramite una sessione di Servizi Terminal e quindi esegue un programma per Windows a 16 bit. Dopo che l'utente chiude il programma Windows a 16 bit, il processo NTVDM.exe non viene chiuso. Al contrario, il processo NTVDM.exe rimane in esecuzione. Se l'opzione Ignora impostazioni del profilo utente e creazione guidata gestore di connessione client è configurato sul server, la sessione di Servizi Terminal smetta di rispondere (si blocchi) quando l'utente si disconnette. Questi sintomi si verificano dopo l'installazione di un aggiornamento della protezione nel computer basato su Windows 2000. Questo aggiornamento della protezione è trattato nell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
840987MS04-032: Aggiornamento della protezione per Microsoft Windows

Cause

Questo problema si verifica poiché processi a 16 bit eseguiti in un processo NTVDM.exe condiviso. Annullare il processo di Windows su Windows (WOW) condiviso non registrazione stesso quando il processo WOW elabora il messaggio di uscita per il programma di Windows a 16 bit.

Risoluzione

Informazioni sull'hotfix

È disponibile un hotfix supportato. Questo hotfix è tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico.

Se l'hotfix è disponibile per il download, è una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta di servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi è necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, è perché un aggiornamento rapido (hotfix) non è disponibile per tale lingua.

Prerequisiti

Questo aggiornamento rapido (hotfix) richiede Windows 2000 Service Pack 4 (SP4).

Necessità di riavvio

È necessario riavviare il computer dopo aver applicato questo hotfix.

Informazioni sulla sostituzione della correzione

Questo aggiornamento rapido (hotfix) non sostituisce eventuali altri hotfix.

Informazioni sui file

La versione di lingua inglese di questo aggiornamento rapido (hotfix) presenta gli attributi di file (o attributi successivi) elencati nella tabella riportata di seguito. Date e ore per questi file sono indicati nella coordinated universal time (UTC). Quando si visualizzano le informazioni sul file, viene convertito in ora locale. Per calcolare la differenza tra ora UTC e l'ora locale, utilizzare la scheda fuso orario dello strumento Data e ora del Pannello di controllo.
Date         Time   Version          Size     File name
----------------------------------------------------------
20-Dec-2004  17:29  5.0.2195.7011     46,352  Basesrv.dll      
21-Sep-2003  08:45  5.0.2195.6824    236,304  Cmd.exe  
18-Jun-2004  07:05  5.0.2195.6945    231,184  Gdi32.dll 
18-Jun-2004  07:05  5.0.2195.6946    712,464  Kernel32.dll  
24-Mar-2004  10:17  5.0.2195.6898     37,136  Mf3216.dll   
24-Mar-2004  10:17  5.0.2195.6824     54,544  Mpr.dll      
18-Jun-2004  07:05  5.0.2195.6928    335,120  Msgina.dll 
24-Mar-2004  10:17  5.0.2195.6892     90,264  Rdpwd.sys   
24-Mar-2004  10:17  5.0.2195.6897    403,216  User32.dll    
06-Aug-2003  06:14  5.0.2195.6794    385,808  Userenv.dll 
10-Aug-2004  11:51  5.0.2195.6966  1,632,624  Win32k.sys  
25-Aug-2004  06:59  5.0.2195.6970    182,544  Winlogon.exe    
18-Jun-2004  07:05  5.0.2195.6946    244,496  Winsrv.dll 

Workaround

avviso Se si utilizza Editor del Registro di sistema in modo non corretto, si potrebbero provocare problemi gravi che potrebbero richiedere la reinstallazione del sistema operativo. Microsoft non garantisce la che è possibile risolvere i problemi derivanti dall'errato utilizzo dell'editor del Registro di sistema. Utilizzare Editor del Registro di sistema a proprio rischio.
Per risolvere questo problema, attenersi alla seguente procedura sul server:
  1. Fare clic su Start , scegliere Esegui , digitare regedit nella casella Apri e quindi fare clic su OK .
  2. Individuare e selezionare la seguente sottochiave del Registro di sistema:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\WOW
  3. Nel riquadro di destra fare clic con il pulsante destro del mouse su DefaultSeparateVDM e scegliere Modifica .
  4. Nella casella dati valore digitare e quindi fare clic su OK .
  5. Chiudere l'editor del Registro di sistema.
Nota Potrebbe essere necessario riavviare il server dopo avere eseguito questi passaggi.

Status

Microsoft ha confermato che questo problema riguarda i prodotti sono elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni sul Bollettino Microsoft sulla sicurezza Microsoft MS04-032, visitare uno dei seguenti siti Web: Per ulteriori informazioni sulla denominazione dei pacchetti di aggiornamento rapido (hotfix), fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
816915Nuovo schema di denominazione di file per i pacchetti di aggiornamento software Microsoft Windows
Per ulteriori informazioni sulla terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft

Proprietà

Identificativo articolo: 891577 - Ultima modifica: giovedì 23 gennaio 2014 - Revisione: 1.7
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
Chiavi: 
kbnosurvey kbarchive kbmt kbautohotfix kbbug kbfix kbwin2000presp5fix kbhotfixserver kbqfe KB891577 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 891577
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com