Artikel-ID: 891605 - Geändert am: Mittwoch, 17. Januar 2007 - Version: 2.1

21426-Ereignis ein Agent-Computer angemeldet ist und Sie erhalten eine Fehlermeldung in der Microsoft Operations Manager (MOM) 2005-Operatorkonsole

SystemtippDieser Artikel bezieht sich auf ein anderes Betriebssystem als das von Ihnen verwendete. Für Sie möglicherweise nicht relevante Artikelinhalte wurden deaktiviert.
wichtig Dieser Artikel enthält Informationen, die Ihnen, zeigt wie Sie Sicherheitseinstellungen herabsetzen oder Sicherheitsfunktionen auf einem Computer deaktivieren. Sie können diese Änderungen einem bestimmten Problem zu umgehen vornehmen. Bevor Sie diese Änderungen vornehmen, empfiehlt Microsoft, zunächst die Risiken, die abzuschätzen mit dieser Problemumgehung in Ihrer speziellen Umgebung verbunden sind. Wenn Sie diese Problemumgehung implementieren, sollten Maßnahmen Sie entsprechende treffen, um den Computer zu schützen.
Alles erweitern | Alles schließen

Problembeschreibung

Wenn McAfee VirusScan Enterprise 8.0i auf einem Agentcomputer installiert ist, treten die folgenden Symptome auf:
  • 21426-Ereignis wird im Ereignisprotokoll Anwendung des Agent-Computers protokolliert.
  • Die folgenden Fehlermeldung erhalten Sie in der Microsoft Operations Manager (MOM) 2005-Operatorkonsole:
    Name:
    Der MOM-Hostprozess verbrauchte zu viel Arbeitsspeicher und wird beendet

    Beschreibung:
    Der Host-Prozess für die Skriptantworten (nnnn) wird gestartet, da nnnnnn mehr Bytes als der Grenzwert von 104857600 verwendet wird. Um diesen Grenzwert anzupassen, bearbeiten Sie den
    Software\Mission Critical Software\OnePoint\MaxScriptHostPrivateBytes
    -Registrierungsschlüssel.

    Verwaltungsgruppe: group name

Ursache

Dieses Problem rührt McAfee VirusScan Windows Script Host-Komponente durch die Proxykomponente von ScriptScan (ScriptProxy.dll) ersetzt. Die ScriptScan-Proxykomponente scannt JavaScript-Skripts und Visual Basic Scripting Edition (VBScript) Skripts. Wenn ein Skript ausgeführt wird und die Überprüfung als sauber durchläuft, wird das Skript an der entsprechenden Windows Script Host übergeben. Die ScriptScan-Proxykomponente analysiert Skripts, bevor Sie von den zugeordneten Windows Script Host ausgeführt werden. Wenn die ScriptScan-Funktion aktiviert ist, verliert die Komponente MOMHost.exe langsam Speicher. Deaktivieren der Funktion ScriptScan in den Eigenschaften McAfee VirusScan wird jedoch nicht das Problem behoben.

Abhilfe

Warnung Diese Problemumgehung kann ein Computer oder ein Netzwerk möglicherweise anfälliger, Angriffe durch böswillige Benutzer oder gefährlicher Software wie Viren vornehmen. Zwar wir empfehlen diese Problemumgehung nicht jedoch diese Informationen, damit Sie diese Problemumgehung eigenem Ermessen implementieren können. Verwenden Sie diese Problemumgehung auf eigene Gefahr.

Um dieses Problem zu umgehen, müssen Sie die ScriptScan-Proxykomponente Registrierung aufheben. Gehen Sie hierzu folgendermaßen vor.

wichtig Wenn Sie die ScriptScan-Proxykomponente Registrierung aufheben, wird McAfee VirusScan nicht Skripts auf Viren überprüft.
  1. Melden Sie sich bei der Agent-Computer über ein Konto mit der Domäne Administrator Berechtigungen.
  2. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie cmd ein und klicken Sie dann auf OK .
  3. Suchen Sie an der Eingabeaufforderung den %ProgramFiles%\Network Associates\VirusScan-Ordner.
  4. Geben Sie an der Eingabeaufforderung Folgendes ein:
    regsvr32/u scriptproxy.dll
  5. Sie müssen den MOM-Dienst um die Änderungen übernehmen neu starten. Gehen Sie hierzu folgendermaßen vor:
    1. Klicken Sie auf Start , zeigen Sie auf Verwaltung , und klicken Sie dann auf Dienste .
    2. Klicken Sie in das Dienste-Snap-in mit der rechten Maustaste auf MOM und klicken Sie auf neu starten .
    3. Beenden Sie das Dienste-Snap-in.

Weitere Informationen

Informationen zu den Hersteller Ihrer Hardware die folgenden-Website:
http://support.microsoft.com/gp/vendors/en-us (http://support.microsoft.com/gp/vendors/en-us)
Weitere Informationen zu diesem Problem finden Sie auf Support-Website von McAfee:
http://knowledgemap.nai.com (http://knowledgemap.nai.com)
Hinweis: Suchen Sie auf der McAfee-Support-Website nach den folgenden Referenzen Solution-ID: kb40067, kb47302, kb40049, und kb46223. Die direkt in diesem Knowledge Base-Artikel beschriebenen Symptome bezieht sich auf McAfee Solution ID kb40067. Obwohl den Speicherverlust von McAfee VirusScan Enterprise 8.0i nicht behoben wird, steht ein Hotfix McAfee Aufheben der Registrierung der ScriptProxy.dll erhältlich. Wenden Sie sich an McAfee-Support, um diesen Hotfix zu erhalten.

Die in diesem Artikel erwähnten Fremdanbieterprodukte werden von einem Lieferanten hergestellt, der von Microsoft unabhängig ist. Microsoft übernimmt keine Garantie, implizite oder sonstige, über die Leistung oder Zuverlässigkeit dieser Produkte.

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Operations Manager 2005 Enterprise Edition
Keywords: 
kbmt kbopmanperfmon kbopmaninterop kbopmanalerts kbtshoot kberrmsg kbperformance kbinterop KB891605 KbMtde
Maschinell übersetzter ArtikelMaschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 891605  (http://support.microsoft.com/kb/891605/en-us/ )
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.