FIX: The common name included in a certificate differs from the corresponding common name in Active Directory when a certificate is requested on a Windows NT 4.0-based computer from a Windows 2000-based certification authority (891854.KB.EN-US.1.1)

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Article ID: 891854 - View products that this article applies to.
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Symptoms

Consider the following scenario. You have a Windows 2000-based domain. You request a certificate on a Windows NT 4.0-based client computer, from a Windows 2000-based certification authority (CA). In this situation, the common name that is included in a certificate differs from the corresponding common name in Active Directory.

Therefore, applications cannot query user information based on the common name that is included in a certificate correctly.

Cause

This problem occurs because the certification authority does not correctly populate the common name of a certificate for Windows NT 4.0-based client computers.

Resolution

To resolve this problem, apply the hotfix on the server that is the certification authority.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Windows 2000 Service Pack 3 (SP3) installed on the computer.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
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File nameFile versionFile sizeDateTimePlatform
Certpdef.dll5.0.2195.702364,27224-Jan-200505:53x86

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 891854 - Last Review: November 2, 2013 - Revision: 4.0
Applies to
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbnosurvey kbarchive kbautohotfix kbexpertiseinter kbbug kbfix kbhotfixserver kbqfe kbwin2000presp5fix KB891854

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