Det visas ett felmeddelande om I/O-fel på enheten när du använder cd-enheten i Windows XP

Artikelöversättning Artikelöversättning
Artikel-id: 891894 - Visa produkter som artikeln gäller.
Mall: zGeneric Problem Article
Visa alla | Dölj alla

Symptom

Ett av följande felmeddelanden kan visas när du försöker installera ett program eller kopiera data från cd-enheten i Microsoft Windows XP:
Begäran kunde inte utföras på grund av ett fel i en I/O-enhet.
Endast delar av en ReadProcessMemory- eller WriteProcessMemory-begäran har slutförts.

Orsak

Detta problem kan uppstå när ett överföringsläge i Windows används som inte stöds av cd-enheten.

Lösning

Lös problemet genom att ändra överföringsläget för cd-enheten CD i egenskaperna för IDE-kanaler. Gör så här:
  1. Klicka på Start, högerklicka på Den här datorn och klicka på Hantera.
  2. Klicka på Enhetshanteraren under Datorhantering (lokal).
  3. Expandera IDE ATA/ATAPI-styrenheter i den högra rutan.
  4. Högerklicka på den kanal som cd-enheten är ansluten till och klicka sedan på Egenskaper. Detta är vanligtvis Sekundär IDE-kanal.
  5. Klicka på Endast PIO på fliken Avancerade inställningar i rutan Överföringsläge för cd-enheten. Vanligtvis är detta Enhet 1. Klicka sedan på OK.
Om problemet kvarstår efter ovanstående ändring av överföringsläge, kanske inte cd-enheten finns på kanalen. Använd samma procedur för att återställa överföringsläget till DMA om tillgängligt. Upprepa sedan stegen för att ändra överföringsläge i för IDE-enheterna i följande ordning tills problemet löses:
  • Primär IDE-kanal, enhet 1
  • Sekundär IDE-kanal, enhet 0
Obs! Primär IDE-kanal, enhet 1 är ansluten till startdisken, vilket är hårddisken som vanligtvis innehåller operativsystemet.

Egenskaper

Artikel-id: 891894 - Senaste granskning: den 7 december 2005 - Revision: 1.1
Informationen i denna artikel gäller:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
Nyckelord: 
kbtshoot kbprb KB891894

Ge feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com