CORRECÇÃO: Internet Explorer 6.0 SP1 não exibe o menu de atalho para um controle ActiveX no Windows XP Service Pack 2

Traduções deste artigo Traduções deste artigo
ID do artigo: 892049 - Exibir os produtos aos quais esse artigo se aplica.
Este artigo foi arquivado. É oferecido "como está" e não será mais atualizado.
importante Este artigo contém informações sobre como modificar o registro. Antes de modificar o registro, certifique-se de backup e certifique-se que você saiba como restaurar o registro se ocorrer um problema. Para obter informações sobre como fazer backup, restaurar e editar o registro, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
256986Descrição do registro do Microsoft Windows
Expandir tudo | Recolher tudo

Neste artigo

Sintomas

No Microsoft Windows XP Service Pack 2 (SP2), quando você abre uma página da Web que contenha um controle ActiveX usando o Microsoft Internet Explorer 6.0 Service Pack 1 (SP1), o menu de atalho para o controle ActiveX não for exibido.

Observação Desativar os recursos de segurança no Internet Explorer não altera esse comportamento e o menu de atalho para o controle ActiveX ainda não for exibido.

Causa

Esse problema ocorre porque o Internet Explorer não encaminha chamadas para o controle ActiveX usando o método IDocHostUIHandler::ShowContextMenu .

Resolução

Informações sobre o hotfix

Um hotfix suportado está disponível no Microsoft. No entanto, esse hotfix destina-se a corrigir o problema descrito neste artigo. Aplique-o somente aos sistemas que apresentarem esse problema específico. Esta correcção poderá submetida a testes adicionais. Portanto, se você não tiver sido gravemente afetado por esse problema, recomendamos que você aguarde a próxima atualização de software que contém esse hotfix.

Se o hotfix está disponível para download, há uma seção "Download de Hotfix disponível" na parte superior neste artigo da Base de dados de Conhecimento. Se esta seção não for exibida, contate o atendimento e suporte para obter o hotfix.

Observação Se ocorrerem problemas adicionais ou se qualquer solução de problemas é necessária, talvez você precise criar uma solicitação de serviço separada. Os custos normais de suporte serão aplicados a questões de suporte adicionais e problemas que não se qualificam para esse hotfix específico. Para obter uma lista completa de números de telefone de suporte e Atendimento Microsoft ou para criar uma solicitação de serviço separada, visite o seguinte site:
http://support.microsoft.com/contactus/?ws=support
Observação O formulário "Download de Hotfix disponível" exibe os idiomas para os quais o hotfix está disponível. Se você não vir seu idioma, é porque um hotfix não está disponível para esse idioma.

Pré-requisitos

O Windows XP Service Pack 2 é necessário.

Requisitos de reinicialização

Você precisa reiniciar o computador após aplicar esse hotfix.

Informações sobre a substituição do hotfix

Esse hotfix não substitui outros hotfixes.

Informações sobre o arquivo

A versão em inglês deste hotfix tem atributos de arquivo (ou atributos de arquivo posteriores) listados na tabela a seguir. As datas e horas desses arquivos são listadas na acordo hora universal coordenada (UTC). Quando você exibe as informações do arquivo, ele é convertido para a hora local. Para encontrar a diferença entre o UTC e a hora local, use a guia fuso horário na ferramenta Data e hora no painel de controle.
   Date         Time   Version        Size       File name
   --------------------------------------------------------
   14-Jan-2005  06:00  6.0.2900.2597  3,007,488  Mshtml.dll       

Situação

A Microsoft confirmou que este é um problema nos produtos da Microsoft listados na seção "Aplica-se a".

Mais Informações

Aviso Se você usar o Editor do Registro incorretamente, você pode causar problemas sérios que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que você pode resolver problemas resultantes do uso incorreto do Editor do Registro. Use o Editor do registro por sua própria conta e risco.

Depois de instalar esse hotfix, você deve ativar o hotfix, adicionando a seguinte subchave do registro no Registro:
FEATURE_ACTIVEX_CONTEXT_MENU_KB892049
Para fazer isso, execute as seguintes etapas:
  1. Feche o Internet Explorer.
  2. Clique em Iniciar , clique em Executar , digite regedit e, em seguida, clique em OK .
  3. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl
  4. No menu Editar , clique em novo e, em seguida, clique em chave .
  5. Digite FEATURE_ACTIVEX_CONTEXT_MENU_KB892049 e, em seguida, pressione ENTER.
  6. Localize e, em seguida, clique na seguinte subchave do Registro:
    HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_ACTIVEX_CONTEXT_MENU_KB892049
  7. No menu Editar , clique em novo e, em seguida, clique em Valor DWORD .
  8. Digite iexplore.exe e, em seguida, pressione ENTER.
  9. Clique com o botão direito do mouse iexplore.exe e, em seguida, clique em Modificar .
  10. Na caixa de diálogo Editar valor DWORD , digite 00000001 e, em seguida, clique em OK .
  11. No menu arquivo , clique em Sair para fechar o Editor do Registro.
Para obter mais informações sobre o método IDocHostUIHandler::ShowContextMenu , visite o seguinte site da Web Microsoft Developer Network (MSDN):
http://msdn2.microsoft.com/en-us/library/Aa753264.aspx
Para obter informações adicionais, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
824684Descrição da terminologia padrão que é usada para descrever as atualizações de software

Propriedades

ID do artigo: 892049 - Última revisão: domingo, 27 de outubro de 2013 - Revisão: 2.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Service Pack 2
Palavras-chave: 
kbnosurvey kbarchive kbmt kbautohotfix kbwinxppresp3fix kbbug kbfix kbqfe kbhotfixserver KB892049 KbMtpt
Tradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 892049

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com