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Symptoms

When you try to use a Microsoft Windows XP Professional-based computer to view the registry on a remote Windows XP Professional-based computer, you may receive the following error message:

Cannot open HKEY_Local_Machine: error while opening key

When you try to use a Windows XP Professional-based computer to view Event Viewer on a remote Windows XP Professional-based computer, you may receive the following error message:

Access is denied

Cause

This behavior may occur if the remote computer was upgraded from Microsoft Windows 2000 to Windows XP Professional. The error messages occur because the Local Service user account does not have permissions to the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ SecurePipeServers\winreg

Resolution

To resolve this issue, use Registry Editor to grant Read Only permissions to the Local Service user account. To do this, follow these steps:

  1. Click Start, click Run, type regedit, and then click OK.

  2. Expand the following registry subkey:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ SecurePipeServers

  3. Right-click winreg, and then click Permissions.

  4. Click Add.

  5. In the Enter the object names to select box, type Local Service, and then click OK.

    Alternatively, you can type the name of a user or group that you want to grant access permission.

  6. In the Permissions for LOCAL SERVICE list, next to Read, click to select the Allow check box.

  7. Quit Registry Editor, and then restart your computer.

More Information

By default, Windows 2000 does not have a built-in user account named Local Service. Instead, the Remote Registry Service is logged on as Local System. In Windows XP, the Remote Registry Service is logged on as Local Service.

For additional information about the required permissions for remote access to the registry, click the following article number to view the article in the Microsoft Knowledge Base:

314837 How to Manage Remote Access to the Registry

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