Article ID: 892228 - Last Review: October 25, 2006 - Revision: 2.4

Some date and time information for downloaded files is not correct when you distribute a package to a computer that is running Microsoft Systems Management Server (SMS) Advanced Client

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SYMPTOMS

Consider the following scenario. You distribute a package to a computer that is running Microsoft Systems Management Server (SMS) Advanced Client. Files in the package are downloaded to the local cache on the computer that is running SMS Advanced Client. On the computer that is running SMS Advanced Client, you open the %SystemRoot%\System32\Ccm\Cache\Pkgid.Ver.Sid folder. You right-click a file, and then you click Properties. You expect that the date and time information that appears next to Modified will be the same as the date and time information for the same file on the distribution point. Instead, the date and time information for the file that you distributed reflects the date and time that the file was distributed. You find that this date and time difference is true for all the files in the %SystemRoot%\System32\Ccm\Cache\Pkgid.Ver.Sid folder.

CAUSE

This problem occurs because computers that are running SMS 2003 Advanced Client open these files for writing after they are downloaded from the distribution point.

RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Systems Management Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
885643  (http://support.microsoft.com/kb/885643/ ) How To obtain the latest Systems Management Server 2003 service pack

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have SMS 2003 Service Pack 1 (SP1) installed before you apply this hotfix.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   -------------------------------------------------------------------------------
   16-Feb-2005  06:02  2.50.3174.1129    809,704  Sms2003-sp1-kb892228-x86-enu.exe

After you install the hotfix, the following files will have the listed attributes or later versions:
   Date         Time   Version            Size    File name
   ----------------------------------------------------------------------------
   19-Oct-2004  20:20  2.50.3174.1129    205,824  Contentaccess.dll  
   14-Jun-2004  01:50  2.0.156.0         254,455  Deployac.exe     
   19-Oct-2004  20:20                      4,663  Patch.ini
   19-Oct-2004  20:20                    345,600  Sms2003ac-sp1-kb892228-x86.msp
   24-Dec-2003  21:30  2.50.2726.154      40,960  Smsse.dll        
   16-Feb-2005  00:22                        562  Smsconfig.inf
   24-Dec-2003  21:30  2.50.2726.154      40,960  Smsse.dll     

Installation instructions

To install this hotfix, follow these steps:
  1. Create a shared folder in a location that can be accessed by the SMS site servers.
  2. Copy the Sms2003-sp1-kb892228-X86-enu.exe hotfix file to the new shared folder.
  3. On each SMS primary and secondary site server in your environment, log on by using an account that has administrative credentials.
  4. Close the SMS Administrator console if it is open.
  5. On each primary and secondary site server, connect to the shared folder that contains the hotfix, double-click the Sms2003-SP1-kb892228-x86-enu.exe hotfix file, and then follow the instructions in the wizard.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Systems Management Server 2003 Service Pack 2.

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

APPLIES TO
  • Microsoft Systems Management Server 2003
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertiseinter kbsms2003spfix kbsms200sp2fix KB892228
 

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