The Generic Service resource stops responding when you create the Generic Service resource in a Windows 2000 cluster

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Article ID: 892232 - View products that this article applies to.

Important This article contains information about how to modify the registry. Make sure to back up the registry before you modify it. Make sure that you know how to restore the registry if a problem occurs. For more information about how to back up, restore, and modify the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows registry
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SYMPTOMS

Consider the following scenario:
  • You create a Generic Service resource in a Windows 2000 cluster.
  • The Generic Service resource uses the Generic Service resource .dll file.
  • More than ten minutes are required for the Generic Service resource to come online.
When this scenario occurs, you may notice that the Generic Service resource stops responding.

CAUSE

This problem occurs because of a hard-coded time-out value that is in the Generic Service resource .dll file.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To install this hotfix, you must have Microsoft Windows 2000 Service Pack 4 (SP4) installed.
For more information about how to install the latest Windows 2000 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
260910 How to obtain the latest Windows 2000 service pack

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfix.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   -----------------------------------------------------------
   19-Jun-2003  20:05  5.0.2195.6683      55,568  Clusapi.dll      
   19-Jun-2003  20:05  5.0.2195.6683      67,760  Clusnet.sys
   28-Feb-2005  08:38  5.0.2195.7035     253,712  Clusres.dll      
   19-Jun-2003  20:05  5.0.2195.6683     682,768  Clussvc.exe      
   24-Mar-2004  02:17  5.0.2195.6824     134,928  Dnsapi.dll       
   24-Mar-2004  02:17  5.0.2195.6876      92,432  Dnsrslvr.dll     
   19-Jun-2003  20:05  5.0.2195.6660      95,504  Netman.dll       
   19-Jun-2003  20:05  5.0.2195.6604     477,456  Netshell.dll     
   19-Jun-2003  20:05  5.0.2195.6683      54,544  Resrcmon.exe     
   07-Feb-2005  05:35  5.0.2195.7026   6,301,696  Sp3res.dll       
   28-Feb-2005  09:11                     10,024  Kb892232.cat
   25-Feb-2005  17:43  6.1.22.4          371,936  Updspapi.dll
After you install this hotfix, increase the time-out value for the Generic Service resource .dll file by using one of the following methods.

Method 1: Use Cluster Administrator

  1. Start Cluster Administrator.
  2. On the resource for which you want to change the Pending Timeout setting, click Properties.
  3. In the Properties dialog box, click the Advanced tab, and then increase the value for the Pending Timeout setting.

Method 2: Modify the registry


Warning Serious problems might occur if you modify the registry incorrectly by using Registry Editor or by using another method. These problems might require that you reinstall your operating system. Microsoft cannot guarantee that these problems can be solved. Modify the registry at your own risk.

Increase the time-out value in the following registry subkey:
HKEY_LOCAL_MACHINE\cluster\Resources\<GUID>

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 892232 - Last Review: October 9, 2011 - Revision: 2.0
APPLIES TO
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbautohotfix kbbug kbfix kbhotfixserver kbqfe KB892232

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