ID do artigo: 892317 - Última revisão: quinta-feira, 27 de julho de 2006 - Revisão: 1.5

Documentos que são anexados a mensagens de email não são adicionados a uma biblioteca de documentos correio eletrônico ativados no Windows SharePoint Services

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Sintomas

Você pode configurar uma biblioteca de documentos no Microsoft Windows SharePoint Services para permitir a inserção de email. Um usuário envia uma mensagem de email que contém um documento anexado à pasta pública no Microsoft Exchange. Você espera que o documento anexado a ser adicionado à biblioteca de documentos habilitadas email em Windows SharePoint Services. No entanto, o documento anexado não é adicionado à biblioteca de documentos habilitadas email. Além disso, você os seguintes sintomas:
  • O proprietário da pasta pública recebe um email que contém a seguinte mensagem de erro:
    Erro ao processar um ou mais anexos
    A linha de assunto na caixa assunto da mensagem de email é a mesmo linha de assunto da mensagem de email original que enviou o usuário.
  • Uma entrada semelhante à seguinte é gerada pelo serviço do Microsoft SharePoint Timer (Owstimer.exe) no arquivo de log:
    0 DateTime 5984 SharePoint Timer Service para email habilitado bibliotecas de documentos: objeto não encontrado: < http://ServerName /Public/ ServerName / FolderName .eml >
  • Se você tirar um rastreamento de rede, você verá que o arquivo de log NexTags contém uma entrada semelhante à seguinte:
    "HTTP/1.1 503 Serviço indisponível": X-MS-ENUMATTS http:// ServerName /exchange/ UserName /Inbox/ FileName .eml HTTP/1.1

Causa

Esse problema ocorre se a ferramenta de segurança UrlScan estiver em execução no computador do Exchange e o verbo de blocos X-MS-ENUMATTS de ferramenta de segurança UrlScan.

Resolução

Para resolver esse problema, modifique o arquivo URLScan.ini para que a ferramenta de segurança UrlScan permite que o verbo X-MS-ENUMATTS. Para fazer isso, execute as seguintes etapas:
  1. Inicie o bloco de notas e, em seguida, abra o arquivo URLScan.ini.

    Observação O arquivo URLScan.ini está localizado na seguinte pasta:
    %Windir%\System32\Inetsrv\Urlscan
  2. Localize a seção [AllowVerbs] do arquivo. A seção [AllowVerbs] é semelhante à seguinte:
    [AllowVerbs]
    ;
    Os verbos (também conhecidos como métodos HTTP) listados aqui são aqueles comumente; processadas por um servidor IIS típico.
    ;
    Observe que essas entradas são eficazes se "UseAllowVerbs = 1" está definido na seção [Options] acima.
    ;
    OBTER
    CABEÇA
    POST
  3. Em uma linha separada após POST , adicione as seguintes linhas:
    ;Below Verb used to Allow Attachments
    X-MS-ENUMATTS
  4. Clique em Salvar no menu arquivo .
  5. Redefina o Microsoft Internet Information Services (IIS). Para fazer isso, clique em Iniciar , clique em Executar , digite iisreset na caixa Abrir e, em seguida, clique em OK .

Mais Informações

Para obter mais informações sobre a ferramenta de segurança UrlScan, visite o seguinte site:
http://technet.microsoft.com/en-us/security/cc242650.aspx (http://technet.microsoft.com/en-us/security/cc242650.aspx)
Para obter informações adicionais sobre como usar a ferramenta URLScan em um ambiente do Exchange Server, clique no número abaixo para ler o artigo na Base de dados de Conhecimento da Microsoft:
823175  (http://support.microsoft.com/kb/823175/ ) Problemas conhecidos e ajuste fino quando você usa o utilitário URLScan em um ambiente do Exchange 2003
Quando você vincula uma biblioteca de documentos no Windows SharePoint Services com uma pasta pública armazenada no Exchange, documentos que são anexados a mensagens na pasta pública de email podem ser inseridos automaticamente na biblioteca de documentos. Para obter informações adicionais sobre como trabalhar com bibliotecas de documentos habilitadas email no Windows SharePoint Services, consulte o tópico "Configurando bibliotecas de documentos habilitadas email" na seção "Configuração" do Windows SharePoint Services 2.0 guia do administrador do Microsoft . Para obter o Windows SharePoint Services 2.0 guia do administrador do Microsoft , visite o seguinte site:
http://www.microsoft.com/downloads/details.aspx?FamilyID=a637eff6-8224-4b19-a6a4-3e33fa13d230&displaylang=en (http://www.microsoft.com/downloads/details.aspx?FamilyID=a637eff6-8224-4b19-a6a4-3e33fa13d230&amp;displaylang=en)
Ou, consulte o tópico "Configurando o correio ELETRÔNICO ativados bibliotecas de documentos" na seção "Gerenciando bibliotecas de documentos" o Microsoft SharePoint Portal Server 2003 guia do administrador do Office . O Guia de administração do Microsoft Office SharePoint Portal Server 2003 (do administrador Help.chm) está localizado na pasta documentos na pasta raiz do CD do SharePoint Portal Server 2003.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows® SharePoint Services
Palavras-chave: 
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Clique aqui para ver a versão em Inglês deste artigo: 892317  (http://support.microsoft.com/kb/892317/en-us/ )