FIX: The Page Properties dialog box does not work correctly when you disable the <base> tag in Microsoft Content Management Server 2002 Service Pack 1a

Article translations Article translations
Article ID: 892474 - View products that this article applies to.
This article has been archived. It is offered "as is" and will no longer be updated.
Expand all | Collapse all

On This Page

SYMPTOMS

When you disable the <base> tag in Microsoft Content Management Server 2002 Service Pack 1a (SP1a), the Page Properties dialog box does not work correctly. The <base> tag is generated by the RobotMetaTag control.

Note This symptom may occur after you apply the hotfix that is described in Microsoft Knowledge Base article 832348. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
832348 Internet Explorer for Macintosh screen refreshes when you click controls

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must have Content Management Server 2002 SP1a installed on your computer.

Restart requirement

You do not have to restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
  Date         Time   Size   File name
  -------------------------------------
  16-Dec-2004  02:20  9,493  Console.js
  16-Dec-2004  02:20  6,259  Windows.js

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Steps to reproduce the problem

  1. Install Content Management Server 2002 SP1a.
  2. Apply the hotfix that is described in Microsoft Knowledge Base article 832348.
  3. Use Microsoft Visual Studio .NET to create a new template.
  4. In new the template, disable the <base> tag. To do this, use one of the following methods:
    • In HTML view, delete the RobotMetaTag control from the template.
    • In the template, add the following code to the Page_Load event.
      RobotMetaTag1.RenderBaseHref = false
  5. Create a new posting that is based on the template that you created in step 3. Then, approve the new posting.
  6. In the Unpublished mode dialog box, click Page Properties.
  7. In the Page Properties dialog box, click Save.

    Note You are redirected to a URL that is not valid. Your Web browser searches for the template in the following location instead of in the correct location:
    http://servername/NR/exeres/

Properties

Article ID: 892474 - Last Review: October 27, 2013 - Revision: 2.2
APPLIES TO
  • Microsoft Content Management Server 2002 Service Pack 1a
Keywords: 
kbnosurvey kbarchive kbautohotfix kbqfe kbhotfixserver kbbug kbfix kbcontentmgtserv2002sp2fix kbcontentmgtserv2002presp2fix KB892474

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com