Article ID: 892499 - Last Review: December 3, 2007 - Revision: 1.7

FIX: Some virtual directory configuration information may be lost and event ID 51260 may be logged on your computer that is running Internet Information Services 6.0

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SYMPTOMS

Some virtual directory configuration information may be lost on your computer that is running Microsoft Internet Information Services (IIS) 6.0. For example, the virtual directory name may unexpectedly change to a different name. When this problem occurs, the virtual directory may experience lost configuration information such as lost authentication and access information and lost IP address restrictions. Additionally, the following event may be logged to the System log on your IIS 6-based computer:

Event Type: Warning
Event Source: IIS Config
Event Category: Catalog
Event ID: 51260
Description:
A child node without a properly formed parent node was found. Ignoring it. Check spelling and format of location properties./LM/W3SVC/1/ROOT/VirtualDirectoryName/VirtualSubDirectoryName ErrorCode : 0x0000000D

CAUSE

This problem occurs when the following conditions are true:
  • You create two virtual directories on your computer that is running IIS.
  • The virtual directories that you create have similar names. However, one virtual directory name includes a dash character ("-") or an apostrophe character ("'"). For example, you create one virtual directory that is named Sub1, and then you create another virtual directory that is named Sub-1.
  • You restart your computer that is running IIS.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, 32-bit versions
   Date         Time   Version       Size       File name
   ---------------------------------------------------------
   25-Jan-2005  16:32  6.0.3790.256  1,124,352  Iiscfg.dll       
   25-Jan-2005  16:32  6.0.3790.256    223,744  Metadata.dll     
Windows Server 2003, Enterprise Edition for Itanium-based Systems
   Date         Time   Version       Size       File name
   ---------------------------------------------------------
   25-Jan-2005  16:28  6.0.3790.256  1,572,352  Iiscfg.dll
   25-Jan-2005  16:28  6.0.3790.256    578,048  Metadata.dll

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Steps to reproduce the behavior

  1. Click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
  2. Expand the computer that is running IIS that you want, and then expand Web Sites.
  3. Right-click the Web site that you want, point to New, click Virtual Directory, type sub1 in the text box, click Next, click Browse, locate the folder that you want, click Next two times, and then click Finish.
  4. Right-click sub1, point to New, click Virtual Directory, type test in the text box, click Next, click Browse, locate the folder that you want, click Next two times, and then click Finish.
  5. Right-click the Web site that you chose in step 3, point to New, click Virtual Directory, type sub-1 in the text box, click Next, click Browse, locate the folder that you want, click Next two times, and then click Finish.
  6. Right-click sub-1, point to New, click Virtual Directory, type test in the text box, click Next, click Browse, locate the folder that you want, click Next two times, and then click Finish.
  7. Restart IIS. To do this, right-click the computer that is running IIS, and then click Restart IIS.
  8. After IIS restarts, quit Internet Information Services (IIS) Manager.

APPLIES TO
  • Microsoft Internet Information Services 6.0
Keywords: 
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