Artigo: 892500 - Última revisão: segunda-feira, 10 de Abril de 2006 - Revisão: 3.1

Os programas que utilizam o DCOM não funcionam correctamente depois de instalar o Microsoft Windows Server 2003 Service Pack 1

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Importante: este artigo contém informações sobre como modificar o registo. Antes de modificar o registo, certifique-se de que efectua uma cópia de segurança e de que compreende como o pode restaurar se ocorrer um problema. Para obter informações sobre como efectuar uma cópia de segurança, restaurar e editar o registo, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registo do Microsoft Windows

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Sintomas

Depois de instalar o Microsoft Windows Server 2003 Service Pack 1 (SP1), os programas que utilizam o DCOM não funcionam correctamente. Por exemplo, se o servidor no qual instalou o Windows Server 2003 SP1 também for um servidor de cópia de segurança, o Veritas Backup Exec 8.6 pára e não consegue efectuar tarefas de cópia de segurança.

Causa

Este problema ocorre porque as permissões predefinidas do COM (Component Object Model) foram alteradas no Windows Server 2003 SP1. As novas permissões do COM restringem chamadas remotas que não sejam autenticadas. O programa COM pode funcionar localmente, mas as chamadas remotas que não sejam autenticadas falharão. Por predefinição, apenas os membros do grupo de administradores têm a permissão de activação remota e as permissões de início. Esta alteração impede que as contas de utilizador que não pertençam ao grupo de administradores iniciem componentes COM.

Resolução

Antes de seguir os passos desta secção que descrevem como resolver este problema, deverá confirmar primeiro a existência deste problema de permissões.

Confirmar a existência do problema de permissões

Aviso: a utilização incorrecta do Editor de registo poderá provocar problemas graves que poderão forçar a reinstalação do sistema operativo. A Microsoft não garante que os problemas resultantes da utilização incorrecta do Editor de registo possam ser resolvidos. Todo e qualquer risco decorrente da utilização do Editor de registo é da responsabilidade do utilizador.

Pode confirmar se tem este problema de permissões activando o registo de erros DCOM. Pode activar o registo de erros alterando o registo e reiniciando o processo DCOM que pretende examinar. O processo DCOM que pretende examinar determina se é necessário reiniciar o computador. Para activar o registo de erros DCOM, siga estes passos:
  1. Clique em Iniciar, clique em Executar, escreva regedit e clique em OK.
  2. Localize a subchave de registo
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole
    .
  3. Clique com o botão direito do rato no valor Ole, aponte para Novo e clique em Valor DWORD.
  4. Escreva ActivationFailureLoggingLevel e prima ENTER. Faça duplo clique em ActivationFailureLoggingLevel, escreva 1 na caixa Dados do valor e clique em OK.
  5. Clique com o botão direito do rato no valor Ole, aponte para Novo e clique em Valor DWORD.
  6. Escreva CallFailureLoggingLevel e prima ENTER. Faça duplo clique em CallFailureLoggingLevel, escreva 1 na caixa Dados do valor e clique em OK.
  7. Reinicie o programa DCOM e verifique se existem erros DCOM no registo de sistema e de aplicações.
As mensagens de erro do registo de eventos contêm informações que pode utilizar para ajudar a resolver o problema de permissões.

Pode desactivar o registo de erros DCOM alterando o valor ActivationFailureLoggingLevel e o valor CallFailureLoggingLevel para zero.

Resolver o problema de permissões

Se confirmar que tem este problema de permissões, resolva-o seguindo estes passos:
  1. Clique em Iniciar, aponte para Ferramentas administrativas e clique em Serviços componentes.
  2. Expanda o contentor Serviços componentes\Computadores.
  3. Clique com o botão direito do rato em O meu computador e clique em Propriedades.
  4. No separador Segurança COM, clique em Editar limites na área Permissões de lançamento e activação ou na área Activação remota. A área depende da localização do problema.
  5. Clique na conta especificada no erro do registo de eventos e clique em Permitir para as permissões Acesso remoto ou Arranque remoto e Activação remota.
  6. Clique em OK duas vezes para aceitar as alterações. Em seguida, experimente utilizar o programa que usa o DCOM.

Ponto Da Situação

Este comportamento ocorre por predefinição.

Mais Informação

Os produtos de outros fabricantes referidos neste artigo são fabricados por empresas independentes da Microsoft. A Microsoft não concede nenhuma garantia, implícita ou de outra natureza, relativamente ao desempenho ou à fiabilidade destes produtos.

Para obter informações sobre como contactar a Veritas, clique no número de artigo adequado na lista que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
65416  (http://support.microsoft.com/kb/65416/ ) Hardware and software vendor contact information, A-K

60781  (http://support.microsoft.com/kb/60781/ ) Hardware and software vendor contact information, L-P

60782  (http://support.microsoft.com/kb/60782/ ) Hardware and software vendor contact information, Q-Z

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Service Pack 1
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