ID do artigo: 892500 - Última revisão: terça-feira, 31 de maio de 2005 - Revisão: 2.1

Programas que usam DCOM não funcionam corretamente após a instalação do Microsoft Windows Server 2003 Service Pack 1

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Importante Este artigo contém informações sobre como modificar o Registro. Antes de modificá-lo, faça um backup e certifique-se de que sabe como restaurá-lo caso ocorra algum problema. Para obter informações adicionais sobre como fazer backup, restaurar e editar o Registro, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento da Microsoft.
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do Registro do Microsoft Windows

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Sintomas

Após a instalação do Microsoft Windows Server 2003 Service Pack 1 (SP1), os programas que usam DCOM não funcionam corretamente. Por exemplo, se o servidor em que o Windows Server 2003 SP1 está instalado também for um servidor de backup, o Veritas Backup Exec 8.6 pára e não consegue realizar as tarefas de backup.

Causa

Esse problema ocorre porque as permissões Modelo de objeto componente (COM) padrão são alteradas no Windows Server 2003 SP1. As novas permissões COM restringem chamadas remotas que não são autenticadas. O programa COM pode funcionar localmente, mas as chamadas remotas não autenticadas falham. Por padrão, somente os membros do grupo Administradores têm as permissões Ativação remota e de Inicialização. Essa alteração impede que as contas de usuário não pertencentes ao grupo Administradores iniciem componentes COM.

Resolução

Antes de executar as etapas desta seção que descrevem como resolver esse problema, primeiro é necessário confirmar se você está enfrentando esse problema com as permissões.

Confirmar se você está enfrentando esse problema com as permissões

Aviso O uso incorreto do Editor do Registro pode causar sérios problemas que talvez exijam a reinstalação do sistema operacional. A Microsoft não garante que os problemas resultantes do uso incorreto do Editor do Registro possam ser solucionados. O uso do Editor do Registro é de sua responsabilidade.

É possível confirmar se você está enfrentando esse problema com as permissões ativando o log de erros DCOM. É possível ativar o log de erros alterando o registro e reiniciando o processo DCOM que você deseja examinar. O processo DCOM a ser examinado determina se a necessidade de reiniciar o computador. Para ativar o log de erros DCOM, execute estas etapas:
  1. Clique em Iniciar e em Executar, digite regedit e clique em OK.
  2. Localize a subchave de registro
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole
    .
  3. Clique com o botão direito do mouse no valor Ole, aponte para Novo e clique em Valor DWORD.
  4. Digite ActivationFailureLoggingLevel e pressione ENTER. Clique duas vezes em ActivationFailureLoggingLevel, digite 1 na caixa Dados do valor e clique em OK.
  5. Clique com o botão direito do mouse no valor Ole, aponte para Novo e clique em Valor DWORD.
  6. Digite CallFailureLoggingLevel e pressione ENTER. Clique duas vezes em CallFailureLoggingLevel, digite 1 na caixa Dados do valor e clique em OK.
  7. Reinicie o programa DCOM e examine os logs do sistema e do aplicativo em busca de erros DCOM.
As mensagens de erro no log de eventos contêm informações que podem ser usadas para ajudar a resolver o problema com as permissões.

É possível desativar o log de erros DCOM alterando o valor ActivationFailureLoggingLevelCallFailureLoggingLevel para zero.

Resolver o problema com as permissões

Caso haja a confirmação de que você está enfrentando esse problema com as permissões, resolva-o executando estas etapas:
  1. Clique em Iniciar, aponte para Ferramentas administrativas e clique em Serviços de componentes.
  2. Expanda o recipiente Serviços de componentes\Computadores.
  3. Clique com o botão direito do mouse em Meu computador e clique em Propriedades.
  4. Na guia Segurança COM, clique em Editar limites nas áreas Permissões de acesso ou Permissões de inicialização e ativação. A área depende de onde o problema ocorre.
  5. Clique na conta especificada no erro do log de eventos e em Permitir para as permissões Acesso remoto.
  6. Clique em OK duas vezes para aceitar as alterações. Em seguida, tente iniciar o programa que usa DCOM.

Situação

Esse comportamento é próprio do projeto.

Mais Informações

Os outros produtos mencionados neste artigo são produzidos por empresas independentes da Microsoft. A Microsoft não oferece garantia, implícita ou não, em relação ao desempenho ou à confiabilidade desses produtos.

Para obter informações adicionais sobre como entrar em contato com a Veritas, clique no número apropriado na seguinte lista para ler o artigo na Base de Dados de Conhecimento da Microsoft:
65416  (http://support.microsoft.com/kb/65416/ ) Lista de informações para contato de fornecedores de hardware e software de terceiros, de A a K

60781  (http://support.microsoft.com/kb/60781/ ) Informações para contato de fornecedores de hardware e software de terceiros, de L a P

60782  (http://support.microsoft.com/kb/60782/ ) Informações para contato de fornecedores de hardware e software de terceiros, de Q a Z

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003 Service Pack 1
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