Makale numarası: 892500 - Son Gözden Geçirme: 31 Ocak 2006 Salı - Gözden geçirme: 3.4

Microsoft Windows Server 2003 Service Pack 1'i yükledikten sonra DCOM'u kullanan programlar doğru çalışmıyor

Sistem İpucuBu makale, kullandığınızdan farklı bir işletim sistemine yöneliktir. Sizinle ilgili olmayabilecek makale içeriği devre dışı bırakıldı.
Önemli Bu makale, kayıt defterini değiştirmeyle ilgili bilgiler içermektedir. Kayıt defterini değiştirmeden önce, yedeklediğinizden ve bir sorun çıkması durumunda kayıt defterini nasıl geri yükleyeceğinizi anladığınızdan emin olun. Kayıt defterini yedekleme, geri yükleme ve düzenleme ile ilgili bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki makale numarasını tıklatın:
256986  (http://support.microsoft.com/kb/256986/ ) Microsoft Windows Kayıt Defteri'nin Açıklaması

Bu Sayfada

Hepsini aç | Hepsini kapa

Belirtiler

Microsoft Windows Server 2003 Service Pack 1'i (SP1) yükledikten sonra, DCOM'u kullanan programlar doğru çalışmaz. Örneğin Windows Server 2003 SP1'i üzerine yüklediğiniz sunucu aynı zamanda bir yedekleme sunucusuysa, Veritas Backup Exec 8.6 yanıt vermez ve yedekleme görevlerini çalıştıramaz.

Neden

Bu sorun, varsayılan Bileşen Nesne Modeli (COM) izinleri Windows Server 2003 SP1'de değiştirildiği için oluşur. Yeni COM izinleri yetkisiz uzak çağrıları sınırlandırır. COM programı yerel olarak çalışabilir ama kimliği doğrulanmamış uzak çağrılar başarısız olur. Varsayılan olarak, yalnızca Yöneticiler grubunun üyelerinin Uzaktan Etkinleştirme izni ve Başlatma izinleri vardır. Bu değişiklik, Yöneticiler grubuna ait olmayan kullanıcı hesaplarının COM bileşenlerini başlatmasına engel olur.

Çözüm

Sorunun nasıl giderileceğini açıklayan bu bölümdeki adımları uygulamadan önce, bu izin sorunuyla karşılaştığınızdan emin olmalısınız.

Bu izin sorunuyla karşılaştığınızdan emin olma

Uyarı Kayıt Defteri Düzenleyicisi'ni yanlış kullanırsanız, işletim sisteminizi yeniden yüklemenizi gerektirebilecek ciddi sorunlara neden olabilirsiniz. Microsoft, Kayıt Defteri Düzenleyicisi'nin yanlış kullanımı sonucunda ortaya çıkan sorunları çözebileceğiniz konusunda garanti vermez. Kayıt Defteri Düzenleyicisi’ni kullanmak kendi sorumluluğunuzdadır.

DCOM hata günlüğünü etkinleştirerek bu izin sorununu yaşayıp yaşamadığınızı anlayabilirsiniz. Kayıt defterini değiştirip, sonra da incelemek istediğiniz DCOM işlemini yeniden başlatarak hata günlüğünü etkinleştirebilirsiniz. İncelemek istediğiniz DCOM işlemi bilgisayarı yeniden başlatmak zorunda olup olmadığınızı belirler. DCOM hata günlüğünü etkinleştirmek için, aşağıdaki adımları izleyin:
  1. Başlat'ı tıklatın, Çalıştır'ı tıklatın, regedit yazın ve Tamam'ı tıklatın.
  2. HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Ole
    kayıt defteri alt anahtarını bulun.
  3. Ole değerini sağ tıklatın, Yeni'nin üzerine gelin ve DWORD Değeri'ni tıklatın.
  4. ActivationFailureLoggingLevel yazın ve ENTER tuşuna basın. ActivationFailureLoggingLevel değerini çift tıklatın, Değer verisi kutusuna 1 yazın ve Tamam'ı tıklatın.
  5. Ole değerini sağ tıklatın, Yeni'nin üzerine gelin ve DWORD Değeri'ni tıklatın.
  6. CallFailureLoggingLevel yazın ve ENTER tuşuna basın. CallFailureLoggingLevel değerini çift tıklatın, Değer verisi kutusuna 1 yazın ve Tamam'ı tıklatın.
  7. DCOM programını yeniden başlatın ve Sistem günlüğü ile DCOM hatalarının Uygulama günlüğünü inceleyin.
Olay günlüğündeki hata iletileri, izin sorununu gidermeye yardımcı olmak için kullanabileceğiniz bilgileri içerir.

ActivationFailureLoggingLevel ve CallFailureLoggingLevel değerlerini sıfıra değiştirerek DCOM hata günlüğünü devre dışı bırakabilirsiniz.

İzin sorununu giderme

İzin sorununu yaşadığınızdan emin olursanız, aşağıdaki adımları izleyerek izin sorununu çözümleyin:
  1. Başlat'ı tıklatın, Yönetimsel Araçlar'ın üzerine gidin ve sonra da Bileşen Hizmetleri'ni tıklatın.
  2. Bileşen Hizmetleri\Bilgisayarlar kapsayıcısını genişletin.
  3. Bilgisayarım'ı sağ tıklatın ve sonra Özellikler'i tıklatın.
  4. COM Güvenliği sekmesinde, Başlatma ve Etkinleştirme İzinleri alanında veya Uzaktan Etkinleştirme alanında Sınırları Düzenle'yi tıklatın. Bu alan, sorunun oluştuğu yere göre değişir.
  5. Olay günlüğü hatasında belirtilen hesabı tıklatın ve Uzaktan Erişim izinleri veya Uzaktan Başlatma ve Uzaktan Etkinleştirme izinleri için İzin ver'i tıklatın.
  6. Değişiklikleri kabul etmek için iki kez Tamam'ı tıklatın. Ardından, DCOM'u kullanan programı kullanmayı deneyin.

Durum

Bu davranış, tasarımdan kaynaklanır.

Daha fazla bilgi

Bu makalede adı geçen üçüncü taraf ürünleri Microsoft'tan bağımsız şirketler tarafından üretilmektedir. Microsoft bu ürünlerin performansı veya güvenilirliği ile ilgili örtük veya başka türlü hiçbir garanti vermez.

Veritas'a başvurma konusunda bilgi için, Microsoft Bilgi Bankası'ndaki makaleyi görüntülemek üzere aşağıdaki uygun makale numarasını tıklatın:
65416  (http://support.microsoft.com/kb/65416/ ) Donanım ve yazılım satıcıları iletişim bilgileri, A-K

60781  (http://support.microsoft.com/kb/60781/ ) Donanım ve yazılım satıcıları iletişim bilgileri, L-P (Bu bağlantı, bir kısmı veya tamamı İngilizce olan içeriğe işaret edebilir.)

60782  (http://support.microsoft.com/kb/60782/ ) Donanım ve yazılım satıcıları iletişim bilgileri, Q-Z (Bu bağlantı, bir kısmı veya tamamı İngilizce olan içeriğe işaret edebilir.)

Bu makaledeki bilginin uygulandığı durum:
  • Microsoft Windows Server 2003 Service Pack 1
Anahtar Kelimeler: 
kbdcom kbcomservices kbcominterop kbclientprotocols kbclient kbinterop kbtshoot KB892500