Sounds do not play after you resume Windows from hibernation on a computer that is running Windows XP Service Pack 2

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Article ID: 892559
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SYMPTOMS

On a computer that is running Microsoft Windows XP Service Pack 2 (SP2), sounds do not play after you resume Windows from hibernation.

If you restart the computer, Windows plays sounds as you expect.

CAUSE

This problem occurs because a race condition exists in the Portcls.sys driver. This driver is a Windows Audio Class driver. A race scenario may occur when the following conditions are true:
  • The Portcls.sys driver receives an IRP_MJ_DEVICE_CONTROL request after Windows resumes from hibernation.
  • The Portcls.sys driver has not yet returned to the PowerDeviceD0 (D0) power state.

    Note A device that is Advanced Configuration and Power Interface (ACPI) compliant has four power states. The D0 state represents the working power state. The D1 through D3 power states represent the sleeping power states.
In this scenario, the Portcls.sys driver may mark the control I/O request packet (IRP) as STATUS_PENDING. However, it never completes the IRP. The upper-level components in the Audio stack that wait for this IRP to be completed block all additional audio requests. Therefore, audio files do not play after you resume Windows from hibernation.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Mar-2005  03:43  5.1.2600.2637     145,920  Portcls.sys
   25-Feb-2005  03:53  6.1.22.4          371,936  Updspapi.dll 

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Related Information:

Troubleshooter: No audio in Windows

Music and sound help with Windows 7

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Article ID: 892559 - Last Review: October 9, 2011 - Revision: 4.0
Keywords: 
kbautohotfix kbqfe kbHotfixServer KB892559

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