No se reproducen sonidos después de reanudar Windows desde la hibernación en un equipo que ejecuta Windows XP Service Pack 2

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Síntomas

En un equipo que ejecuta Microsoft Windows XP Service Pack 2 (SP2), sonidos no se reproducen después de reanudar Windows desde la hibernación.

Si reinicia el equipo, Windows reproduce sonidos como espera.

Causa

Este problema se produce porque existe una condición de anticipación en el controlador Portcls.sys. Este controlador es un controlador de clase de audio de Windows. Un escenario de anticipación puede producirse cuando se cumplen las condiciones siguientes:
  • El controlador Portcls.sys recibe una solicitud IRP_MJ_DEVICE_CONTROL cuando Windows se reanuda desde la hibernación.
  • El controlador Portcls.sys aún no ha devuelto a PowerDeviceD0 el estado de energía (D0).

    Nota Un dispositivo de Advanced Configuration interfaz y energía (ACPI) compatible con tiene cuatro estados de energía. El estado D0 representa el estado de energía de trabajo. La D1 a través de los estados de energía de D3 representan los estados inactivo de energía.
En este escenario, el controlador Portcls.sys puede marcar el paquete de solicitud de E/s (IRP) de control como STATUS_PENDING. Sin embargo, nunca completa el IRP. Los componentes de nivel superior en la pila de audio que esperar a que este IRP completar bloquean todas las solicitudes de audio adicionales. Por tanto, los archivos de audio no se reproducen después de reanudar Windows desde la hibernación.

Solución

Información de revisiones

Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema que se describe en este artículo. Esta revisión sólo se aplican a los sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por tanto, si no se ve muy afectado por este problema, recomendamos que espere la próxima actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, hay una sección de "Descarga de revisión disponible" en la parte superior de este artículo de Knowledge Base. Si esta sección no aparece, póngase en contacto con el servicio de atención al cliente y soporte técnico para obtener la revisión.

Nota Si se producen problemas adicionales o si se requiere cualquier solución de problemas, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no reúnan las condiciones necesarias para esta revisión específica. Para obtener una lista completa de servicio de atención al cliente y soporte números de teléfono o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponible" muestra los idiomas para el que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para buscar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria en la herramienta fecha y hora en el panel de control.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   22-Mar-2005  03:43  5.1.2600.2637     145,920  Portcls.sys
   25-Feb-2005  03:53  6.1.22.4          371,936  Updspapi.dll 

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Music and sound help with Windows 7
No audio in Windows Vista
No audio device error message in Windows Vista
Sound problems in Windows XP

Propiedades

Id. de artículo: 892559 - Última revisión: miércoles, 29 de agosto de 2007 - Versión: 2.4
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
Palabras clave: 
kbmt kbautohotfix kbqfe kbhotfixserver KB892559 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 892559

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