Article ID: 892891 - Last Review: June 16, 2009 - Revision: 2.0

You receive an "Access is denied" error message when you install the Bluetooth stack and detect a Bluetooth device in Microsoft Windows XP Service Pack 2

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SYMPTOMS

When you install the Microsoft Bluetooth stack and detect a Bluetooth device in Microsoft Windows XP Service Pack 2 (SP2), you receive an "Access is denied" error message. Additionally, your computer cannot configure the Bluetooth device.

CAUSE

This problem may occur if you connect a Bluetooth device to the computer, and if there is a conflict between the device and some other device that is installed on the computer. For example, aA conflict can occur if the Atheros wireless local area network (LAN) adapter is installed.

This problem may also occur if the Windows security database is corrupted. The database may become corrupted the first time that you start your computer after you upgrade to Windows XP SP2, or the first time that you start a computer that has Windows XP SP2 installed. If you install the Bluetooth stack when the Windows security database is corrupted, the wrong user right is set to the registry key that is required to configure the Bluetooth device. Therefore, the Bluetooth device does not configure correctly.

WORKAROUND

To work around this problem, use one of the following methods.

Method 1: Perform a clean restart

You may have to perform a clean restart to avoid a software conflict that occurs at startup. This conflict can occur because some programs start automatically and run in the background when you start Windows in the usual manner. These programs may include system utilities that can interfere with the installation of the Bluetooth device.

To perform a clean restart, click the following article numbers to view the articles in the Microsoft Knowledge Base:
310353  (http://support.microsoft.com/kb/310353/ ) How to configure Windows XP to start in a "clean boot" state
Note This article includes Guided Help.
929135  (http://support.microsoft.com/kb/929135/ ) How to troubleshoot a problem by performing a clean boot in Windows Vista

Method 2: Determine whether the Windows security database is corrupted

Verify the status of the Windows security database

To determine whether the Windows security database is corrupted, follow these steps:
  1. Click Start, click Run, type cmd, and then click OK.
  2. At the command prompt, type
    esentutl /g %windir%\security\database\secedit.sdb
    You should receive output that resembles the following output:
    Microsoft(R) Windows(TM) Database Utilities
    Version 5.1
    Copyright (C) Microsoft Corporation. All Rights Reserved.
    
    Initiating INTEGRITY mode...
            Database: C:\WINDOWS\security\database\secedit.sdb
      Temp. Database: TEMPINTEG1704.EDB
    
    Checking database integrity.
    
                         Scanning Status (% complete)
    
              0    10   20   30   40   50   60   70   80   90  100
              |----|----|----|----|----|----|----|----|----|----|
              ...................................................
    
    
    Integrity check successful.
    
    Operation completed successfully in 1.592 seconds.
    
    If the Windows security database is corrupted, the output will contain the following line:
    This operation may find that this database is corrupt.

Repair a corrupted Windows security database

If the Windows security database is corrupted, you can repair the database. To do this, follow these steps:
  1. Follow these steps, depending on the location of the Edb.log file and the Edb.chk file:
    • If both the Edb.log file and the Edb.chk file are in the %windir%\security directory, follow these steps to repair the security database:
      1. Click Start, click Run, type cmd, and then click OK.
      2. At the command prompt, type the following command:
        esentutl /r edb /l %windir%\security /s %windir%\security
    • If either the Edb.log file or the Edb.chk file is in the C:\WINDOWS\security directory, or if neither file exists in the directory, follow these steps to repair the security database:
      1. Click Start, click Run, type cmd, and then click OK.
      2. At the command prompt, type the following command:
        esentutl /p %windir%\security\Database\secedit.sdb
      3. Click OK when you receive the following message:
        You should only run Repair on damaged or corrupted databases. Repair will not apply information in the transaction log files on the database, and may cause information to be lost. Do you wish to proceed?
  2. After you repair the security database, follow these steps to modify the registry so that you can access the registry key that is required to configure the Bluetooth device:
    1. Create a text file that is named bt.inf and that contains the following text.
        [version]
        signature="$CHICAGO$"
        revision=1
        DriverVer=07/01/2001,5.1.2600.1106
      
        [Registry Keys]
        "MACHINE\SYSTEM\CurrentControlSet\Services\BTHPORT",0,"D:AR(A;CI;GRGW;;;PU)(A;CI;GRGW;;;LS)"
      
    2. Save the bt.inf file to the root directory of the drive that contains the operating system. For example, save the file to drive C so that it has the following full path:
      C:\bt.inf
    3. Click Start, click Run, type cmd, and then click OK.
    4. At the command prompt, type the following command:
      secedit /configure /cfg C:\bt.inf /db C:\bt.sdb
      Note In this command, C represents the drive letter that you used in step b.
    5. Delete the C:\bt.inf file and the C:\bt.sdb file.
Note Before you follow the steps that are outlined in this article, verify that the Bluetooth Support service has been started and that the Bluetooth Support service is configured to use the local administrator account. For more information about how to troubleshoot the Bluetooth Support service, click the following article number to view the article in the Microsoft Knowledge Base:
894035  (http://support.microsoft.com/kb/894035/ ) The Bluetooth Devices item is not present when you open Control Panel

MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
884018   (http://support.microsoft.com/kb/884018/ ) You cannot add a Windows component in Windows XP

APPLIES TO
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
Keywords: 
kbregistration kberrmsg kbprb KB892891