Não é possível iniciar sessão no Windows XP depois de remover o Wsaupdater.exe

Traduções de Artigos Traduções de Artigos
Artigo: 892893 - Ver produtos para os quais este artigo se aplica.
Importante: este artigo contém informações sobre como modificar o registo. Antes de modificar o registo, certifique-se de que efectua uma cópia de segurança e de que compreende como o pode restaurar se ocorrer um problema. Para obter informações sobre como efectuar uma cópia de segurança, restaurar e editar o registo, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
256986 Descrição do registo do Microsoft Windows
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Depois de remover o Wsaupdater.exe de BlazeFind utilizando a compilação 181 do Ad-Aware 6 e o ficheiro de referência 01R314 02.06.2004 ou 01R320 19.06.2004, não é possível iniciar sessão no Microsoft Windows XP.

Nota: BlazeFind é um objecto auxiliar do Internet Explorer que redirecciona e altera as definições do Internet Explorer.

Causa

O Wsaupdater.exe é spyware que altera o Userinit.exe, para Wsaupdater.exe no registo. O Ad-Aware da Lavasoft remove o ficheiro Wsaupdater.exe do computador, mas não consegue alterar a subchave de registo novamente para Userinit.exe,. A subchave de registo que é alterada é
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon

Valor: Userinit
Dados: %Windir%\System32\Wsaupdater.exe

Nota: %windir% representa a localização da pasta System32. Por exemplo, se a localização for C:\Windows\System32, os dados seriam C:\Windows\System32\Wsaupdater.exe.

Os dados deverão conter o Userinit.exe, em vez do Wsaupdater.exe. Tendo em conta o exemplo anterior, os dados seriam C:\Windows\System32\Userinit.exe,.

Nota: a vírgula a seguir ao caminho de ficheiro é necessária.

Resolução

Utilize a Consola de recuperação (Recovery Console) para copiar o Userinit.exe para o Wsaupdater.exe de forma a permitir o restauro da capacidade de início de sessão e que os dados do registo sejam corrigidos manualmente. Para o fazer, siga estes passos:

Utilizar a 'Consola de recuperação' para copiar o Userinit.exe para o Wsaupdater.exe

  1. Na linha de comandos da Consola de recuperação (Recovery Console), escreva cd system32 e prima ENTER.
  2. Escreva copy userinit.exe wsaupdater.exe e prima ENTER.
  3. Escreva exit e, em seguida, prima ENTER.

Modificar o registo

  1. Clique em Iniciar (Start), clique em Executar (Run), escreva regedit e clique em OK.
  2. No Editor de registo (Registry Editor), expanda
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
    .
  3. No painel da direita, clique com o botão direito do rato em userinit e clique em Modificar (Modify).
  4. Substitua wsaupdater.exe por userinit.exe, (certifique-se de que inclui a vírgula, conforme apresentado) e clique em OK.
  5. Reinicie o computador.

Eliminar o ficheiro Wsaupdater.exe

  1. Inicie sessão no computador utilizando uma conta com permissões de administrador.
  2. Clique em Iniciar (Start), clique em Executar (Run), escreva %Windir%\system32 e clique em OK.
  3. Clique com o botão direito do rato em wsaupdater.exe, clique em Eliminar (Delete) e clique em OK.
Para obter informações adicionais sobre a consola de recuperação do Windows, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
314058 Descrição da consola de recuperação do Windows XP

Mais Informação

Para obter informações adicionais, visite o seguinte Web site da Lavasoft:
http://www.lavasofthelp.com/articles/v6/04/06/0901.html

A Microsoft fornece informações sobre contactos de outros fabricantes para o ajudar na obtenção de suporte técnico. Estas informações de contacto poderão ser alteradas sem aviso prévio. A Microsoft não garante o rigor das informações sobre o contacto destes fabricantes.

Os produtos de outros fabricantes referidos neste artigo são fabricados por empresas independentes da Microsoft. A Microsoft não concede nenhuma garantia, implícita ou de outra natureza, relativamente ao desempenho ou à fiabilidade destes produtos.

Propriedades

Artigo: 892893 - Última revisão: 28 de março de 2005 - Revisão: 1.1
A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows XP Media Center Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Service Pack 1
  • Microsoft Windows XP Service Pack 2
Palavras-chave: 
kbtshoot kbprb KB892893

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com