FIX: You receive a 7619 error message when you run a full text query that contains certain Japanese character strings on an instance of SQL Server 2000 that is running on a Windows 2000-based computer

Article translations Article translations
Article ID: 892924 - View products that this article applies to.
Bug #: 149946 (Windows SE)
Expand all | Collapse all

On This Page

Article contents

SUMMARY

This article describes the following about this hotfix release:
  • The issues that are fixed by this hotfix package
  • The prerequisites for installing the hotfix package
  • Whether you must restart your computer after you install the hotfix package
  • Whether the hotfix package is replaced by any other hotfix package
  • Whether you must make any registry changes
  • The files that are contained in the hotfix package

SYMPTOMS

You are running an instance of Microsoft SQL Server 2000 on a Microsoft Windows 2000-based computer. When you run a full-text query that contains certain Japanese character strings in the search condition against the instance of SQL Server 2000, you may receive an error message that is similar to the following:
Server: Msg 7619, Level 16, State 1, Line 1
Execution of a full-text operation failed. A clause of the query contained only ignored words.
This error message indicates that a clause of the query contains only ignored words. However, the query that you tried to run does contain valid words.

For a list of previous hotfixes, see the "Microsoft SQL Server 2000 post-Service Pack 3 or Microsoft SQL Server 2000 post-Service Pack 3a hotfixes" section in the following Microsoft Knowledge Base article:
290211 How to obtain the latest SQL Server 2000 service pack

CAUSE

This issue occurs when some Japanese character strings are used in a full-text query. This condition causes an access violation in the Japanese language wordbreaker that is used by the Microsoft Search service (Mssearch.exe).

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

You must have Windows 2000 installed to apply this hotfix. There are no other prerequisites.

Restart information

You must stop the Microsoft Search service to apply this hotfix. You do not have to restart your computer after you apply this hotfix.

Hotfix file information

This hotfix contains only those files that are required to correct the issues that this article lists. This hotfix may not contain all the files that you must have to fully update a product to the latest build.

The Japanese version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version     Size    File name
   ---------------------------------------------------
   13-Feb-2005  23:03  3.0.1.4413  86,097  Msir2jp.dll
Note Because of file dependencies, the most recent hotfix that contains these files may also contain additional files.

STATUS

Microsoft has confirmed that this is a bug in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

Note Microsoft Windows Server 2003 uses a newer version of the Japanese language wordbreaker (Msir3jp.dll) to perform full-text queries. If you are running SQL Server 2000 on a Windows Server 2003-based computer, click the following article number to view the article in the Microsoft Knowledge Base:
885899 Full Text Search catalog creation fails when Japanese character strings are used
For more information about the naming schema for SQL Server updates, click the following article number to view the article in the Microsoft Knowledge Base:
822499 New naming schema for Microsoft SQL Server software update packages
For more information about the terminology that Microsoft uses when it corrects software after it is released, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 892924 - Last Review: November 2, 2007 - Revision: 1.8
APPLIES TO
  • Microsoft SQL Server 2000 Developer Edition, when used with:
    • the operating system: Microsoft Windows 2000
  • Microsoft SQL Server 2000 Enterprise Edition, when used with:
    • the operating system: Microsoft Windows 2000
  • Microsoft SQL Server 2000 Personal Edition, when used with:
    • the operating system: Microsoft Windows 2000
  • Microsoft SQL Server 2000 Standard Edition, when used with:
    • the operating system: Microsoft Windows 2000
  • Microsoft SQL Server 2000, Workgroup Edition, when used with:
    • the operating system: Microsoft Windows 2000
  • Microsoft SQL Server 2000 Enterprise Edition 64-bit, when used with:
    • the operating system: Microsoft Windows 2000
Keywords: 
kbautohotfix kbsqlserv2000presp4fix kbfix kbbug kbhotfixserver kbqfe KB892924

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com