REVISIÓN: "esta acción sólo es válida para productos instalados" mensaje de error después de instalar dos actualizaciones de software principales para un producto en Windows XP SP2 mediante Windows Installer 3.0

Seleccione idioma Seleccione idioma
Id. de artículo: 893048 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Después de instalar dos actualizaciones de software principales para un producto en Microsoft Windows XP Service Pack 2 (SP2), cualquier posteriores operaciones de instalación son incorrectas. Cuando se produce este problema, recibirá el siguiente mensaje de error:
Esta acción sólo es válida para productos actualmente instalados
Nota Una actualización de software incluye reparaciones, eliminaciones o aplicaciones de actualización de software adicional que aplica al producto. Una actualización importante es una actualización completa de un producto que justifica un cambio en la propiedad ProductCode .

Causa

Este problema se produce cuando Microsoft Windows Installer 3.0 intenta buscar el producto incorrecto. Este problema está causado por un error en la secuencia de actualización.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

Tendrá que reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y horas de estos archivos aparecen en la hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
Date          Time   Version        Size       File name
 --------------------------------------------------------------
25-Jan-2005   14:52  1.0.0.0       1,089,264   Windowsxp-kb893048-x86-enu.exe 
25-Jan-2005   14:50  1.0.0.0         929,520   Windowsxp-kb893048-x86-symbols-enu.exe
25-Jan-2005   17:12  3.0.3790.2601 2,804,736   Msi.dll
Nota El archivo de WindowsXP-kb893048-x 86-enu.exe es el instalador de revisión. El archivo de símbolos-86-enu.exe de WindowsXP-kb893048-x es el instalador para el archivo de símbolo de revisión que se denomina Msi.pdb. No es necesario instalar el archivo de símbolos-86-enu.exe kb893048-WindowsXP-x

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener información adicional, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 893048 - Última revisión: miércoles, 29 de agosto de 2007 - Versión: 4.1
La información de este artículo se refiere a:
  • Microsoft Windows Installer 3.0
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
  • Microsoft Windows XP Home Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Tablet PC Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
Palabras clave: 
kbmt kbautohotfix kbbug kbfix kbprb kbhotfixserver kbqfe KB893048 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 893048

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com