Windows 2000 Active Directory returns only 5,000 entries in response to an Outlook client query

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Article ID: 893354 - View products that this article applies to.
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Important This article contains information about modifying the registry. Before you modify the registry, make sure to back it up and make sure that you understand how to restore the registry if a problem occurs. For information about how to back up, restore, and edit the registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986 Description of the Microsoft Windows Registry
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SYMPTOMS

If a Microsoft Outlook client queries the Active Directory directory service, the maximum number of entries that are returned by the Active Directory is restricted to 5,000 entries.

Notes
  • Microsoft Windows 2000 Active Directory returns a maximum of 5,000 entries, regardless of the number of entries that are to be returned in response to a client’s query.
  • The client may not receive a warning message that states that the Active Directory search is restricted to a maximum of 5,000 entries.
  • Regardless of the registry setting on the client computer to request more than 5,000 entries, Active Directory returns a maximum of 5,000 entries.

CAUSE

This behavior occurs to improve the query response time for searches for Active Directory entries. To improve the query response time for searches, searches are limited to 5,000 entries in a Windows 2000 domain.

RESOLUTION

Warning If you use Registry Editor incorrectly, you may cause serious problems that may require you to reinstall your operating system. Microsoft cannot guarantee that you can solve problems that result from using Registry Editor incorrectly. Use Registry Editor at your own risk.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version         Size       File name
   -----------------------------------------------------------
   24-Mar-2004  02:17  5.0.2195.6876     388,368  Advapi32.dll
   24-Mar-2004  02:17  5.0.2195.6866      69,904  Browser.dll
   24-Mar-2004  02:17  5.0.2195.6824     134,928  Dnsapi.dll
   24-Mar-2004  02:17  5.0.2195.6876      92,432  Dnsrslvr.dll
   24-Mar-2004  02:17  5.0.2195.6883      47,888  Eventlog.dll
   24-Mar-2004  02:17  5.0.2195.6890     143,632  Kdcsvc.dll
   11-Mar-2004  02:37  5.0.2195.6903     210,192  Kerberos.dll
   21-Sep-2003  00:32  5.0.2195.6824      71,888  Ksecdd.sys
   15-Oct-2004  18:16  5.0.2195.6987     513,296  Lsasrv.dll
   25-Feb-2004  23:59  5.0.2195.6902      33,552  Lsass.exe
   11-Mar-2004  02:37  5.0.2195.6897     123,152  Msv1_0.dll
   10-Jun-2004  16:58  5.0.2195.6949     309,008  Netapi32.dll
   24-Mar-2004  02:17  5.0.2195.6891     371,472  Netlogon.dll
   02-Feb-2005  09:31  5.0.2195.7028     938,256  Ntdsa.dll
   24-Mar-2004  02:17  5.0.2195.6897     388,368  Samsrv.dll
   24-Mar-2004  02:17  5.0.2195.6893     111,376  Scecli.dll
   24-Mar-2004  02:17  5.0.2195.6903     253,200  Scesrv.dll
   28-Jan-2005  05:49  5.0.2195.7023   6,282,752  Sp3res.dll
   24-Mar-2004  02:17  5.0.2195.6824      50,960  W32time.dll
   21-Sep-2003  00:32  5.0.2195.6824      57,104  W32tm.exe

After you apply the hotfix

After you apply this hotfix, you must modify the 0003660d registry entry on the client computer. You must do this to enable the client to request more than 5,000 entries. To modify the 0003660d registry entry on the client computer, follow these steps:
  1. On the client computer, click Start, click Run, type regedit in the Open box, and then click OK.
  2. Locate and then click the following registry subkey:
    HKEY_CURRENT_USER\Software\Microsoft\Windows NT\CurrentVersion\Windows Messaging Subsystem\Profiles\ProfileName\13dbb0c8aa05101a9bb000aa002fc45a
  3. On the right pane, right-click 0003660d, and then click Modify.

    Note If the
    0003660d
    registry entry is not found, you have to create it. To create the
    0003660d
    registry entry, click New on the Edit menu, click REG_DWORD Value, and then type 0003660d.
  4. In the Value data box, type the maximum number of entries that you want the client to request. For example, type 10000 to enable the client to request 10,000 entries.

    Note After you apply the hotfix, the maximum number of entries that are returned by Active Directory is 10,000 entries.
  5. Click OK, and then quit Registry Editor.

STATUS

This behavior is by design.

MORE INFORMATION

For additional information about how hotfix packages are named, click the following article number to view the article in the Microsoft Knowledge Base:
816915 New file naming schema for Microsoft Windows software update packages
For additional information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 893354 - Last Review: October 27, 2013 - Revision: 1.5
APPLIES TO
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows 2000 Advanced Server
Keywords: 
kbnosurvey kbarchive kbautohotfix kbregistry kbactivedirectory kbbug kbfix kbwin2000presp5fix kbhotfixserver kbqfe KB893354

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