Artigo: 893652 - Última revisão: terça-feira, 27 de Novembro de 2007 - Revisão: 2.6

Recebe uma mensagem de erro "O programa de configuração encontrou um erro e não foi possível continuar" quando tenta actualizar um cliente do SMS 2003 avançadas para o SMS 2003 Service Pack 1

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
importante Este artigo contém informações sobre como modificar o registo. Antes de modificar o registo, certifique-se de que efectua uma cópia de segurança e de que compreende como o restaurar o registo se ocorrer um problema. Para obter informações sobre como efectuar uma cópia de segurança, restaurar e editar o registo, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Descrição do registo do Microsoft Windows
Expandir tudo | Reduzir tudo

Sintomas

Quando tenta actualizar um cliente do Microsoft Systems Management Server (SMS) 2003 avançadas para o SMS 2003 Service Pack 1 (SP1), é registado o seguinte erro no ficheiro Ccmsetup.log:
Installation failed with error code 1603
Se actualizar manualmente o cliente do SMS 2003 avançadas, receberá a seguinte mensagem de erro:
Configuração abortada

Falha na configuração

O programa de configuração encontrou um erro e não foi possível continuar.
Além disso, as informações seguintes são registadas no ficheiro \System32\Ccmsetup\Client.msi.log %WinDir%:
Action start 23:14:32: SmsValidateProductVersion.
[23:14:32] WARNING: Failed to get the version info for product {D8EF2D11-47CF-45E5-B423-47B29706DE12} (1608).
Windows Installer may contain invalid product registrations.
O GUID nesta mensagem de aviso representa a versão original do cliente SMS 2003 avançadas. Este problema ocorre em computadores cliente que executem o Microsoft Windows 2000 Server Service Pack 3 (SP3) ou Microsoft Windows 2000 Server Service Pack 4 (SP4).

Causa

Este problema ocorre se a subchave
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1- 5-18
é removida o cliente do SMS 2003 avançadas. Esta subchave contém informações sobre configuração de cliente do SMS 2003 avançadas.

Para obter mais informações sobre como pode ser eliminada a subchave S-1-5-18, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
890212  (http://support.microsoft.com/kb/890212/ ) Mensagem de erro "Esta aplicação tem de ser instalada antes de poder utilizar" quando tenta iniciar um programa que foi instalado utilizando o Windows Installer no Windows 2000

Resolução

Para resolver este problema de futuras instalações do cliente SMS 2003 avançadas, instale a correcção documentada no artigo de base de dados de conhecimento da Microsoft 890212. Em alguns casos, é possível reparar a instalação do cliente do SMS 2003 avançadas. No entanto, a Microsoft não garante que com êxito pode reparar uma instalação danificada do cliente do SMS 2003 avançadas. Por conseguinte, recomendamos que remova e reinstale o cliente avançado em computadores afectados.

Para tentar reparar a instalação do cliente do SMS 2003 avançadas, siga estes passos no cliente do SMS 2003 avançadas:
  1. Clique em Iniciar , clique em Executar , escreva cmd e, em seguida, clique em OK .
  2. Escreva o seguinte na linha de comandos e, em seguida, prima ENTER:
    msiexec.exe /I /qn C:\winnt\system32\ccmsetup\{9BE6F195-A36C-4584-919C-342B5A33E30D}\client.msi
Nota A pasta Ccmsetup listado no passo 2 existe apenas em computadores que tenham a versão original do SMS 2003 Advanced Client instalado. Esta pasta é removida após uma actualização com êxito para o SMS 2003 SP1. A Microsoft não garante que com êxito pode reparar uma instalação danificada do cliente do SMS 2003 avançadas.

Para obter mais informações sobre como remover o cliente avançado, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
826842  (http://support.microsoft.com/kb/826842/ ) Como remover um cliente do Systems Management Server 2003


Se a distribuição de software não funciona correctamente no danificado avançadas cliente do SMS 2003, pode remover remotamente o danificado Advanced Client. Para o fazer, utilize um das seguintes ferramentas para executar o programa Ccmclean.exe remotamente:
  • O programa de serviço remoto de comando (Rcmd.exe).Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
    151519  (http://support.microsoft.com/kb/151519/ ) Utilitário do Kit de recursos fornece a execução do comando remoto
  • Um programa de outros fabricantes, como o PsExec. O programa PSExec é incluído no pacote PsTools da Sysinternals. Para obter mais informações sobre o programa PsExec, visite o seguinte site de Sysinternals Web:
    http://technet.microsoft.com/en-us/sysinternals/default.aspx (http://technet.microsoft.com/en-us/sysinternals/default.aspx)
Ccmclean.exe é um componente do SMS 2003 Toolkit 2. Para mais informações sobre o SMS 2003 Toolkit 2, visite o seguinte Web site da Microsoft:
http://technet.microsoft.com/en-us/sms/bb676787.aspx (http://technet.microsoft.com/en-us/sms/bb676787.aspx)
Para utilizar o programa PsExec e o programa Ccmclean.exe para remover remotamente o Advanced Client, siga estes passos.

Nota Tem de ter permissões de administrador no cliente avançado.

aviso Se utilizar o Editor de registo incorrectamente, poderá provocar problemas graves que poderão forçar a reinstalação do sistema operativo. Microsoft não garante que os problemas resultantes da utilização incorrecta do Editor de registo possam ser resolvidos. As suas próprias risco da utilização do Editor de registo.
  1. Transferir o programa PsExec do site Sysinternal Web.
  2. Clique em Iniciar , clique em Executar , escreva notepad e, em seguida, clique em OK .
  3. Cole o seguinte texto no bloco de notas:
    Windows Registry Editor Version 5.00
    
    [-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SMS]
    
    [-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\CCM]
  4. Clique em ficheiro e, em seguida, clique em Guardar .
  5. Na caixa de texto nome do ficheiro , escreva removeSMSkeys.reg e, em seguida, clique em Guardar . Recomendamos que guardar este ficheiro numa pasta partilhada temporária na rede. Certifique-se que o cliente avançado pode aceder à pasta.
  6. Clique em Iniciar , clique em Executar , escreva cmd e, em seguida, clique em OK .
  7. Tipo psexec \\ client - c c:\ local path \ccmclean.exe /q , onde client é o nome do cliente avançado e local path é a pasta onde se encontra Ccmclean.exe. Este comando copia Ccmclean.exe para o cliente avançado e, em seguida, executa Ccmclean.exe no modo silencioso.
  8. Escreva psexec \\ client regedit.exe /s \\server\share \removeSMSkeys.reg , onde client é o nome do cliente avançado e server\share é a pasta de rede partilhada que contém o ficheiro .reg que criou nos passos 2 a 5. Este comando remotamente executa o ficheiro. reg. O ficheiro .reg remove as chaves SMS.

    aviso Não execute este comando em quaisquer servidores de site SMS. Se executar este comando num servidor de site SMS, danificará o servidor local.

Mais Informação

Para obter mais informações, clique no número de artigo que se segue para visualizar o artigo na Microsoft Knowledge Base:
890212  (http://support.microsoft.com/kb/890212/ ) Mensagem de erro "Esta aplicação tem de ser instalada antes de poder utilizar" quando tenta iniciar um programa que foi instalado utilizando o Windows Installer no Windows 2000
Os produtos de outros fabricantes explicado neste artigo são fabricados por empresas independentes da Microsoft. A Microsoft não oferece nenhuma garantia, expressa ou implícita, relativamente ao desempenho ou fiabilidade destes produtos. Microsoft fornece informações de contactos outros fabricantes para ajudar a encontrar suporte técnico. Poderá ser alterado estas informações de contacto sem aviso prévio. Microsoft não garante a precisão destas informações de contacto outros fabricantes.

A informação contida neste artigo aplica-se a:
  • Microsoft Systems Management Server 2003 Enterprise Edition nas seguintes plataformas
    • Microsoft Windows 2000 Service Pack 3
    • Microsoft Windows 2000 Server SP4
Palavras-chave: 
kbmt kbsmsinstall kbsmsdistribution kbsmsdeploy kbsmsclients kbtshoot kbregistry kbclient kberrmsg kbupgrade kbsetup kbinterop kbsoftwaredist KB893652 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 893652  (http://support.microsoft.com/kb/893652/en-us/ )