Como abrir documentos usando o recurso Abrir e reparar no Word

Traduções deste artigo Traduções deste artigo
ID do artigo: 893672 - Exibir os produtos aos quais esse artigo se aplica.
Expandir tudo | Recolher tudo

Neste artigo

INTRODUÇÃO

Esse artigo descreve como abrir documentos usando o recurso Abrir e reparar no Microsoft Office Word 2007, no Microsoft Office Word 2003 e no Microsoft Word 2002.

Mais Informações

O Microsoft Word automaticamente usará o recurso Abrir e reparar se o Word detectar um problema com um documento ao abri-lo. Entretanto, é possível forçar o Word a usar o recurso Abrir e reparar ao abrir qualquer documento. Isso pode ser especialmente útil quando você tiver a intenção de salvar o documento em um formato de arquivo diferente. Se você salvar um documento corrompido em um formato de arquivo diferente, pode não ser possível abrir o documento salvo. Para obter mais informações sobre como solucionar problemas de documentos do Word corrompidos, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
826864 Como solucionar problemas de documentos corrompidos do Word
Para abrir um documento usando o recurso Abrir e reparar no Word, use um dos seguintes métodos.

Método 1: Para abrir um documento específico

Para abrir um documento específico usando o recurso Abrir e reparar no Word, execute as seguintes etapas:
  1. Inicie o Word.
  2. No menu Arquivo, clique em Abrir.

    Observação No Word 2007, clique no Botão Office e em Abrir.
  3. Na caixa de diálogo Abrir, marque o arquivo que deseja abrir.
  4. Clique na seta para baixo no botão Abrir e clique em Abrir e reparar.

Método 2: Para abrir todos os documentos

A Microsoft fornece exemplos de programação apenas por questões ilustrativas, sem garantias expressas ou implícitas. Isto inclui, mas não está limitado a, garantias implícitas de comercialização ou adequação a um determinado propósito. Este artigo pressupõe que você conhece a linguagem de programação demonstrada e também as ferramentas usadas para criar e depurar procedimentos. Os engenheiros de suporte da Microsoft podem ajudá-lo, fornecendo a explicação da funcionalidade de um determinado procedimento, mas não modificarão estes exemplos para fornecer funcionalidades adicionais ou construir procedimentos específicos para atender às suas necessidades específicas. Para abrir todos os documentos usando o recurso Abrir e reparar no Word, substitua a macro interna FileOpen no Word por uma macro VBA. Para fazer isto, execute as seguintes etapas:
  1. Inicie o Word e abra um novo documento em branco.
  2. No Word 2007, clique em Macros no menu Desenvolvedor. No Word 2003, aponte para Macro no menu Ferramentas e clique em Macros.
  3. Clique na seta para baixo na caixa Macros em e clique em Comandos do Word.
  4. Na lista Nome da macro, clique em FileOpen.
  5. Clique na seta para baixo na caixa Macros em e clique em Normal.dot (modelo global).

    Observação No Word 2007, clique em Normal.dotm (modelo global).
  6. Clique em Criar.
  7. A macro interna FileOpen aparece como no seguinte exemplo:
    Sub FileOpen()
    '
    ' FileOpen Macro
    ' Opens an existing document or template
    '
        Dialogs(wdDialogFileOpen).Show
    
    End Sub
    
  8. Substitua a macro interna FileOpen pelo seguinte exemplo de macro:
    Option Explicit
    
    ' WARNING: ANY USE BY YOU OF THE CODE PROVIDED IN THIS EXAMPLE IS
    ' AT YOUR OWN RISK. Microsoft provides this macro code "as is" without warranty of
    ' any kind, either expressed or implied, including but not limited to the implied 
    ' warranties of merchantability and/or fitness for a particular purpose.
    
    Sub FileOpen()
    '
    ' FileOpen Macro
    ' Opens an existing document or template
    '
    Dim sFileName As String
    
    ' Display the File Open dialog and capture the filename selected and pass it to a
    ' variable
    With Application.Dialogs(wdDialogFileOpen)
        .Display
        sFileName = .Name
    End With
    
    ' Test to verify the filename has a value
    ' If no file is chosen or if the Open dialog is dismissed, 
    ' the following code is skipped
    If sFileName <> "" Then
        ' Use the filename as a variable to be opened using Open and Repair feature
        Documents.Open FileName:=sFileName, OpenAndRepair:=True
    End If
    
    End Sub
    
  9. No menu Arquivo, clique em Fechar e voltar para Microsoft Word.
  10. No menu Arquivo, pressione SHIFT e clique em Salvar todas.
Observações
  • A nova macro FileOpen será executada se você abrir um documento usando qualquer um dos seguintes métodos:
    • Você clica em Abrir no menu Arquivo.
    • Você clica em Abrir na barra de ferramentas Padrão.
  • A nova macro FileOpen não será executada se você abrir um documento usando qualquer um dos seguintes métodos:
    • Você abre o documento no Windows Explorer.
    • Você abre o documento a partir da lista de arquivos MRU.

Propriedades

ID do artigo: 893672 - Última revisão: segunda-feira, 16 de maio de 2011 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Office Word 2007
  • Microsoft Word 2002 Standard Edition
  • Microsoft Word 2010
Palavras-chave: 
kbopenfile kbprogramming kbautomation kbvba kbhowto KB893672

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com