Artikel-ID: 894071 - Geändert am: Dienstag, 15. November 2005 - Version: 1.2

Eine Verzögerung bevor die Liste der neuen Dateien zurückgegeben wird, wenn Sie den Befehl DIR oder LS-Befehl, Ausführen nach der Aktualisierung zu Windows Services for UNIX 3.0 oder Windows Services for UNIX 3.5

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wichtig Dieser Artikel enthält Informationen zum Ändern der Registrierung. Bevor Sie die Registrierung bearbeiten, vergewissern Sie sich bitte, dass Sie die Registrierung wiederherstellen können, falls ein Problem auftritt. Weitere Informationen zum Erstellen einer Sicherungskopie, zum Wiederherstellen und Bearbeiten der Registrierung finden Sie in folgendem Artikel der Microsoft Knowledge Base:
256986  (http://support.microsoft.com/kb/256986/ ) Beschreibung der Microsoft Windows-Registrierung
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Problembeschreibung

Nach der Sie Microsoft Windows Services for UNIX 2.0 auf Microsoft Windows Services für UNIX 3.0 oder Microsoft Windows Services for UNIX 3.5 aktualisiert, treten eine Verzögerung, bevor die Liste der neuen Dateien oder der neue Ordner, beim Ausführen der Befehl DIR oder den Befehl LS zurückgegeben wird .

Dieses Problem tritt beispielsweise auf, wenn Sie diese Schritte durchführen:
  1. Sie bereitstellen eine System (NFS) Dateifreigabe im Netzwerk Verwenden von Client für NFS.
  2. Ändern Sie das Laufwerk, in der bereitgestellten NFS-Freigabe.
  3. Sie führen den Befehl DIR auf bereitgestellten NFS-Freigabe.
  4. In UNIX kopieren Sie neue Dateien für die NFS-Freigabe, die in Schritt 1 bereitgestellt.
  5. Sie wiederholen den Befehl DIR , bis die neuen Dateien aufgelistet sind.

    Hinweis: Es kann 20 bis 30 Sekunden, bevor die neuen Dateien aufgeführt sind, dauern.

Ursache

Dieses Problem rührt von Client for NFS NFS-Freigabe den Ordner Inhalt für einen Standard-Zeitraum von 30 Sekunden zwischengespeichert.

Abhilfe

Warnung Fehlerhafte Verwendung des Registrierungseditors kann schwerwiegende Probleme verursachen, die eine Neuinstallation Ihres Betriebssystems erforderlich machen. Microsoft kann nicht garantieren, dass Probleme, die Verwendung des Registrierungseditors entstehen, behoben werden können. Benutzen Sie den Registrierungseditor auf eigene Verantwortung.

Erstellen Sie um dieses Problem zu umgehen, eines Registrierungseintrags, das steuert die Standardzeit, bevor der Cache ungültig ist. Gehen Sie hierzu folgendermaßen vor:
  1. Klicken Sie auf Start , klicken Sie auf Ausführen , geben Sie regedit ein und klicken Sie dann auf OK .
  2. Klicken Sie auf folgenden Unterschlüssel in der Registrierung:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Client für NFS\CurrentVersion\Users\Default
  3. Klicken Sie im Menü Bearbeiten auf neu zeigen Sie und klicken Sie dann auf Schlüssel .
  4. Geben Sie Cache , und drücken Sie anschließend die [EINGABETASTE].
  5. Klicken Sie auf folgenden Unterschlüssel in der Registrierung:
    HKEY_LOCAL_MACHINE\Software\Microsoft\Client für NFS\CurrentVersion\Users\Default\Cache
  6. Klicken Sie im Menü Bearbeiten auf neu , und klicken Sie dann auf DWORD-Wert .
  7. Geben Sie AttributeTimeDelta , und drücken Sie anschließend die [EINGABETASTE].
  8. Klicken Sie mit der rechten Maustaste auf AttributeTimeDelta , und klicken Sie dann auf Ändern .
  9. Klicken Sie im Dialogfeld DWORD-Wert bearbeiten klicken Sie auf Dezimal , geben Sie einen Wert, der kleiner als der Standardwert von 30 Sekunden ist und klicken Sie dann auf OK .
  10. Klicken Sie im Menü Datei auf Beenden .

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Gilt für" aufgeführt sind.

Weitere Informationen

Weitere Informationen zu Windows Services for UNIX 3.5 der folgenden Microsoft-Website:
http://technet.microsoft.com/en-us/interopmigration/bb380242.aspx (http://technet.microsoft.com/en-us/interopmigration/bb380242.aspx)

Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Services for UNIX 3.5
  • Microsoft Windows Services for UNIX 3.0 Standard Edition
Keywords: 
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 894071  (http://support.microsoft.com/kb/894071/en-us/ )
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