Idioma de MUI configuración no funciona correctamente en WordPad después de instalar seguridad la actualización MS04-041 en un equipo basado en Windows XP Service Pack 1

Seleccione idioma Seleccione idioma
Id. de artículo: 894072 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Tenga en cuenta la situación siguiente:
  • Tener un Service Pack 1 (SP1) de Microsoft Windows XP - basado en equipo que tiene instalado el paquete Multilingual User Interface (MUI).
  • En el equipo ha instalado la actualización de seguridad MS04-041.
  • Cambia el idioma predeterminado de interfaz de usuario del programa a otro idioma.

    Nota Puede utilizar la Configuración Regional y de idioma en el panel de control para cambiar el idioma de interfaz de usuario de programa.
  • Inicie Microsoft WordPad.
En este escenario, cuando inicie WordPad, puede observar que el idioma que aparece en la interfaz de usuario de WordPad es el idioma inglés predeterminado en lugar del idioma que seleccionó en Configuración Regional y de idioma .

Nota Windows XP Service Pack 2 (SP2) incluye la actualización de seguridad MS04-041. Puede experimentar este problema en un equipo basado en Windows XP SP2 si instala la actualización de seguridad MS04-041 antes de instalar el SP2 de Windows XP.

Causa

Este problema se produce porque un valor de entrada incorrecta del registro está establecido para una de las entradas de registro de WordPad cuando instala actualización de seguridad MS04-041. El valor de entrada de registro incorrecto impide que los recursos de idioma MUI cargar correctamente. Por tanto, WordPad utiliza el idioma inglés predeterminado para la interfaz de usuario de WordPad.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Esta revisión requiere que Windows XP Service Pack 1 (SP1) está instalado en el equipo.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
Windows XP Itanium-based versiones
   Date         Time   Version           Size     File name      Platform
   ---------------------------------------------------------------------
   21-Mar-2005  14:22  5.1.2600.1650     581,120  Wordpad.exe    IA-64
   21-Mar-2005  14:01  5.1.2600.1650     201,216  Wwordpad.exe   x86
   24-Feb-2005  14:20  6.1.22.4          639,712  Updspapi.dll   IA-64
Windows XP x 86
   Date         Time   Version           Size     File name
   ------------------------------------------------------------
   22-Mar-2005  03:31  5.1.2600.1650     201,216  Wordpad.exe      
   22-Mar-2005  03:27  5.1.2600.2637     214,528  Wordpad.exe      
   25-Feb-2005  03:53  6.1.22.4          371,936  Updspapi.dll

Solución

Para evitar este problema, utilice Agregar o quitar programas para quitar la actualización de seguridad MS04-041 y, a continuación, instalar Windows XP SP2.

Para obtener más información acerca de cómo obtener e instalar el Service Pack 2 (SP2) de Windows XP, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
322389Cómo obtener el service pack más reciente de Windows XP

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información acerca de la terminología estándar que se utiliza para describir las actualizaciones de software de Microsoft, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 894072 - Última revisión: miércoles, 29 de agosto de 2007 - Versión: 2.2
La información de este artículo se refiere a:
  • Microsoft Windows XP Service Pack 1 sobre las siguientes plataformas
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
Palabras clave: 
kbmt kbautohotfix kbqfe kbhotfixserver kbwin2000presp3fix kbfix kbbug KB894072 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 894072

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com