REVISIÓN: La vista de árbol del explorador de Windows puede mostrar una carpeta que no tiene un nombre o que tiene un nombre incorrecto en Windows 2000 y en Windows XP

Seleccione idioma Seleccione idioma
Id. de artículo: 894077 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Vista de árbol del explorador de Microsoft Windows puede mostrar una carpeta que no tiene un nombre o que tiene un nombre incorrecto después de una aplicación externa, crea una carpeta o se cambia el nombre de una carpeta. Este problema puede producirse con una carpeta de extensión de espacio de nombres que es un punto de unión en el sistema de archivos.

Cuando la vista de árbol del explorador de Windows controla una notificación de cambio para el shell de la aplicación externa, la notificación de cambio para el shell indica que una carpeta se ha creado o se ha cambiado el nombre.

Causa

Los archivos y carpetas en la extensión de espacio de nombres se almacenan en la carpeta del sistema de archivo que se utiliza para registrar el punto de unión. La función SHChangeNotify genera un sistema de archivos ITEMIDLIST. Esta acción se produce cuando se llama la función SHChangeNotify por una aplicación para notificar el shell cuando se ha creado una carpeta de sistema de archivos o ha cambiado el nombre. Vista de árbol del explorador de Windows controla la notificación de cambio pasando el sistema de archivos ITEMIDLIST a la interfaz IShellFolder de la carpeta que contiene el elemento que se crearon o modificaron. Esta acción se realiza para obtener el nombre mostrar del elemento. No se controlan correctamente las notificaciones de cambio para los elementos bajo la carpeta de punto de unión. Este problema se produce porque la extensión de espacio de nombres espera pasar un ITEMIDLIST generado por el espacio de nombres en lugar de la carpeta de sistema de archivo.

Solución

Microsoft Windows 2000

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Tendrá que instalar Microsoft Windows 2000 Service Pack 4 antes de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información del registro

Una vez instalados los archivos de la revisión, puede habilitar la revisión mediante la configuración de directiva de shell en la siguiente clave del registro:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer
Nombre: CompareJunctionness
Tipo: REG_DWORD
Valor de datos: 1

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time   Version        Size       File name 
   --------------------------------------------------------- 
   18-Apr-2005  11:28  5.0.3900.7040  2,359,568  Shell32.dll

Windows XP

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

Tendrá que instalar Microsoft Windows XP Service Pack 2 antes de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información del registro

Una vez instalados los archivos de la revisión, puede habilitar la revisión mediante la configuración de directiva de shell en la siguiente clave del registro:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\Explorer
Nombre: CompareJunctionness
Tipo: REG_DWORD
Valor de datos: 1

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
   Date         Time    Version         Size      File name     
   ----------------------------------------------------------------
   14-Feb-2005  21:32   6.0.2900.2610  8,451,584  Shell32.dll 
   14-Feb-2005  21:32   6.0.2900.2606    473,600  Shlwapi.dll

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 894077 - Última revisión: viernes, 16 de noviembre de 2007 - Versión: 3.3
La información de este artículo se refiere a:
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Tablet PC Edition
  • Microsoft Windows XP Media Center Edition
  • the operating system: Microsoft Windows 2000 SP4
Palabras clave: 
kbmt kbautohotfix kbfix kbqfe kbhotfixserver KB894077 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 894077

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com