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Numéro d'article: 894351 - Dernière mise à jour: mardi 10 janvier 2006 - Version: 6.1

Le message d'erreur « Le programme d'installation ne peut pas copier le fichier staxmem.dll » peut s'afficher lorsque vous essayez d'installer IIS sur un ordinateur Windows XP Professionnel SP2

Sommaire

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Symptômes

Lorsque vous essayez d'installer Microsoft Internet Information Services (IIS) sur un ordinateur Microsoft Windows XP Professionnel Service Pack 2 (SP2), l'un des messages d'erreur suivants peut s'afficher :
Erreur de copie :

Le programme d'installation ne peut pas copier le fichier staxmem.dll. Insérez le CD-ROM « Windows XP Professionnel Service Pack 2 ».
Le programme d'installation n'a pas pu copier un ou plusieurs fichiers. Le code d'erreur spécifique est 0x4b8.
Toutefois, lorsque vous placez le CD-ROM Windows XP Professionnel Service Pack 2 dans votre lecteur de CD-ROM, le programme d'installation ne peut pas trouver le fichier Staxmem.dll.

Cause

Ce problème peut survenir si l'une des conditions suivantes est remplie :
  • Le fichier de base de données Secedit.sdb est endommagé.
  • L'Assistant Composants de Windows (Sysocmgr.exe) doit installer des fichiers de telle façon que vous avez besoin à la fois du CD-ROM original de Windows XP Professionnel et du CD-ROM Windows XP Professionnel SP2.

Résolution

Pour résoudre ce problème, exécutez d'abord l'outil Esentutl.exe pour vérifier l'intégrité de la base de données Secedit.sdb. Pour cela, procédez comme suit :
  1. Cliquez sur Démarrer, puis sur Exécuter, tapez cmd, puis cliquez sur OK.
  2. À l'invite de commandes, tapez la commande suivante, puis appuyez sur ENTRÉE :
    esentutl /g lecteur:\RépWin\security\database\secedit.sdb
    Remarque Dans cette commande, lecteur désigne le disque dur où Windows XP Professionnel est installé et RépWin le dossier d'installation de Windows XP Professionnel.
À la fin de l'exécution de l'outil Esentutl.exe, appliquez l'une des méthodes suivantes pour résoudre le problème, selon le message retourné par l'outil Esentutl.exe :
  • Si l'outil Esentutl.exe retourne le message suivant, utilisez la Méthode 1 pour résoudre le problème :
    This operation may find that this database is corrupt (Cette opération peut déterminer que la base de données est corrompue)
  • Si l'outil Esentutl.exe retourne des informations semblables au message suivant, utilisez la Méthode 2 pour résoudre le problème :

    Utilitaires de base de données Microsoft(R) Windows(R)
    Version 5.2
    Copyright (C) Microsoft Corporation. Tous droits réservés.

    Initiating INTEGRITY mode...
    Database: L:\WINDOWS\security\database\secedit.sdb
    Temp. Database: TEMPINTEG2680.EDB

    Checking database integrity.

    Scanning Status (% complete)
    0 10 20 30 40 50 60 70 80 90 100
    |---|---|---|---|---|---|---|---|---|---|
    ...................................................

    Integrity check successful.

    Operation completed successfully in 0.841 seconds.
Remarque Lorsque vous exécutez l'outil Esentutl.exe, votre ordinateur est réinitialisé à son état d'installation d'origine dans lequel la stratégie de sécurité locale n'est pas définie. Vous devez peut-être redémarrer votre ordinateur en Mode sans échec pour renommer ou déplacer les fichiers. Pour démarrer votre ordinateur en Mode sans échec, appuyez sur la touche F8 pendant le démarrage de Windows XP Professionnel, tapez 1 pour choisir le Mode sans échec dans les options de démarrage, puis appuyez sur Entrée.

Méthode 1 : Réparer ou recréer le fichier Stratégie de groupe local

Pour réparer le fichier Stratégie de groupe local, procédez comme suit :
  1. Cliquez sur Démarrer, puis sur Exécuter, tapez cmd, puis cliquez sur OK.
  2. À l'invite de commandes, tapez la commande suivante, puis appuyez sur ENTRÉE :
    esentutl /p lecteur:\RépWin\security\database\secedit.sdb
    Remarque Dans cette commande, lecteur désigne le disque dur où Windows XP Professionnel est installé et RépWin le dossier d'installation de Windows XP Professionnel.
  3. Essayez d'installer IIS. Si vous n'y parvenez pas, appliquez les étapes suivantes pour recréer le fichier Stratégie de groupe local.
Pour recréer le fichier Stratégie de groupe local, procédez comme suit :
  1. Cliquez sur Démarrer, puis sur Exécuter. Tapez explorer, puis cliquez sur OK.
  2. Recherchez et ouvrez le dossier lecteur:\RépWin.
  3. Créez un nouveau dossier dans le dossier lecteur:\RépWin, puis nommez le nouveau dossier OldSecurity. Pour cela, procédez comme suit :
    1. Double-cliquez sur le dossier RépWin.
    2. Dans le menu Fichier, pointez sur Nouveau, puis cliquez sur Dossier.
    3. Tapez OldSecurity, puis appuyez sur ENTRÉE.
  4. Déplacez tous les fichiers possédant une extension .log du dossier lecteur:\RépWin\Security vers le dossier lecteur:\RépWin\OldSecurity. Pour cela, procédez comme suit :
    1. Double-cliquez sur le dossier Security, puis maintenez la touche CTRL enfoncée pendant que vous cliquez sur chaque nom de fichier portant une extension .log.
    2. Dans le menu Edition, cliquez sur Couper.
    3. Recherchez le dossier OldSecurity et cliquez dessus.
    4. Dans le menu Edition, cliquez sur Coller.
  5. Recherchez le fichier Secedit.sdb dans le dossier lecteur:\RépWin\Security\Database, puis renommez le fichier Secedit.sdb en Secedit.old. Pour ce faire, procédez comme suit :
    1. Cliquez avec le bouton droit sur Secedit.sdb, puis cliquez sur Renommer.
    2. Tapez Secedit.old, puis appuyez sur ENTRÉE.
  6. Cliquez sur Démarrer, sur Exécuter, tapez mmc, puis cliquez sur OK.
  7. Ajoutez le complément logiciel enfichable Configuration et analyse de la sécurité. Pour cela, procédez comme suit.
    1. Cliquez sur Fichier, cliquez sur Ajouter/Supprimer un composant logiciel enfichable, sur Configuration et analyse de la sécurité dans la liste Composants logiciels enfichables disponibles, puis cliquez sur Ajouter.
    2. Dans la boîte de dialogue Ajout d'un composant logiciel enfichable autonome, cliquez sur Fermer.
    3. Dans la boîte de dialogue Ajouter/Supprimer un composant logiciel enfichable, cliquez sur OK.
  8. Cliquez avec le bouton droit sur Configuration et analyse de la sécurité, puis cliquez sur Ouvrir une base de données.
  9. Recherchez le dossier lecteur:\RépWin\Security\Database. Dans la zone Nom de fichier, tapez Secedit.sdb, puis cliquez sur Ouvrir.

    Remarque Si vous recevez un message indiquant que l'accès est refusé, vous pouvez l'ignorer.
  10. Cliquez avec le bouton droit sur Configuration et analyse de la sécurité, cliquez sur Modèle d'importation, tapez setup security.inf, puis cliquez Ouvrir.
  11. Redémarrez l'ordinateur si vous y êtes invité.
  12. Essayez d'installer IIS. Si vous n'y parvenez pas, suivez la procédure de la Méthode 2.

Méthode 2 : Intégrer les fichiers d'installation de Windows XP Professionnel SP2 dans la version originale des fichiers d'installation de Windows XP Professionnel

Pour intégrer les fichiers d'installation de Windows XP Professionnel SP2 dans la version originale des fichiers d'installation de Windows XP Professionnel, procédez comme suit :
  1. Créez un nouveau dossier ne contenant pas de fichiers. Pour cela, procédez comme suit :
    1. Cliquez sur Démarrer, puis sur Exécuter, tapez cmd, puis cliquez sur OK.
    2. À l'invite de commandes, tapez cd \, puis appuyez sur ENTRÉE.
    3. À l'invite de commandes, tapez md winxp, puis appuyez sur ENTRÉE.
    4. À l'invite de commandes, tapez cd winxp, puis appuyez sur ENTRÉE.
    5. À l'invite de commandes, tapez md i386, puis appuyez sur ENTRÉE.
  2. Placez la version originale du CD-ROM Windows XP Professionnel dans votre lecteur de CD-ROM.
  3. À l'invite de commandes, tapez la commande suivante, puis appuyez sur ENTRÉE :
    xcopy /E /I /V lecteur_CD-ROM:\i386\*.* /s lecteur:\winxp\i386
    Remarque Dans cette commande, lecteur_CD-ROM est le lecteur de CD-ROM où se trouve le CD-ROM original de Windows XP Professionnel.
  4. Retirez le CD-ROM Windows XP Professionnel du lecteur de CD-ROM, puis placez le CD-ROM Windows XP Professionnel SP2 dans le lecteur de CD-ROM.
  5. À l'invite de commandes, tapez la commande suivante, puis appuyez sur ENTRÉE :
    lecteur_CD-ROM:
    Remarque Dans cette commande, lecteur_CD-ROM est le lecteur de CD-ROM où se trouve le CD-ROM Windows XP Professionnel SP2.
  6. À l'invite de commandes, tapez la commande suivante, puis appuyez sur ENTRÉE :
    xpsp2 /integrate:lecteur:\winxp
  7. Installez IIS.
  8. Lorsque vous êtes invité à rechercher les fichiers d'installation de Windows XP Professionnel, tapez lecteur:\winxp, puis appuyez sur Entrée.

Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Professional Service Pack 2 (SP2)
Mots-clés : 
kbtshoot kbprb KB894351
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