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User profiles are not removed after you log off a terminal server that is running Windows Server 2003

Article ID:894791
Last Review:July 24, 2007
Revision:1.9
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SYMPTOMS

If you try to log off from a Microsoft Windows Server 2003-based terminal server, the logoff process is very slow and the profiles are not removed from the terminal server. Additionally, the following events occur if the Microsoft User Profile Hive Cleanup service is installed:

Event Type: Information
Event Source: UPHClean
Event Category: None
Event ID: 1001
Date: date
Time: time
User: N/A
Computer: computer name
Description:
The description for Event ID ( 1001 ) in Source ( UPHClean ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: 1.5.0.18.

Event Type: Information
Event Source: UPHClean
Event Category: None
Event ID: 1101
Date: date
Time: time
User: S-1-5-21-1177238915-2111687655-1801674531-3702
Computer: computer name
Description:
The description for Event ID ( 1101 ) in Source ( UPHClean ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: NCH\wardc22, S-1-5-21-1177238915-2111687655-1801674531-3702.

Event Type: Information
Event Source: UPHClean
Event Category: None
Event ID: 1201
Date: date
Time: time
User: S-1-5-21-1177238915-2111687655-1801674531-2437
Computer: computer name
Description:
The description for Event ID ( 1201 ) in Source ( UPHClean ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event:
NCH\dormar, S-1-5-21-1177238915-2111687655-1801674531-2437, wmiprvse.exe (7296)
HKCU (0x1c8)
0x77dfc200 ADVAPI32!CredFree+0xc40
0x77da7b63 ADVAPI32!RegCreateKeyW+0x1d
0x00b79809 <no module>!<no symbol>
0x01019245 wmiprvse!<no symbol>
0x010193db wmiprvse!<no symbol>
0x77c578e0 RPCRT4!NdrServerInitialize+0x560
0x77ce51d0 RPCRT4!NdrStubCall2+0x1d0
0x77ce5862 RPCRT4!CStdStubBuffer_Invoke+0x82
0x7557b2c0 FastProx!CUntypedArray::AppendRange+0xc42
0x77269a8a ole32!StgGetIFillLockBytesOnFile+0x10f44
0x77179c5c ole32!CoLockObjectExternal+0x152a

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CAUSE

This problem occurs because the Windows Management Service process (Wmiprvse.exe) does not unload the user profiles correctly.

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RESOLUTION

Service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 (http://support.microsoft.com/kb/889100/) How to obtain the latest service pack for Windows Server 2003

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Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

No prerequisites are required.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later) that are listed in the following table. The dates and times for these files are listed in coordinated universal time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   28-Feb-2005  08:38  5.2.3790.280       84,480  Stdprov.dll      

Windows Server 2003, Itanium-based versions

   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   27-Feb-2005  16:35  5.2.3790.280      287,232  Stdprov.dll      IA-64

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

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MORE INFORMATION

For more information about the standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Microsoft Windows Server 2003, Standard Edition (32-bit x86)
Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
Microsoft Windows Server 2003, Web Edition
Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems

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Keywords: 
kbautohotfix kbbug kbfix kbwinserv2003presp1fix kbpubtypekc kbhotfixserver kbqfe KB894791

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