Security permissions for a service are not correctly set when you use a Group Policy object to modify service settings on a Windows XP Service Pack 2-based computer

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Article ID: 894794
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Symptoms

Consider the following scenario.
  • You use the System Services settings to configure a service in a Group Policy object (GPO) on a Microsoft Windows XP Service Pack 2 (SP2)-based computer.
  • You select a service in the GPO and then view the service properties.
  • You click to select the Define this policy setting check box to configure the service.
  • The Security Permissions dialog box for the service appears when you define the policy settings.
  • The dialog box contains a predefined set of permissions.
  • You close the Security Permissions dialog box and then select a service startup mode.
  • You update the changes that are made to the GPO.
In this scenario, when you apply the GPO to Windows XP-based computers, some services may not start because of the predefined security settings.

Cause

This problem occurs because the security permissions that the GPO sets on the services are different from the permissions that currently are assigned to the Windows XP SP2-based computer on which the GPO was modified.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix requires Windows XP SP2.

Restart requirement

You must restart your computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version           Size     File name   
   --------------------------------------------------------------
   02-Mar-2005  17:51  5.1.2600.2622     596,992  Wsecedit.dll

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about standard terminology that is used to describe Microsoft software updates, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates

Properties

Article ID: 894794 - Last Review: June 20, 2014 - Revision: 3.0
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbwinxppresp3fix kbfix kbbug KB894794

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