文書番号: 894896 - 最終更新日: 2005年2月21日 - リビジョン: 1.3

休止状態からの復帰でシステムが応答を停止することがある

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概要

1GB 以上の メモリーを搭載したコンピュータで、休止状態からの復帰時に非常にまれにシステムが応答を停止する場合があります。

現象

休止状態からの復帰時の画面でバーが右端まで達した後、画面に何も表示されない状態でシステムが応答を停止します。 現象発生時には、キーボード、マウスなどの入力デバイスも反応しません。

原因

休止状態からの復帰時にNTLDR がカーネルやHALを同一のラージページに読み込みます。そのメモリのキャッシュのタイプは Cached のアトリビュートに設定されますが、ビデオドライバなど一部のドライバが、ダイナミックにシステムメモリにアロケートされる場合、ラージページの一部を NonCached 或は WriteCombined に設定する可能性があります。そのため、同じフィジカルメモリアドレスに対して、異なるキャッシュアトリビュートが同時に設定され、キャッシュのアトリビュートの不整合が発生し、Processor TLB が破壊される可能性があります。 このため、NTLDR からカーネルに処理がわたった段階でシステムが応答を停止します。

状況

マイクロソフトでは、この問題を適用される製品一覧に記述される製品の不具合と認識しています。

回避策

現象発生時には、機械的に電源を切る以外に一切の操作ができなくなります。
 一旦電源を切った後、しばらくたってから再度電源を投入すると、「システムは休止状態からの復帰に失敗しました。もう一度再起動しますか?」といったメッセージが表示され、「復元データを削除してシステム ブート メニューにすすみます」と「続けてシステムを再起動します」の選択メニューが表示されます。
一旦、「続けてシステムを再起動します」を選択します。
システムが復帰しない場合、休止状態の保存ファイルが損傷している可能性がありますので、「復元データを削除してシステム ブート メニューにすすみます」を選択して、新たにシステムを起動してください。

この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Tablet PC Edition Service Pack 2 (SP2)
  • Microsoft Windows XP Media Center Edition Service Pack 2 (SP2)
キーワード:?
kbharmony kbtshoot kbprb kbbug KB894896
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