U kunt de opdracht Historie niet gebruiken wanneer u het hulpprogramma Remote Shell in Windows 2000 met Service Pack 4 of Windows XP met Service Pack 2 gebruiken

Vertaalde artikelen Vertaalde artikelen
Artikel ID: 895109
Alles uitklappen | Alles samenvouwen

Op deze pagina

Symptomen

Wanneer u het hulpprogramma Remote Shell (Rsh.exe) gebruikt op een computer met Microsoft Windows XP met Service Pack 2 (SP2) of Microsoft Windows 2000 met Service Pack 4 (SP4) u een van de volgende symptomen kunnen optreden.

Windows XP met SP2
  • U kunt de opdracht Historie niet gebruiken. Daarnaast u het volgende foutbericht:
    Terminal lezen: de ingang is ongeldig.
  • U kunt de opdracht Historie onder bepaalde voorwaarden. Als u de opdracht Historie, het hulpprogramma Remote Shell veroorzaakt echter een oneindige lus. Bovendien, als u een lijst met opdrachten Remote Shell het hulpprogramma een eindeloze lus plaatsvindt.
Windows 2000 met SP4
  • Als u Windows 2000 post-SP4 hotfix-versie 5.0.2195.6927, de opdrachtgeschiedenis van de niet gebruiken. Bovendien wordt het volgende bericht:
    Terminal lezen: de ingang is ongeldig.
    Klik op het volgende artikelnummer om het artikel in voor meer informatie. de Microsoft Knowledge Base:
    837090Remote Shell (Rsh.exe) reageert niet meer wanneer u een computer met Windows 2000 op een toets drukt
  • U kunt de opdracht Historie onder bepaalde voorwaarden. Als u de opdracht Historie, het hulpprogramma Remote Shell veroorzaakt echter een oneindige lus. Bovendien, als u een lijst met opdrachten Remote Shell het hulpprogramma een eindeloze lus plaatsvindt.

OpmerkingAls een oneindige lus, CPU-gebruik 100 procent is en de computer niet reageert.

Oorzaak

Het probleem treedt op omdat de terminal handler invoer threads voor het hulpprogramma Remote Shell bepaalt niet of de opdracht invoer is omgeleid. De functie input handler wordt ervan uitgegaan dat de invoer altijd afkomstig van de console. De invoer kan echter worden omgeleid naar andere invoer streams.

Oplossing

Windows XP met SP2

Informatie over hotfixes

Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter bedoeld om alleen het probleem dat in dit artikel wordt beschreven. Deze hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet.

Als u de hotfix downloaden, is er een sectie 'Hotfix downloaden beschikbaar' aan het begin van dit Knowledge Base-artikel. Als deze sectie niet wordt weergegeven, een verzoek indienen om Microsoft Customer Service and Support om de hotfix te verkrijgen.

OpmerkingAls er nog andere problemen optreden of als er oplossingen vereist is, moet u mogelijk een afzonderlijk serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen die niet in aanmerking voor deze specifieke hotfix komen. Bezoek de volgende Microsoft-website voor een volledige lijst met telefoonnummers van Microsoft Customer Service and Support of een afzonderlijk serviceverzoek maken:
http://support.Microsoft.com/contactus/?ws=support
OpmerkingHet formulier 'Hotfix gedownload' geeft de talen waarvoor de hotfix beschikbaar is. Als uw taal niet wordt weergegeven, is omdat een hotfix voor die taal beschikbaar.
Vereisten
Er gelden geen voorwaarden.
Opnieuw opstarten
U hebt niet de computer opnieuw opstarten nadat u deze hotfix.
Vervanging van hotfixes
Deze hotfix vervangt geen andere hotfixes.
Bestandsgegevens
Het bestand heeft de Engelse versie van deze hotfix kenmerken (of recentere bestandskenmerken) die in de volgende tabel worden weergegeven. De datums en tijden voor deze bestanden worden weergegeven in Coordinated Universal Time (UTC). Wanneer u de bestandsinformatie weergeeft, wordt deze naar lokale tijd geconverteerd. Naar het verschil tussen UTC en lokale tijd, gebruikt u deTijd Zonetabblad in het onderdeel Datum en tijd in het Configuratiescherm.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   17-Mar-2005  01:10  5.1.2600.2634      14,848  Rsh.exe          

Windows 2000

Informatie over hotfixes

Een ondersteunde hotfix is beschikbaar bij Microsoft. Deze hotfix is echter bedoeld om alleen het probleem dat in dit artikel wordt beschreven. Deze hotfix alleen uit op systemen waarop dit specifieke probleem zich voordoet.

Als u de hotfix downloaden, is er een sectie 'Hotfix downloaden beschikbaar' aan het begin van dit Knowledge Base-artikel. Als deze sectie niet wordt weergegeven, een verzoek indienen om Microsoft Customer Service and Support om de hotfix te verkrijgen.

OpmerkingAls er nog andere problemen optreden of als er oplossingen vereist is, moet u mogelijk een afzonderlijk serviceverzoek indienen. De normale ondersteuningskosten gelden voor extra ondersteuningsvragen die niet in aanmerking voor deze specifieke hotfix komen. Bezoek de volgende Microsoft-website voor een volledige lijst met telefoonnummers van Microsoft Customer Service and Support of een afzonderlijk serviceverzoek maken:
http://support.Microsoft.com/contactus/?ws=support
OpmerkingHet formulier 'Hotfix gedownload' geeft de talen waarvoor de hotfix beschikbaar is. Als uw taal niet wordt weergegeven, is omdat een hotfix voor die taal beschikbaar.
Vereisten
Er gelden geen voorwaarden.
Opnieuw opstarten
U hoeft niet uw computer opnieuw opstarten nadat u deze hotfix.
Vervanging van hotfixes
Deze hotfix vervangt geen andere hotfixes.
Bestandsgegevens
Het bestand heeft de Engelse versie van deze hotfix kenmerken (of recentere bestandskenmerken) die in de volgende tabel worden weergegeven. De datums en tijden voor deze bestanden worden weergegeven in Coordinated Universal Time (UTC). Wanneer u de bestandsinformatie weergeeft, wordt deze naar lokale tijd geconverteerd. Naar het verschil tussen UTC en lokale tijd, gebruikt u deTijd Zonetabblad in het onderdeel Datum en tijd in het Configuratiescherm.
   Date         Time   Version            Size    File name
   --------------------------------------------------------------
   04-Apr-2005  21:32  5.0.2195.7038      14,608  Rsh.exe          

Status

Microsoft heeft bevestigd dat dit probleem in de Microsoft-producten die worden vermeld is in de sectie 'Van toepassing op'.

Meer informatie

Klik op het volgende artikelnummer in de Microsoft Knowledge Base voor meer informatie:
816915Nieuwe bestand naamgevingsschema voor Software-updatepakketten voor Microsoft Windows
824684Beschrijving van de standaardterminologie die wordt gebruikt om software-updates voor Microsoft te beschrijven
Opmerking Dit is een artikel voor snelle publicatie dat rechtstreeks is gemaakt vanuit de ondersteuningsorganisatie van Microsoft. De informatie in dit artikel wordt in de huidige vorm aangeboden in reactie op nieuw geconstateerde problemen. Aangezien artikelen van dit type zeer snel moeten worden gepubliceerd, kan de inhoud typografische fouten bevatten en kan de inhoud zonder voorafgaande kennisgeving worden gewijzigd. Raadpleeg de Gebruiksrechtovereenkomst voor overige aandachtspunten.

Eigenschappen

Artikel ID: 895109 - Laatste beoordeling: donderdag 17 maart 2011 - Wijziging: 2.0
Trefwoorden: 
kbautohotfix kbbug kbfix kbhotfixserver kbqfe kbmt KB895109 KbMtnl
Automatisch vertaald artikel
BELANGRIJK: Dit artikel is vertaald door de vertaalmachine software van Microsoft in plaats van door een professionele vertaler. Microsoft biedt u professioneel vertaalde artikelen en artikelen vertaald door de vertaalmachine, zodat u toegang heeft tot al onze knowledge base artikelen in uw eigen taal. Artikelen vertaald door de vertaalmachine zijn niet altijd perfect vertaald. Deze artikelen kunnen fouten bevatten in de vocabulaire, zinsopbouw en grammatica en kunnen lijken op hoe een anderstalige de taal spreekt en schrijft. Microsoft is niet verantwoordelijk voor onnauwkeurigheden, fouten en schade ontstaan door een incorrecte vertaling van de content of het gebruik ervan door onze klanten. Microsoft past continue de kwaliteit van de vertaalmachine software aan door deze te updaten.
De Engelstalige versie van dit artikel is de volgende:895109

Geef ons feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com