REVISIÓN: Programa personalizado que utiliza el contexto de activación puede dejar de responder inesperadamente en un equipo que ejecuta Windows XP con Service Pack 1

Seleccione idioma Seleccione idioma
Id. de artículo: 895322 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando se ejecuta un programa personalizado que utiliza el contexto de activación en un equipo que ejecuta Microsoft Windows XP con Service Pack 1 (SP1), el programa personalizado puede dejar inesperadamente de responder.

Causa

Este problema se produce si la función QueryPathOfRegTypeLib no devuelve correctamente el nombre de archivo completo para una biblioteca de tipo que se especificó en el archivo de manifiesto.

Solución

Información de revisiones

Hay una revisión compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Aplíquela sólo a los sistemas que experimenten este problema específico. Esta revisión podría sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a la siguiente actualización de software que contenga este hotfix.

Si la revisión está disponible para descarga, es hay una sección de "Descarga de revisión disponible" al principio de este artículo. Póngase en contacto si no aparece en esta sección, con los Microsoft cliente Servicios de y soporte técnico para obtener la revisión de.

Nota Si se producen problemas adicionales o si cualquier solución de problemas es necesario, quizás tenga que crear una solicitud de servicio independiente. Los costos habituales de soporte se aplicarán a las preguntas de soporte técnico adicionales y problemas que no guarden relación con esta revisión específica. Para obtener una lista completa de números de teléfono de servicio de atención al cliente y soporte técnico o para crear una solicitud de servicio independiente, visite el siguiente sitio Web:
http://support.microsoft.com/contactus/?ws=support
Nota El formulario "Descarga de revisión disponibles" muestra los idiomas para que la revisión está disponible. Si no ve su idioma, es porque una revisión no está disponible para ese idioma.

Requisitos previos

No se necesita ningún requisito previo.

Requisito de reinicio

Debe reiniciar el equipo después de aplicar este hotfix.

Información acerca de la sustitución de la revisión

Este hotfix no sustituye a otros hotfix.

Información de archivo

La versión en inglés de este hotfix tiene los atributos de archivo (o atributos de último archivo) mostrados en la siguiente tabla. Las fechas y las horas de estos archivos se muestran en hora universal coordinada (UTC). La información de los archivos se convertirá a la hora local cuando la vea. Para averiguar la diferencia entre hora UTC y la hora local, utilice la ficha zona horaria de la herramienta fecha y hora en el panel de control.
Versiones de 64 bits de Windows XP
   Date         Time   Version        Size       File name      Platform
   ----------------------------------------------------------------------
   11-Mar-2005  11:52  3.50.5020.0      655,360  Asycfilt.dll   IA-64
   11-Mar-2005  11:52  3.50.5020.0    3,969,024  Oleaut32.dll   IA-64
   11-Mar-2005  07:12  3.50.5017.0       17,920  Stdole2.tlb
   11-Mar-2005  11:52  5.1.2600.1643  2,034,176  Sxs.dll        IA-64
   11-Mar-2005  11:55  3.50.5020.0       77,824  Wasycfilt.dll  x86
   11-Mar-2005  11:55  3.50.5020.0      577,536  Woleaut32.dll  x86
   11-Mar-2005  11:55  5.0.5020.0       106,496  Wolepro32.dll  x86
   09-Mar-2005  11:24  3.50.5020.0       17,920  Wstdole2.tlb
   11-Mar-2005  11:55  5.1.2600.1643    683,008  Wsxs.dll       x86
Versiones de 32 bits de Windows XP
   Date         Time   Version        Size     File name
   --------------------------------------------------------
   12-Mar-2005  01:25  3.50.5020.0     77,824  Asycfilt.dll     
   12-Mar-2005  01:25  3.50.5020.0    577,536  Oleaut32.dll     
   12-Mar-2005  01:25  5.0.5020.0     106,496  Olepro32.dll     
   10-Mar-2005  00:54  3.50.5020.0     17,920  Stdole2.tlb
   12-Mar-2005  01:25  5.1.2600.1643  683,008  Sxs.dll

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft enumerados en la sección "La información de este artículo se refiere a:".

Más información

Para obtener más información acerca de una revisión para el mismo problema en Windows XP con Service Pack 2, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
891117REVISIÓN: Una aplicación personalizada que utiliza el contexto de activación deja de responder en Windows XP con Service Pack 1 o Service Pack 2
Para obtener más información, haga clic en el número de artículo siguiente para verlo en Microsoft Knowledge Base:
824684Descripción de la terminología estándar utilizada para describir las actualizaciones de software de Microsoft

Propiedades

Id. de artículo: 895322 - Última revisión: miércoles, 29 de agosto de 2007 - Versión: 2.1
La información de este artículo se refiere a:
  • Microsoft Windows XP Service Pack 1 sobre las siguientes plataformas
    • Microsoft Windows XP Professional 64-Bit Edition (Itanium)
    • Microsoft Windows XP Professional
    • Microsoft Windows XP Home Edition
Palabras clave: 
kbmt kbautohotfix kbwinxpsp3fix kbwinxppresp3fix kbfix kbbug kbqfe kbhotfixserver KB895322 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 895322

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com