Event ID 9307 displays an incorrect value for the number of messages that are moved or that are deleted by the Mailbox Management process in Exchange Server 2003 or in Exchange 2000 Server

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Article ID: 895471 - View products that this article applies to.
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SYMPTOMS

Consider the following scenario. In Microsoft Exchange Server 2003 or in Microsoft Exchange 2000 Server, you configure the following:
  • You increase diagnostics logging for the Mailbox Management category in the MSExchangeSA service to the maximum logging level by using Exchange System Manager.
  • You define and configure a recipient policy that uses Mailbox Manager Settings property pages.
  • You run the Mailbox Management process in Exchange 2003 or in Exchange 2000.
In this scenario, event ID 9307 is generated in the Application event log when the Mailbox Management process is finished. Event ID 9307 displays a summary of the number of processed mailboxes together with the messages that meet the criteria that are defined in the recipient policy that you configured.

When you view event ID 9307, you notice that it displays an incorrect value for the number of messages that are moved or that are deleted.

CAUSE

This problem occurs if the size of the messages that are to be moved or that are to be deleted is larger than 4,294,967,295 kilobytes (KB).

RESOLUTION

Service pack information for Exchange Server 2003

To resolve this problem, obtain the latest service pack for Exchange Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003

Hotfix information

Microsoft Exchange Server 2003

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
Because of file dependencies, you must have Exchange 2003 Service Pack 1 (SP1) installed to install this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
836993 How to obtain the latest service packs for Exchange Server 2003
Restart requirement
You do not have to restart the computer after you install this hotfix. However, Exchange-related services may be automatically restarted when you install this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------
   23-Mar-2005  20:56  6.5.7232.96     8,917,504  Mad.exe

Microsoft Exchange 2000 Server

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.
Prerequisites
Because of file dependencies, you must have Exchange 2000 Service Pack 3 (SP3) installed to install this hotfix. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
301378 How to obtain the latest Exchange 2000 Server service pack
Restart requirement
You do not have to restart the computer after you install this hotfix. However, Exchange-related services may be automatically restarted when you install this hotfix.
Hotfix replacement information
This hotfix does not replace any other hotfixes.
File information
The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
   Date         Time   Version            Size    File name
   --------------------------------------------------------
   06-Apr-2005  06:02  6.0.6617.62     2,973,696  Mad.exe

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

This problem was first corrected in Exchange Server 2003 Service Pack 2.

MORE INFORMATION

For more information, click the following article numbers to view the articles in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
817903 New naming schema for Exchange Server software update packages

Properties

Article ID: 895471 - Last Review: October 25, 2007 - Revision: 3.3
APPLIES TO
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange 2000 Server Standard Edition
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbexchange2003presp2fix kbfix kbbug KB895471

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