You cannot open the Active Directory Users and Computers MMC snap-in from within the Active Directory Domains and Trusts MMC snap-in on a computer that is running Windows XP Professional x64 Edition

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Article ID: 895978 - View products that this article applies to.
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SYMPTOMS

You install the Microsoft Windows Server 2003 Administration Tools Pack on a computer that is running Microsoft Windows XP Professional x64 Edition. When you try to start the Active Directory Users and Computers Microsoft Management Console (MMC) snap-in from within the Active Directory Domains and Trusts MMC snap-in, you may receive the following error message:
MMC cannot open the file DriveLetter:\WINDOWS\system32\dsa.msc.
This may be because the file does not exist, is not an MMC console, or was created by a later version of MMC.
This may also be because you do not have sufficient rights to the file.

CAUSE

When you install the Administration Tools Pack on a computer that is running Windows XP Professional x64 Edition, the Active Directory Users and Computers MMC snap-in file (Dsa.msc) is installed in the %windir%\Syswow64 folder. Additionally, the computer's file system maps the Active Directory Users and Computers MMC snap-in to the following path:
DriveLetter:\%windir%\Syswow64\Dsa.msc
However, the Active Directory Domains and Trust MMC snap-in incorrectly specifies the path of the Active Directory Users and Computers MMC snap-in as follows:
DriveLetter:\%windir%\System32\Dsa.msc
When the computer's file system tries to locate the Dsa.msc file from within the Active Directory Domains and Trust MMC snap-in, Mmc.exe is run. Mmc.exe is run because the Dsa.msc file is associated with Mmc.exe. When Mmc.exe is run, it uses the following path to locate Dsa.msc:
DriveLetter:\%windir%\System32\Dsa.msc DomainPath
After the Mmc.exe command is run, the Active Directory Domains and Trust MMC snap-in tries to locate the Dsa.msc file. Because the Dsa.msc file does not exist in the %windir%\System32 folder, the error message that is mentioned in the "Symptoms" section is generated.

RESOLUTION

To resolve this problem, manually copy the Dsa.msc file from the %windir%\Syswow64 folder to the %windir%\System32 folder.

MORE INFORMATION

Technical support for Windows x64 editions

Your hardware manufacturer provides technical support and assistance for Microsoft Windows x64 editions. Your hardware manufacturer provides support because a Windows x64 edition was included with your hardware. Your hardware manufacturer might have customized the Windows x64 edition installation with unique components. Unique components might include specific device drivers or might include optional settings to maximize the performance of the hardware. Microsoft will provide reasonable-effort assistance if you need technical help with your Windows x64 edition. However, you might have to contact your manufacturer directly. Your manufacturer is best qualified to support the software that your manufacturer installed on the hardware.

For product information about Microsoft Windows XP Professional x64 Edition, visit the following Microsoft Web site:
http://www.microsoft.com/windowsxp/64bit/default.mspx
For product information about Microsoft Windows Server 2003 x64 editions, visit the following Microsoft Web site:
http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx

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Article ID: 895978 - Last Review: September 11, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft Windows XP Professional x64 Edition
Keywords: 
kbtshoot kbprb KB895978

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