Artigo: 895978 - Última revisão: segunda-feira, 30 de Outubro de 2006 - Revisão: 2.3

Não é possível abrir a MMC de computadores e utilizadores do Active Directory snap-in de dentro do snap-in Active Directory Domains e fidedignidades MMC num computador com o Windows XP Professional x 64 Edition

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

Instalar o Microsoft Windows Server 2003 Administration Tools Pack num computador com o Microsoft Windows XP Professional x 64 Edition. Quando tenta iniciar a consola computadores de gestão da Microsoft (MMC) e utilizadores do Active Directory snap-in no snap-in Active Directory Domains e MMC fidedignidades, poderá receber a seguinte mensagem de erro:
MMC não consegue abrir o ficheiro DriveLetter: \WINDOWS\system32\dsa.msc.
Isto pode ser porque o ficheiro não existe, não é uma consola MMC ou foi criado por uma versão posterior da MMC.
Também pode ser porque não tem direitos suficientes para o ficheiro.

Causa

Quando instala o pacote de ferramentas de administração num computador com o Windows XP Professional x 64 Edition, a MMC de computadores e utilizadores do Active Directory snap-in do ficheiro (DSA.msc) é instalado na pasta %windir%\Syswow64. Além disso, o sistema de ficheiros do computador mapeia o snap-in MMC de computadores e utilizadores do Active Directory para o seguinte caminho:
DriveLetter: \%windir%\Syswow64\Dsa.msc
No entanto, o snap-in Active Directory Domains e fidedignidade da MMC incorrectamente Especifica o caminho do snap-in MMC de computadores e utilizadores do Active Directory da seguinte forma:
DriveLetter: \%windir%\System32\Dsa.msc
Quando o sistema de ficheiros do computador tenta localizar o ficheiro DSA.msc a partir do snap-in Active Directory Domains e fidedignidade da MMC, MMC.exe é executada. MMC.exe é executada porque o ficheiro DSA.msc está associado a MMC.exe. Quando é executado MMC.exe, utiliza o seguinte caminho para localizar DSA.msc:
DriveLetter: \%windir%\System32\Dsa.msc DomainPath
Depois de executar o comando MMC.exe, o snap-in Active Directory Domains e fidedignidade da MMC tenta localizar o ficheiro DSA.msc. Uma vez que o ficheiro DSA.msc não existe na pasta % Windir%\System32, é gerada a mensagem de erro mencionada na secção "Sintomas".

Resolução

Para resolver este problema, manualmente copie o ficheiro DSA.msc da pasta %windir%\Syswow64 para a pasta % Windir%\System32.

Mais Informação

Suporte técnico para edições x 64 do Windows

O fabricante do hardware fornece suporte técnico e assistência para edições x 64 do Microsoft Windows. O fabricante do hardware fornece suporte porque foi incluída com o hardware de uma edição x 64 do Windows. O fabricante do hardware pode ter personalizado a instalação da edição x 64 do Windows com componentes exclusivos. Estes componentes exclusivos podem incluir controladores de dispositivo específicos ou podem incluir definições opcionais para maximizar o desempenho do hardware. A Microsoft fornecerá assistência razoável se necessitar de ajuda técnica na sua edição x 64 do Windows. No entanto, poderá ter de contactar o fabricante directamente. O fabricante está melhor qualificado para suportar o software que o fabricante do instalado no hardware.

Para obter informações sobre o Microsoft Windows XP Professional x 64 Edition, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/windowsxp/64bit/default.mspx (http://www.microsoft.com/windowsxp/64bit/default.mspx)
Para obter informações sobre o Microsoft Windows Server 2003 as edições x 64, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx (http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx)

A informação contida neste artigo aplica-se a:
  • Microsoft Windows XP Professional x64 Edition
Palavras-chave: 
kbmt kbtshoot kbprb KB895978 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 895978  (http://support.microsoft.com/kb/895978/en-us/ )