Programme, die die <a0>QueryPerformanceCounter</a0>-Funktion verwenden, ist möglicherweise schlecht in Windows Server 2000, Windows Server 2003 und Windows XP durchführen.

SPRACHE AUSWÄHLEN SPRACHE AUSWÄHLEN
Artikel-ID: 895980 - Produkte anzeigen, auf die sich dieser Artikel bezieht
Alles erweitern | Alles schließen

Auf dieser Seite

Problembeschreibung

In Windows Server 2000, Windows Server 2003 und Windows XP kann ein Programm, das die Funktion QueryPerformanceCounter Abfrage Systemzeit verwendet schlecht durchführen. Wenn Sie den Ping-Befehl an der Eingabeaufforderung ausführen, kann z. B. Wartezeit niedrig oder falsche Werte erhalten.

Hinweis: Dieses Problem tritt auf, auf einem Computer, auf dem eine X 86 - basierte Version von Windows oder eine X 64 - basierten Version von Windows ausgeführt wird.

Ursache

Dieses Problem tritt auf, wenn der Computer, der AMD-Cool'n verfügt ' Stiller Technologie, die im BIOS aktiviert.

Lösung

Um dieses Problem zu beheben, installieren Sie den neuen AMD-CPU-Treiber. Gehen Sie hierzu die folgende AMD-Website:
http://www.amd.com/us-en/assets/content_type/utilities/setup.zip
Nachdem Sie den neuen Treiber installiert haben, müssen Sie den Computer neu starten.

Hinweis: Fügt die Treiberinstallation die / Usepmtimer in der Datei "Boot.ini" zu wechseln. Diese Option wird im Abschnitt "Abhilfe" beschrieben.

Abhilfe

Um dieses Problem zu umgehen, aktualisieren Sie das BIOS auf dem Computer. Oder ändern Sie die Datei "Boot.ini" Verwenden der / Usepmtimer zu wechseln. Gehen Sie hierzu folgendermaßen vor:
  1. Melden Sie sich auf dem Computer mit einem Konto, das über administrative Anmeldeinformationen verfügt.
  2. Klicken Sie auf Start, klicken Sie auf Ausführen, geben Sie Notepad c:\boot.ini, und klicken Sie dann auf OK.
  3. Eine Zeile, die mit "Default beginnt" befindet sich in der Datei "Boot.ini" im Abschnitt "[Ladeprogramm starten]". Diese Zeile gibt den Speicherort des standardmäßigen Betriebssystems. Die Zeile kann wie folgt aussehen:
    Standard = Multi (0) (0) (0) Rdisk Datenträgerpartition (2) \Windows
    Suchen Sie im Abschnitt "[Operating Systems]" in der Zeile für das Betriebssystem, das die Zeile "Default" entspricht. Wenn der Computer Microsoft Windows Server 2003, Enterprise X 64 Edition, sollte die Zeile beispielsweise folgendermaßen aussehen:
    Multi (0) Festplatte (0) Rdisk (0) (2) Partition \WINDOWS="Windows Server 2003 Enterprise X 64 Edition" / fastdetect / /NoExecute = "OptIn"
  4. Am Ende der Zeile ein Leerzeichen hinzufügen, und geben Sie / Usepmtimer. Die Zeile sollte nun wie folgt aussehen.
    Multi (0) Festplatte (0) Rdisk (0) (2) Partition \WINDOWS="Windows Server 2003 Enterprise X 64 Edition" / fastdetect / /NoExecute = "OptIn" /usepmtimer
  5. Speichern Sie die Datei, und beenden Sie dann Editor.
  6. Starten Sie den Computer neu.
Im folgenden ist eine Beispieldatei für die Datei "Boot.ini" für ein System, enthält die / Usepmtimer zu wechseln.
[Bootloader]
Timeout = 0
Standard = Multi (0) (0) (0) Rdisk Datenträgerpartition (2) \Windows
[Betriebssysteme]
Multi (0) Festplatte (0) Rdisk (0) (2) Partition \WINDOWS="Windows Server 2003 Enterprise X 64 Edition" / fastdetect / /NoExecute = "OptIn" /usepmtimer
Hinweis: Die Datei "Boot.ini" befindet sich im Stammordner des Systemlaufwerks.

Weitere Informationen

Standardmäßig verwendet Windows Server 2003 Service Pack 2 (SP2) den PM-Zeitgeber für alle mit mehreren Prozessoren APIC- oder ACPI-HALs, es sei denn, die Kontrollkästchen, um zu bestimmen, ob das BIOS die APIC- oder ACPI-HALs unterstützt fehlschlägt. Wenn Sie nicht Windows Server 2003 SP2 ausführen, müssen Sie erzwingen, dass den AMD-Computer für die Verwendung von PM-Zeitgeber mit der / Usepmtimer zu wechseln.

Weitere Informationen zu ACPI und APCI Hardwareunterstützung klicken Sie auf die folgende KB-Artikelnummer:
309283HAL-Optionen nach Windows XP oder Windows Server 2003-Setup

Technischer Support für x 64-basierten Versionen von Microsoft Windows

Wenn Ihre Hardware mit einer Microsoft Windows X 64 Edition bereits installiert war, bietet der Hardwarehersteller technischen Support und Unterstützung für die Windows X 64 Edition. In diesem Fall bietet der Hersteller Ihrer Hardware unterstützt, da eine Windows X 64 Edition zusammen mit Ihrer Hardware geliefert wurde. Der Hersteller Ihrer Hardware kann die Installation von Windows X 64 Edition mit eigenen Komponenten angepasst haben. Eindeutige Komponenten gehören bestimmte Gerätetreiber oder zählen optionale Einstellungen, um die Leistung der Hardware zu optimieren. Wenn Sie technische Hilfe zu einer Windows X 64 Edition benötigen, bietet Microsoft in diesem Fall Unterstützung in angemessenem Rahmen. Allerdings müssen Sie sich direkt an den Hersteller wenden. Der Hersteller Ihres ist am besten qualifiziert, um die Software zu unterstützen, die auf der Hardware des Herstellers installiert. Wenn Sie eine Windows X 64 Edition, wie z. B. ein Microsoft Windows Server 2003 x 64-Edition) separat erworben haben, wenden Sie sich an Microsoft, um technischen Support zu erhalten.

Produktinformationen zu Microsoft Windows XP Professional X 64 Edition finden Sie auf folgender Website von Microsoft:
http://www.microsoft.com/windowsxp/64bit/default.mspx
Produktinformationen zu x 64-basierten Versionen von Microsoft Windows Server 2003 finden Sie auf folgender Website von Microsoft:
http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx
Die in diesem Artikel erwähnten Fremdanbieterprodukte werden von einem Lieferanten hergestellt, der von Microsoft unabhängig ist. Microsoft gewährt keine implizite oder sonstige Garantie in Bezug auf die Leistung oder Zuverlässigkeit dieser Produkte.

Eigenschaften

Artikel-ID: 895980 - Geändert am: Donnerstag, 11. März 2010 - Version: 6.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003, Datacenter Edition (32-bit x86)
  • Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  • Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  • Microsoft Windows Server 2003, Web Edition
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows 2000 Enterprise Edition
  • Microsoft Windows 2000 Standard Edition
  • MS Windows 2000 Server
Keywords: 
kbmt kbtshoot kbprb KB895980 KbMtde
Maschinell übersetzter Artikel
Wichtig: Dieser Artikel wurde maschinell und nicht von einem Menschen übersetzt. Die Microsoft Knowledge Base ist sehr umfangreich und ihre Inhalte werden ständig ergänzt beziehungsweise überarbeitet. Um Ihnen dennoch alle Inhalte auf Deutsch anbieten zu können, werden viele Artikel nicht von Menschen, sondern von Übersetzungsprogrammen übersetzt, die kontinuierlich optimiert werden. Doch noch sind maschinell übersetzte Texte in der Regel nicht perfekt, insbesondere hinsichtlich Grammatik und des Einsatzes von Fremdwörtern sowie Fachbegriffen. Microsoft übernimmt keine Gewähr für die sprachliche Qualität oder die technische Richtigkeit der Übersetzungen und ist nicht für Probleme haftbar, die direkt oder indirekt durch Übersetzungsfehler oder die Verwendung der übersetzten Inhalte durch Kunden entstehen könnten.
Den englischen Originalartikel können Sie über folgenden Link abrufen: 895980
Microsoft stellt Ihnen die in der Knowledge Base angebotenen Artikel und Informationen als Service-Leistung zur Verfügung. Microsoft übernimmt keinerlei Gewährleistung dafür, dass die angebotenen Artikel und Informationen auch in Ihrer Einsatzumgebung die erwünschten Ergebnisse erzielen. Die Entscheidung darüber, ob und in welcher Form Sie die angebotenen Artikel und Informationen nutzen, liegt daher allein bei Ihnen. Mit Ausnahme der gesetzlichen Haftung für Vorsatz ist jede Haftung von Microsoft im Zusammenhang mit Ihrer Nutzung dieser Artikel oder Informationen ausgeschlossen.

Ihr Feedback an uns

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com