Artigo: 895980 - Última revisão: quinta-feira, 11 de Março de 2010 - Revisão: 6.0

Programas que utilizam a função <a0>QueryPerformanceCounter podem executam deficiente no Windows Server 2000, no Windows Server 2003 e no Windows XP

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.

Nesta página

Expandir tudo | Reduzir tudo

Sintomas

No Windows Server 2000, Windows Server 2003 e Windows XP, um programa que utiliza a função QueryPerformanceCounter à hora de sistema de consulta pode efectuar com fraca qualidade. Por exemplo, se executar o comando ping na linha de comandos, poderá receber valores de latência baixa ou incorrectas.

Nota Este problema ocorre num computador com um x 86 - versão do Windows ou um x 64 com base - baseados em versão do Windows.

Causa

Este problema ocorre quando o computador tem o Cool'n AMD ' silencioso tecnologia activada no BIOS.

Resolução

Para resolver este problema, instale o controlador AMD CPU novo. Para o fazer, visite o seguinte Web site da AMD:
http://www.amd.com/us-en/assets/content_type/utilities/setup.zip (http://www.amd.com/us-en/assets/content_type/utilities/setup.zip)
Depois de instalar o novo controlador, tem de reiniciar o computador.

Nota A instalação do controlador adiciona os / usepmtimer no ficheiro Boot.ini. Este parâmetro é discutido na secção "Como contornar".

Como contornar

Para contornar este problema, actualize o BIOS no computador. Ou, modifique o ficheiro Boot.ini para utilizar o / usepmtimer mudar. Para tal, siga estes passos:
  1. Inicie sessão no computador utilizando uma conta com credenciais administrativas.
  2. Clique em Iniciar, clique em Executar, escreva notepad c:\boot.ini e, em seguida, clique em OK.
  3. No ficheiro Boot.ini, uma linha que começa por "predefinido" está localizada na secção "[carregador de arranque]". Esta linha especifica a localização do sistema operativo predefinido. A linha pode aparecer da seguinte forma:
    predefinição = multi (0) disk (0) rdisk (0) partition (2) \WINDOWS
    Na secção "[operating systems]", localize a linha para o sistema operativo que corresponde à linha "predefinido". Por exemplo, se o computador estiver a executar o Microsoft Windows Server 2003, Enterprise x 64 Edition, a linha deve semelhante ao seguinte:
    multi (0) disk (0) rdisk (0) partition (2) \WINDOWS="Windows Server 2003 Enterprise x 64 Edition" /fastdetect /NoExecute = OptIn
  4. No fim da linha, adicione um espaço e, em seguida, escreva / usepmtimer. A linha deverá agora semelhante ao seguinte.
    multi (0) disk (0) rdisk (0) partition (2) \WINDOWS="Windows Server 2003 Enterprise x 64 Edition" /fastdetect /NoExecute = OptIn /usepmtimer
  5. Guarde o ficheiro e saia do bloco de notas.
  6. Reinicie o computador.
Segue-se um ficheiro Boot.ini de amostra para um sistema que contém o / usepmtimer mudar.
[boot loader]
timeout = 0
predefinição = multi (0) disk (0) rdisk (0) partition (2) \WINDOWS
[operating systems]
multi (0) disk (0) rdisk (0) partition (2) \WINDOWS="Windows Server 2003 Enterprise x 64 Edition" /fastdetect /NoExecute = OptIn /usepmtimer
Nota O ficheiro Boot.ini está localizado na pasta raiz da unidade de sistema.

Mais Informação

Por predefinição, o Windows Server 2003 Service Pack 2 (SP2) utiliza o temporizador PM para todos os múltiplos processadores APIC ou HAL ACPI, a menos que o processo de verificação para determinar se o BIOS suporta o APIC ou HAL ACPI falha. Se não estiver a executar o Windows Server 2003 SP2, terá de forçar o computador AMD para utilizar o temporizador PM utilizando o / usepmtimer mudar.

Para obter mais informações sobre o suporte de hardware ACPI e APCI, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft:
309283  (http://support.microsoft.com/kb/309283/ ) Opções de HAL após o Windows XP ou o programa de configuração do Windows Server 2003

Suporte técnico para versões baseadas em 64 do Microsoft Windows x

Se o hardware foi fornecido com uma edição x 64 do Microsoft Windows instalada, o fabricante do hardware fornece suporte técnico e assistência para a edição x 64 do Windows. Neste caso, o fabricante do hardware fornece suporte porque uma edição x 64 do Windows foi incluída com o hardware. O fabricante do hardware pode ter personalizado a instalação da edição do x 64 do Windows utilizando componentes exclusivos. Estes componentes exclusivos podem incluir controladores de dispositivo específicos ou podem incluir definições opcionais para maximizar o desempenho do hardware. A Microsoft fornecerá assistência razoável se necessitar de ajuda técnica para uma edição x 64 do Windows. No entanto, poderá ter de contactar o fabricante directamente. O fabricante está melhor qualificado para suportar o software que o fabricante instalado no hardware. Se tiver adquirido uma edição x 64 do Windows, tal como um Microsoft Windows Server 2003 x 64 edition, separadamente, contacte a Microsoft para obter suporte técnico.

Para obter informações sobre o Microsoft Windows XP Professional x 64 Edition, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/windowsxp/64bit/default.mspx (http://www.microsoft.com/windowsxp/64bit/default.mspx)
Para obter informações sobre versões baseadas em 64 do Microsoft Windows Server 2003 x, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx (http://www.microsoft.com/windowsserver2003/64bit/x64/editions.mspx)
Os produtos de outros fabricantes que este artigo aborda são fabricados por empresas independentes da Microsoft. Microsoft não oferece nenhuma garantia, expressa ou implícita, relativamente ao desempenho ou fiabilidade destes produtos.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows Server 2003, Datacenter x64 Edition
  • Microsoft Windows Server 2003, Enterprise x64 Edition
  • Microsoft Windows Server 2003, Standard x64 Edition
  • Microsoft Windows Server 2003 Datacenter Edition
  • Microsoft Windows Server 2003 Enterprise Edition
  • Microsoft Windows Server 2003 Standard Edition
  • Microsoft Windows Server 2003 Web Edition
  • Microsoft Windows XP Professional x64 Edition
  • Microsoft Windows XP Professional Edition
  • Microsoft Windows 2000 Enterprise Edition
  • Microsoft Windows 2000 Standard Edition
  • MS Windows 2000 Server
Palavras-chave: 
kbmt kbtshoot kbprb KB895980 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 895980  (http://support.microsoft.com/kb/895980/en-us/ )