La fenêtre qui ouvre inopinément une boîte de dialogue Téléchargement de fichier se ferme lorsque vous essayez de télécharger un fichier à l'aide d'Internet Explorer dans Windows XP Service Pack 2

Traductions disponibles Traductions disponibles
Numéro d'article: 896017 - Voir les produits auxquels s'applique cet article
important Cet article contient des informations sur la modification du Registre. Veillez à sauvegarder le Registre avant de le modifier. Vérifiez que vous connaissez comment restaurer le Registre si un problème se produit. Pour plus d'informations sur la façon sauvegarder, restaurer et modifier le Registre, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
256986 Description du Registre Microsoft Windows
Agrandir tout | Réduire tout

Sommaire

Symptômes

Lorsque vous essayez de télécharger un fichier à l'aide de Microsoft Internet Explorer, vous pouvez rencontrer le problème suivant :

Lorsque vous cliquez sur Enregistrer , ouvrir ou Annuler dans la boîte de dialogue Téléchargement de fichier , la fenêtre qui ouvre inopinément la boîte de dialogue Téléchargement de fichier se ferme.

Cause

Ce problème peut se produire si vous exécutez Windows XP Service Pack 2 (SP2). Ce problème se produit en raison d'une modification de comportement dans Internet Explorer lorsqu'il s'exécute dans le Service Pack 2 Windows XP.

Le MIME de gestion des fonctionnalités est modifié lorsqu'il traite un téléchargement à partir d'une fenêtre pop-up. Dans ce scénario, la fonctionnalité de gestion MIME ferme la fenêtre contextuelle lorsque le contenu téléchargé est envoyé à partir du serveur Web en utilisant l'en-tête HTTP « content-disposition ; document joint ».

Résolution

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes rencontrant ce problème spécifique. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas gravement touché par ce problème, nous vous recommandons d'attendre la prochaine mise à jour logicielles qui contiendra ce correctif.

Si le correctif est disponible pour le téléchargement, il est une section « téléchargement correctif disponible » en haut de cet article de la base de connaissances. Si cette section n'apparaît pas, contactez le service clientèle Microsoft et de support pour obtenir le correctif.

note Si des problèmes supplémentaires se produisent ou si n'importe quel dépannage est nécessaire, vous devrez peut-être créer une demande de service distincte. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes non traités par ce correctif spécifique. Pour une liste complète des Microsoft client service et support numéros de téléphone ou pour créer une demande de service distincte, reportez-vous au site de Web Microsoft suivant :
http://support.microsoft.com/contactus/?ws=support
note L'écran de « téléchargement correctif disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas la langue, il est car un correctif logiciel n'est pas disponible pour cette langue.

Conditions préalables

Windows XP SP2 pour appliquer le correctif doit être. Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
322389 Comment obtenir le dernier pack de service Windows XP

Demande de redémarrage

Vous devez redémarrer l'ordinateur après avoir appliqué le correctif.

Informations sur le remplacement de correctif

Le correctif n'en remplace aucun autre correctif.

Informations de fichier

La version anglaise de ce correctif dispose les attributs de fichier (ou attributs de fichier version ultérieure) répertoriés dans le tableau suivant. Les dates et heures de ces fichiers sont exprimées en temps universel coordonné (UTC). Lorsque vous affichez les informations de fichier, il est convertie en heure locale. Pour connaître le décalage entre l'heure UTC et l'heure locale, utilisez l'onglet Fuseau horaire dans l'outil Date et heure du Panneau de configuration.
   Date         Time   Version         Size       File name
   ----------------------------------------------------------
   25-Mar-2005  05:46  6.0.2900.2640   1,484,800  Shdocvw.dll

Informations d'installation de correctif

Avertissement Des problèmes graves peuvent se produire si modification incorrecte du Registre à l'aide de l'Éditeur du Registre ou en utilisant une autre méthode. Ces problèmes peuvent obliger à réinstaller votre système d'exploitation. Microsoft ne peut pas garantir que ces problèmes peuvent être résolus. Modifier le Registre à vos risques et périls.

note Cette mise à jour est également comprise dans mises à jour cumulatives commençant après MS05-025 (883939). La mise à jour cumulative ne nécessite pas les étapes suivantes pour activer le comportement modifié. Les modifications de Registre suivantes sont nécessaires uniquement si vous installez ce correctif spécifique (896017).

Après avoir installé ce correctif et redémarrez l'ordinateur, vous devez configurer un paramètre de Registre pour activer les modifications apportées par ce correctif. Pour ce faire, procédez comme suit :
  1. Quittez Internet Explorer si elle est en cours d'exécution.
  2. Cliquez sur Démarrer , cliquez sur Exécuter , tapez regedit et cliquez sur OK .
  3. Recherchez et cliquez ensuite la sous-clé de Registre suivante :
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
    note Si la sous-clé FeatureControl n'existe pas, ajoutez-le. Pour ce faire, procédez comme suit :
    1. Cliquez avec le bouton droit sur principal , pointez sur Nouveau et puis cliquez sur clé .
    2. Dans la zone Nouvelle touche # 1 , tapez FeatureControl et puis appuyez sur ENTRÉE.
  4. Cliquez avec le bouton droit sur FeatureControl , pointez sur Nouveau et puis cliquez sur clé .
  5. Dans la zone Nouvelle touche # 1 , tapez FEATURE_Enable_WindowOpen_when_ContentDisposition_Attachment_KB896017 et puis appuyez sur ENTRÉE.
  6. Cliquez avec le bouton droit sur FEATURE_Enable_WindowOpen_when_ContentDisposition_Attachment_KB896017 , pointez sur Nouveau et puis cliquez sur valeur DWORD .
  7. Dans la zone Nouvelle valeur # 1 , tapez iexplore.exe , puis appuyez sur ENTRÉE.
  8. Cliquez avec le bouton droit sur iexplore.exe , puis cliquez sur Modifier .
  9. Dans la zone données de la valeur , tapez 00000001 et puis cliquez sur OK .
  10. Quittez l'Éditeur du Registre.

Contournement

Pour contourner ce problème, modifiez le client code HTML pour utiliser une valeur « target » pour la commande POST envoyée au serveur. Par exemple, prenez l'exemple de code suivant :
 <form method="POST" action="download.asp">
Pour contourner ce problème, remplacez ce code d'exemple le code suivant :
 <form method="POST" action="download.asp" target="_top">

Statut

Microsoft a confirmé que c'est un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Plus d'informations

Pour plus d'informations, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
824684 Description de la terminologie standard utilisée pour décrire les mises à jour logicielles Microsoft

Propriétés

Numéro d'article: 896017 - Dernière mise à jour: mercredi 29 août 2007 - Version: 4.3
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Windows XP Service Pack 2 sur le système suivant
    • Microsoft Windows XP Media Center Edition
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows XP Édition familiale
    • Microsoft Windows XP Professional
Mots-clés : 
kbmt kbautohotfix kbbug kbfix kbqfe kbhotfixserver KB896017 KbMtfr
Traduction automatique
IMPORTANT : Cet article est issu du système de traduction automatique mis au point par Microsoft (http://support.microsoft.com/gp/mtdetails). Un certain nombre d?articles obtenus par traduction automatique sont en effet mis à votre disposition en complément des articles traduits en langue française par des traducteurs professionnels. Cela vous permet d?avoir accès, dans votre propre langue, à l?ensemble des articles de la base de connaissances rédigés originellement en langue anglaise. Les articles traduits automatiquement ne sont pas toujours parfaits et peuvent comporter des erreurs de vocabulaire, de syntaxe ou de grammaire (probablement semblables aux erreurs que ferait une personne étrangère s?exprimant dans votre langue !). Néanmoins, mis à part ces imperfections, ces articles devraient suffire à vous orienter et à vous aider à résoudre votre problème. Microsoft s?efforce aussi continuellement de faire évoluer son système de traduction automatique.
La version anglaise de cet article est la suivante: 896017
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com