Windows XP Service Pack 2 で Internet Explorer を使用してファイルをダウンロードするとき、[ファイルのダウンロード] ダイアログ ボックスを表示するウィンドウが突然閉じる

文書翻訳 文書翻訳
文書番号: 896017 - 対象製品
重要 : この資料には、レジストリの編集方法が記載されています。万一に備えて、編集の前には必ずレジストリをバックアップし、レジストリの復元方法を理解しておいてください。バックアップ、復元、および編集方法の詳細を参照するには、以下の「サポート技術情報」(Microsoft Knowledge Base) をクリックしてください。
256986 Microsoft Windows レジストリの説明
すべて展開する | すべて折りたたむ

目次

現象

Microsoft Internet Explorer を使用してファイルをダウンロードすると、以下の現象が発生する場合があります。

[ファイルのダウンロード] ダイアログ ボックスにある [保存]、[開く]、または [キャンセル] をクリックすると、[ファイルのダウンロード] ダイアログ ボックスが表示されているウィンドウが予期せず終了します。

原因

この問題は、Windows XP Service Pack 2 (SP2) を実行している場合に発生することがあります。この現象は、Windows XP SP2 で Internet Explorer を実行したときに Internet Explorer の動作が変わることにより発生します。

ポップアップ ウィンドウからのダウンロードを処理するときの MIME 処理機能が変更されました。この場合、"content-disposition; attachment" HTTP ヘッダーを使用して、ダウンロードしたコンテンツを Web サーバーから送信したとき、MIME 処理機能によりポップアップ ウィンドウが閉じます。

解決方法

修正プログラムの情報

マイクロソフトでは、現在この問題を修正する修正プログラムを提供中ですが、修正プログラムはこの資料に記載された問題のみを修正することを目的としており、障害があったコンピュータに対してのみ適用することを推奨します。この修正プログラムは、今後さらにテストを行う場合があります。この問題で深刻な影響を受けていない場合は、この修正プログラムが含まれる次のソフトウェア更新プログラムがリリースされるまで待つことを推奨します。

修正プログラムをダウンロードできる場合は、この「サポート技術情報」(Microsoft Knowledge Base) の資料の上部に「修正プログラムのダウンロード」セクションがあります。このセクションが表示されない場合は、Microsoft Customer Service and Support に問い合わせて修正プログラムを入手してください。

: 別の問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストを作成することが必要になる場合があります。特定の修正プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。Microsoft Customer Service and Support の電話番号一覧、または別のサービス リクエストを作成する方法については、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
:「ダウンロード」フォームには、修正プログラムを入手できる言語が表示されます。使用している言語が表示されない場合は、その言語の修正プログラムが存在しないことになります。

必要条件

: Windows XP SP2 をインストールしてからこの修正プログラムを適用する必要があります。 関連情報を参照するには、以下の「サポート技術情報」(Microsoft Knowledge Base) をクリックしてください。
322389 最新の Windows XP Service Pack を入手する方法

再起動の必要性

この修正プログラムの適用後に、コンピュータを再起動する必要があります。

修正プログラムの置き換えに関する情報

この更新プログラムを適用しても、他の更新プログラムが置き換えられることはありません。

ファイル情報

修正プログラム (英語版) のファイル属性は次表のとおりです。ただし、これより新しい修正プログラムがリリースされている可能性もあります。各ファイルの日付および時刻は、世界協定時刻 (UTC) で示されています。ファイル情報に表示される時刻は、ローカル時刻に変換されています。UTC とローカル時刻との時差を確認するには、コントロール パネルの [日付と時刻] の [タイム ゾーン] タブを使用してください。
   日付           時刻    バージョン           サイズ     ファイル名
   ----------------------------------------------------------
25-Mar-2005  05:46  6.0.2900.2640   1,484,800  Shdocvw.dll

修正プログラムのインストール情報

警告 : レジストリ エディタまたは別の方法を使用してレジストリを誤って変更すると、深刻な問題が発生することがあります。最悪の場合、オペレーティング システムの再インストールが必要になることがあります。マイクロソフトは、レジストリの変更により発生した問題に関しては、一切責任を負わないものとします。レジストリの変更は、自己の責任において行ってください。

: この更新プログラムは、セキュリティ更新プログラム 883939 (MS05-025) 以降の累積的な更新プログラムにも含まれています。この累積的な更新プログラムは、以下に示す変更された動作を有効にするための手順を必要としません。この修正プログラム (896017) をインストールした場合のみ、以下のレジストリ変更が必要です。

この修正プログラムをインストールしてコンピュータを再起動したら、レジストリ設定を構成して、この修正プログラムで行われた変更を有効にする必要があります。これを行うには、次の手順を実行します。
  1. Internet Explorer が実行中の場合は終了します。
  2. [スタート] ボタンをクリックし、[検索の開始] ボックスに regedit と入力し、Enter キーを押します。
  3. 次のレジストリ サブキーを見つけてクリックします。
    HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Main\FeatureControl
    : FeatureControl サブキーが存在しない場合は、このサブキーを追加します。これを行うには、次の手順を実行します。
    1. [Main] を右クリックし、[新規] をポイントし、[キー] をクリックします。
    2. [新しいキー #1] ボックスに、FeatureControl と入力し、Enter キーを押します。
  4. [FeatureControl] を右クリックし、[新規] をポイントし、[キー] をクリックします。
  5. [新しいキー #1] ボックスに、FEATURE_Enable_WindowOpen_when_ContentDisposition_Attachment_KB896017 と入力して、Enter キーを押します。
  6. [FEATURE_Enable_WindowOpen_when_ContentDisposition_Attachment_KB896017] を右クリックし、[新規] をポイントし、[DWORD 値] をクリックします。
  7. [新しい値 #1] ボックスに、iexplore.exe と入力し、Enter キーを押します。
  8. [iexplore.exe] を右クリックし、[修正] (または [変更]) をクリックします。
  9. [値のデータ] ボックスに 00000001 と入力し、[OK] をクリックします。
  10. レジストリ エディタを終了します。

回避策

この問題を回避するには、サーバーに送信される POST コマンドに "target" 値を使用するようにクライアントの HTML コードを変更します。たとえば、次のようなサンプル コードを検討します。
 <form method="POST" action="download.asp">
この問題を回避するには、このサンプル コードを次のコードに変更します。
 <form method="POST" action="download.asp" target="_top">

状況

マイクロソフトでは、この問題をこの資料の対象製品として記載されているマイクロソフト製品の問題として認識しています。

詳細

関連情報を参照するには、以下の「サポート技術情報」(Microsoft Knowledge Base) をクリックしてください。
824684 マイクロソフトのソフトウェアの更新で使用される一般的な用語の説明

プロパティ

文書番号: 896017 - 最終更新日: 2008年8月7日 - リビジョン: 4.3
この資料は以下の製品について記述したものです。
  • Microsoft Windows XP Service Pack 2?を以下の環境でお使いの場合
    • Microsoft Windows XP Media Center Edition
    • Microsoft Windows XP Tablet PC Edition
    • Microsoft Windows XP Home Edition
    • Microsoft Windows XP Professional
キーワード:?
kbautohotfix kbbug kbfix kbqfe kbhotfixserver KB896017
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com