Le magasin de bases de données Exchange peut ne pas être monté dans Exchange Server 2003 ou Exchange 2000 Server et les ID d'événement 9175, 486, 455, 413 et 5 peuvent être enregistrés

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Sommaire

Symptômes

Lorsque vous essayez de monter une base de données sur un serveur exécutant Microsoft Exchange 2000 Server ou Microsoft Exchange Server 2003, le message d'erreur suivant peut s'afficher :
Une erreur de traitement interne s'est produite. Essayez de redémarrer le Gestionnaire système Exchange, le service de banque d'informations Microsoft Exchange ou les deux.
ID de l'erreur : c1041724
Gestionnaire système Exchange
En outre, les événements suivants peuvent être enregistrés dans le journal d'applications :

Type d'événement : Erreur
Source de l'événement : MSExchangeSA
Catégorie de l'événement : (14)
ID de l'événement : 9175
Description : L'appel MAPI 'OpenMsgStore' a échoué avec l'erreur suivante : L'ordinateur Microsoft Exchange Server n'est pas disponible. Soit des problèmes de réseau sont survenus, soit l'ordinateur Microsoft Exchange Server est arrêté pour maintenance. Échec du fournisseur MAPI. ID de l'erreur de la banque d'informations Microsoft Exchange Server : 8004011d-0526-00000000

Type d'événement : Erreur
Source de l'événement : ESE
Catégorie de l'événement : Général
ID de l'événement : 486
Description : Banque d'informations (3932) Premier groupe de stockage : Une tentative de déplacement du fichier "E:\Program Files\Exchsrvr\mdbdata\E00.log" vers "E:\Program Files\Exchsrvr\mdbdata\E000080A.log" a échoué en indiquant l'erreur système 2 (0x00000002) : "Le système ne trouve pas le fichier spécifié." L'opération de déplacement de fichier échouera en indiquant l'erreur -1811 (0xfffff8ed).

Type d'événement : Erreur
Source de l'événement : Événement ESE
Catégorie : Enregistrement/Récupération
ID de l'événement : 455
Description : eseutil (4724) L'erreur -1811 (0xfffff8ed) s'est produite lors de l'ouverture d'un fichier journal lettre_lecteur:\Program Files\Exchsrvr\MDBDATA\E00.log.

Type d'événement : Erreur
Source de l'événement : Événement ESE
Catégorie : Enregistrement/Récupération
ID de l'événement : 455
Description : eseutil (2352) L'erreur -1811 s'est produite lors de l'ouverture d'un fichier journal lettre_lecteur:\Program Files\Exchsrvr\MDBDATA\E000080A.log.

Type d'événement : Erreur
Source de l'événement : MSExchangeIS
Catégorie de l'événement : Général
ID de l'événement : 9518
Description : Erreur Fichier journal actuel manquant lors du démarrage du groupe de stockage /DC=COM/DC=COMPANY/CN=CONFIGURATION/CN=SERVICES/CN=MICROSOFT EXCHANGE/CN=MICROSOFT/CN=ADMINISTRATIVE GROUPS/CN=FIRST ADMINISTRATIVE GROUP/CN=SERVERS/CN=SERVER1/CN=INFORMATIONSTORE/CN=FIRST STORAGE GROUP sur la banque d'informations Microsoft Exchange.

Type d'événement : Erreur
Source de l'événement : ESE
Catégorie de l'événement : Enregistrement/Récupération
ID de l'événement : 413
Description : Banque d'informations (3932) Premier groupe de stockage : Impossible de créer le fichier journal car la base de données ne peut pas écrire sur le lecteur. Ce lecteur est probablement en lecture seule, mal configuré ou endommagé ou son espace disque est insuffisant. Erreur -1811.

Type d'événement : Erreur
Source de l'événement : Nom_programme_antivirus
Catégorie de l'événement : Aucune
ID de l'événement : 5
Description : La description pour l'ID d'événement (5) dans la source (Nom_programme_antivirus) est introuvable. L'ordinateur local n'a peut-être pas les informations de Registre ou les librairies requises pour afficher les messages émanant d'un ordinateur distant. Vous pourrez peut-être utiliser l'option /AUXSOURCE = pour récupérer cette description. Reportez-vous aux rubriques Aide et support pour plus de détails. Les informations suivantes font partie de l'événement : Virus trouvé ! Nom de virus : W32.Netsky.P@mm dans le fichier : E:\Program Files\Exchsrvr\mdbdata\E00.log par : Analyse de protection en temps réel. Action : La quarantaine a réussi : Accès refusé.

Type d'événement : Erreur
Source de l'événement : Nom_programme_antivirus
Catégorie de l'événement : Aucune
ID de l'événement : 5
Description : La description pour l'ID d'événement (5) dans la source (Nom_programme_antivirus) est introuvable. L'ordinateur local n'a peut-être pas les informations de Registre ou les librairies requises pour afficher les messages émanant d'un ordinateur distant. Vous pourrez peut-être utiliser l'option /AUXSOURCE = pour récupérer cette description. Reportez-vous aux rubriques Aide et support pour plus de détails. Les informations suivantes font partie de l'événement : Virus trouvé ! Nom de virus : W32.Netsky.P@mm!enc dans le fichier : E:\Program Files\Exchsrvr\Mailroot\vsi 1\Queue\NTFS_216f566e01c43c76000002af.EML par : Analyse de protection en temps réel. Action : Le nettoyage a échoué : La quarantaine a échoué : Accès refusé.

Cause

  • Cause 1
    L'erreur 1811 correspond à JET_errFileNotFound. Ce problème peut se produire dans un fichier journal Exchange dont la signature et la valeur lGeneration ne correspondent pas. En général, le fichier journal Exchange est le fichier E00.log. Si la signature du fichier E00.log ne correspond pas, la banque d'informations peut ne pas être montée même si la base de données est cohérente. Pour résoudre ce problème, reportez-vous à la section « Résolution 1 ».
  • Cause 2
    Ce problème peut se produire si un programme antivirus met en quarantaine ou supprime le fichier journal Exchange actuel. Pour résoudre ce problème, reportez-vous à la section « Résolution 2 ».
  • Cause 3
    Ce problème peut se produire si la commande eseutil /p a été exécutée sur les bases de données concernées et que les fichiers journaux n'ont pas été supprimés. Pour résoudre ce problème, reportez-vous à la section « Résolution 3 ».
  • Cause 4
    Ce problème peut se produire si vous exécutez la commande suivante avec un nom de base de fichier journal incorrect, comme illustré dans l'exemple suivant :
    eseutil /r nom de base de fichier journal à trois caractères
    Pour résoudre ce problème, reportez-vous à la section « Résolution 4 ».

Résolution

Résolution 1

Contactez les services de Support technique Microsoft. Pour plus d'informations sur la façon de contacter le Support technique Microsoft, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com

Résolution 2

  1. Examinez la configuration du programme antivirus.
    1. Assurez-vous que votre programme antivirus n'est pas configuré pour analyser les répertoires Exchange Server.
    2. Par défaut, certains programmes antivirus sont configurés pour analyser des lecteurs et des répertoires chaque semaine en mode manuel ou automatique. Ce paramètre est fréquemment oublié. Veillez à ajouter les répertoires Exchange Server à la liste d'emplacements exclus pour le programme antivirus. Pour plus d'informations sur la façon de configurer des programmes antivirus pour fonctionner avec Exchange, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
      823166 Aperçu d'Exchange Server 2003 et de logiciel antivirus
  2. Examinez les fichiers journaux du programme antivirus pour vérifier si le fichier journal Exchange a été mis en quarantaine ou supprimé.
  3. Appliquez l'une des méthodes ci-dessous pour récupérer le fichier journal Exchange.

    Méthode 1 : Si le fichier journal Exchange a été mis en quarantaine

    Si le fichier journal Exchange a été mis en quarantaine, procédez comme suit :
    1. Restaurez le journal Exchange dans le dossier contenant vos fichiers journaux de production.
    2. Démarrez le service de banque d'informations Microsoft Exchange. Si aucun autre fichier journal ne manque, la base de données est montée. Si d'autres fichiers journaux sont manquants, vérifiez si les fichiers journaux manquants sont situés dans le dossier de quarantaine du programme antivirus. Si les fichiers journaux ne sont pas situés dans ce dossier, suivez les étapes décrites dans la section « Méthode 2 : Si le fichier journal Exchange a été supprimé ».

    Méthode 2 : Si le fichier journal Exchange a été supprimé

    Si le fichier journal Exchange a été supprimé, vous devez restaurer la base de données Groupe de stockage à partir d'une sauvegarde. Ensuite, vous devez lire les fichiers journaux. Si vous ne pouvez pas restaurer la base de données à partir d'une sauvegarde, reportez-vous à la section « Méthode 3 : Si vous ne pouvez pas restaurer la base de données à partir d'une sauvegarde ». Pour restaurer une base de données disponible, procédez comme suit :
    1. Déplacez toutes les bases de données incohérentes vers un dossier de sauvegarde.
    2. Si un nouveau fichier E00.log a été créé, déplacez le nouveau fichier E00.log vers le dossier de sauvegarde. En outre, déplacez le fichier E00.chk vers le dossier de sauvegarde.
    3. Copiez tous les fichiers journaux existants dans le dossier de sauvegarde.

      Remarque Vous devez copier les fichiers journaux. Ne les déplacez pas.
    4. Renommez le dernier fichier E00*.log en E00.log.
    5. Restaurez la base de données à partir d'une sauvegarde. Ensuite, relisez les fichiers journaux. Cette procédure met la base de données dans un état cohérent. Toutefois, la base de données n'inclut pas le fichier E00.log qui a été copié dans le dossier de sauvegarde. Bien que cela entraîne une perte de données, vous disposez maintenant d'une base de données qui peut être montée.
    6. Démarrez le service de banque d'informations Microsoft Exchange.

    Méthode 3 : Si vous ne pouvez pas restaurer la base de données à partir d'une sauvegarde

    Si vous ne pouvez pas restaurer la base de données à partir d'une sauvegarde, vous devez exécuter des utilitaires de réparation sur la base de données pour la mettre dans un état cohérent. Ensuite, suivez les étapes décrites dans la section « Méthode 2 : Si le fichier journal Exchange a été supprimé ».

Résolution 3

Pour déterminer si la commande eseutil /p a été exécutée, procédez comme suit :
  1. Cliquez sur Démarrer, sur Exécuter, tapez cmd, puis cliquez sur OK.
  2. À l'invite, tapez la commande suivante :
    c:\program files\exchsrvr\bin\eseutil /mh "c:\program files\exchsrvr\mdbdata\nom_base_de_données_Exchange.edb"
    Remarque Cet exemple suppose les conditions suivantes :
    • Les fichiers programme Exchange Server ont été installés dans le dossier c:\program files\exchsrvr.
    • Votre base de données est située dans le dossier c:\program files\exchsrvr\mdbdata.
  3. Lisez l'attribut de nombre de réparations. Si l'attribut de nombre de réparations a pour valeur 0 (zéro), la commande eseutil /p n'a pas été exécutée. Si l'attribut de nombre de réparations a une valeur différente de 0, la commande eseutil /p a été exécutée sur la base de données.
Si les bases de données publiques et privées sont dans un état cohérent ou d'« arrêt correct », vous pouvez déplacer les fichiers du journal des transactions vers un autre dossier. Pour déterminer si les bases de données sont dans un état cohérent ou d'arrêt correct, procédez comme suit :
  1. Cliquez sur Démarrer, sur Exécuter, tapez cmd, puis cliquez sur OK.
  2. Pour examiner la banque d'informations privée, tapez les éléments suivants :
    c:\program files\exchsrvr\bin>eseutil /mh "lecteur:\program files\exchsrvr\mdbdata\priv1.edb"
  3. Pour examiner la banque d'informations publique, tapez les éléments suivants :
    c:\program files\exchsrvr\bin>eseutil /mh "lecteur:\program files\exchsrvr\mdbdata\pub1.edb"
    Remarque Ces exemples supposent les conditions suivantes :
    • Les fichiers programme Exchange Server ont été installés dans le dossier c:\program files\exchsrvr.
    • Votre base de données est située dans le dossier c:\program files\exchsrvr\mdbdata.
  4. Examinez les résultats de la vérification de cohérence. Si la base de données est cohérente (état = arrêt correct), tous les fichiers journaux ont été validés dans la banque d'informations. Si la base de données n'est pas cohérente (état = arrêt incorrect), elle n'est peut-être pas endommagée. Il est possible que les fichiers journaux n'aient pas encore été validés dans la base de données.
  5. Si l'état est « arrêt normal »", déplacez tous les fichiers journaux de tous les répertoires mdbdata vers un répertoire de sauvegarde.
  6. Montez les bases de données.

Résolution 4

Utilisez le commutateur correct pour exécuter la commande avec succès. Les noms de base des fichiers journaux courants sont e00, e01, e02 et e03. Par exemple, la commande suivante contient un nom de base de fichier journal correct :
eseutil /r e00
Remarque Si le problème persiste après ces résolutions, contactez les services de Support technique Microsoft. Pour plus d'informations sur la façon de contacter le Support technique Microsoft, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com

Références

Pour plus d'informations sur la récupération de données dans Exchange 2000 Server et Exchange Server 2003, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://www.microsoft.com/france/technet/prodtechnol/exchange/2003/library/disrecopgde.mspx
Pour obtenir les coordonnées du fournisseur de votre logiciel antivirus, cliquez sur le numéro approprié ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
65416 Liste des fournisseurs tiers de matériels et de logiciels, A-K

60781 Liste des fournisseurs tiers de matériels et de logiciels, L-P

60782 Liste des fournisseurs tiers de matériels et de logiciels, Q-Z
Pour plus d'informations sur la commande Eseutil, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft.
170091 Emplacement de l'utilitaire Eseutil
Pour plus d'informations, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft.
245822 Recommandations pour dépanner un ordinateur Exchange Server sur lequel un logiciel antivirus est installé
244525 Comment faire pour exécuter Eseutil sur un ordinateur dépourvu de Microsoft Exchange Server
317014 Commutateurs de ligne de commande de l'utilitaire Eseutil d'Exchange 2000 Server
261947 Comment faire pour déterminer si une réparation matérielle (Eseutil /p) a été effectuée sur une base de données
255224 Le message d'erreur « Erreur d'utilisation : Argument non valide » s'affiche si le nom de dossier de groupe de stockage dans le chemin d'accès contient des espaces lorsque vous exécutez Eseutil dans Exchange 2000 Server

Propriétés

Numéro d'article: 896143 - Dernière mise à jour: lundi 3 décembre 2007 - Version: 3.2
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Mots-clés : 
kbtshoot kbprb KB896143
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