O armazenamento de banco de dados do Exchange pode não montar no Exchange Server 2003 ou no Exchange 2000 Server e as identificações de evento 9175, 486, 455, 413 e 5 podem ser registradas

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Sintomas

Ao tentar montar um banco de dados em um servidor executando o Microsoft Exchange 2000 Server ou em um servidor executando o Microsoft Exchange Server 2003, a seguinte mensagem de erro pode ser exibida:
Um erro de processamento interno ocorreu. Tente reiniciar o Exchange System Manager ou o serviço de armazenamento de informações do Microsoft Exchange, ou ambos.
Nº da identificação: c1041724
Exchange System Manager
Além disso, as seguintes entradas podem estar registradas no log do aplicativo:

Tipo de evento: Erro
Fonte: MSExchangeSA
Categoria: (14)
Identificação do evento: 9175
Descrição: A chamada MAPI "OpenMsgStore" falhou com o seguinte erro: O computador do Microsoft Exchange Server não está disponível. Pode haver problemas de rede ou o computador do Microsoft Exchange Server está necessitando de manutenção. O provedor MAPI falhou. Identificação do armazenamento de informações do Microsoft Exchange Server: 8004011d-0526-00000000

Tipo de evento: Erro
Fonte: ESE
Categoria: Geral
Identificação do evento: 486
Descrição: Armazenamento de informações (3932) Primeiro grupo de armazenamento: Falha ao tentar mover o arquivo "E:\Arquivos de programas\Exchsrvr\mdbdata\E00.log" para "E:\Arquivos de programas\Exchsrvr\mdbdata\E000080A.log" com o erro de sistema 2 (0x00000002): O sistema não pôde encontrar o arquivo especificado. Falha na operação de movimentação de arquivo com o erro -1811 (0xfffff8ed).

Tipo de evento: Erro
Fonte: Evento ESE
Categoria: Log/recuperação
Identificação do evento: 455
Descrição: eseutil (4724) Erro -1811 (0xfffff8ed) ocorreu ao abrir o arquivo de log letra_da_unidade:\Arquivos de programa\Exchsrvr\MDBDATA\E00.log.

Tipo de evento: Erro
Fonte: Evento ESE
Categoria: Log/recuperação
Identificação do evento: 455
Descrição: eseutil (2352) Erro -1811 ocorreu ao abrir o arquivo de log letra_da_unidade:\Arquivos de programa\Exchsrvr\MDBDATA\E000080A.log.

Tipo de evento: Erro
Fonte: MSExchangeIS
Categoria: Geral
Identificação do evento: 9518
Descrição: Erro de log de arquivo ao procurar a inicialização do Grupo de armazenamento /DC=COM/DC=COMPANY/CN=CONFIGURATION/CN=SERVICES/CN=MICROSOFT EXCHANGE/CN=MICROSOFT/CN=ADMINISTRATIVE GROUPS/CN=FIRST ADMINISTRATIVE GROUP/CN=SERVERS/CN=SERVER1/CN=INFORMATIONSTORE/CN=FIRST STORAGE GROUP no Microsoft Exchange Information Store.

Tipo de evento: Erro
Fonte: ESE
Categoria: Log/recuperação
Identificação do evento: 413
Descrição: Armazenamento de informações (3932) Primeiro grupo de armazenamento: Não é possível criar um novo arquivo de log pois o banco de dados não pode gravar na unidade do log. A unidade pode ser somente leitura, estar sem espaço em disco, configurada incorretamente ou corrompida. Erro -1811.

Tipo de evento: Erro
Fonte: Nome_do_programa_antivírus
Categoria: Nenhuma
Identificação do evento: 5
Descrição: A descrição para a Identificação de evento ( 5 ) na Fonte ( Nome_do_programa_antivírus ) não pode ser encontrada. O computador local pode não ter as informações de registro necessárias ou os arquivos DLL de mensagem para exibir as mensagens a partir de um computador remoto. Talvez seja possível usar o sinalizador /AUXSOURCE= para recuperar essa descrição. Consulte a Ajuda e suporte para obter detalhes. As seguintes informações fazem parte do evento: Vírus encontrado! Nome do vírus: W32.Netsky.P@mm no arquivo: E:\Arquivos de programas\Exchsrvr\mdbdata\E00.log por: Realtime Protection scan. Ação: Quarentena bem-sucedida: Acesso negado.

Tipo de evento: Erro
Fonte: Nome_do_programa_antivírus
Categoria: Nenhuma
Identificação do evento: 5
Descrição: A descrição para a Identificação de evento ( 5 ) na Fonte ( Nome_do_programa_antivírus ) não pode ser encontrada. O computador local pode não ter as informações de registro necessárias ou os arquivos DLL de mensagem para exibir as mensagens a partir de um computador remoto. Talvez seja possível usar o sinalizador /AUXSOURCE= para recuperar essa descrição. Consulte a Ajuda e suporte para obter detalhes. As seguintes informações fazem parte do evento: Vírus encontrado! Nome do vírus: W32.Netsky.P@mm!enc no arquivo: E:\Arquivos de programas\Exchsrvr\Mailroot\vsi 1\Queue\NTFS_216f566e01c43c76000002af.EML por: Realtime Protection scan. Ação: Falha na limpeza: Falha na quarentena: Acesso negado.

Causa

  • Causa 1
    O erro 1811 corresponde ao JET_errFileNotFound. Este problema pode ocorrer em um arquivo de log do Exchange com uma assinatura e LGeneration que não correspondem. Normalmente, o arquivo de log do Exchange é o arquivo E00.log. Se o arquivo E00.log tiver uma assinatura não compatível, o armazenamento de informações talvez não possa ser montado, mesmo se o banco de dados for consistente. Para resolver este problema, consulte a seção "Resolução 1".
  • Causa 2
    Este problema pode ocorrer se um programa antivírus colocar em quarentena ou excluir o arquivo de log atual do Exchange. Para resolver este problema, consulte a seção "Resolução 2".
  • Causa 3
    Este problema pode ocorrer se o comando eseutil /p foi executado nos bancos de dados afetados e se os arquivos de log não foram removidos. Para resolver este problema, consulte a seção "Resolução 3".
  • Causa 4
    Este problema pode ocorrer se o seguinte comando for executado com um nome de base de arquivo de log incorreto, como no seguinte exemplo:
    eseutil /r nome de base do arquivo de log com três caracteres
    Para resolver este problema, consulte a seção "Resolução 4".

Resolução

Resolução 1

Entre em contato com o Atendimento Microsoft (PSS). Para obter informações adicionais sobre como entrar em contato com o Atendimento Microsoft, visite o seguinte site da Microsoft:
http://support.microsoft.com

Resolução 2

  1. Examine a configuração do programa antivírus.
    1. Verifique se o programa antivírus não está configurado para examinar os diretórios do Exchange Server.
    2. Por padrão, alguns programas antivírus são definidos para examinar unidades e diretórios semanalmente em um modo manual ou em um modo automático. Essa configuração pode ser facilmente verificada. Verifique se os diretórios do Exchange Server foram adicionados aos locais excluídos do programa antivírus. Para obter informações adicionais sobre como configurar os programas antivírus para funcionarem junto com o Exchange, clique no número abaixo para ler o artigo na Base de Dados de Conhecimento Microsoft (a página pode estar em inglês):
      823166 Visão geral do Exchange Server 2003 e do software antivírus
  2. Revise os arquivos de log no programa antivírus para verificar se o arquivo de log do Exchange foi colocado em quarentena ou foi excluído.
  3. Use um dos seguintes métodos pra recuperar o arquivo de log do Exchange.

    Método 1: Se o arquivo de log do Exchange foi colocado em quarentena

    Se o arquivo de log do Exchange tiver sido colocado em quarentena, execute as seguintes etapas:
    1. Recupere o arquivo de log do Exchange na pasta que contém seus arquivos de log de produção.
    2. Inicie o serviço Microsoft Exchange Information Store. Se nenhum outro arquivo de log estiver ausente, o banco de dados montará. Se outros arquivos de log estiverem ausentes, verifique se esses arquivos estão localizados na pasta de quarentena do programa antivírus. Se não estiverem, execute as etapas descritas na seção "Método 2: Se o arquivo de log do Exchange tiver sido excluído".

    Método 2: Se o arquivo de log do Exchange tiver sido excluído

    Se o arquivo de log do Exchange tiver sido excluído, será necessário restaurar o banco de dados do Grupo de armazenamento de um backup. Em seguida, será necessário verificar os arquivos de log. Se não for possível restaurar o banco de dados de um backup, consulte a seção "Método 3: Se não for possível restaurar o banco de dados de um backup". Para restaurar um banco de dados disponível, execute as seguintes etapas:
    1. Mova todos os bancos de dados inconsistentes para uma pasta de backup.
    2. Se um novo arquivo E00.log tiver sido criado, mova o novo arquivo E00.log para a pasta de backup. Além disso, mova o arquivo E00.chk para a pasta de backup.
    3. Copie todos os arquivos de log existentes na pasta de backup.

      Observação É necessário copiar os arquivos de log. Não mova os arquivos de log.
    4. Renomeie o último arquivo E00*.log para E00.log.
    5. Restaure o banco de dados de um backup. Em seguida, verifique novamente os arquivos de log. Isso faz com que o banco de dados fique em um estado consistente. No entanto, o banco de dados não inclui o arquivo E00.log copiado para a pasta de backup. Embora ocorra alguma perda de dados, agora o banco de dados pode ser montado.
    6. Inicie o serviço Microsoft Exchange Information Store.

    Método 3: Se não for possível restaurar o banco de dados de um backup

    Se não for possível restaurar o banco de dados de um backup, será necessário executar os utilitários de reparo no banco de dados para fazer que com ele fique em um estado consistente. Em seguida, execute as etapas descritas na seção "Método 2: Se o arquivo de log do Exchange tiver sido excluído".

Resolução 3

Para determinar se o comando eseutil /p foi executado, execute as seguintes etapas:
  1. Clique em Iniciar, em Executar, digite cmd e clique em OK.
  2. Digite o seguinte no prompt de comando:
    c:\arquivos de programas\exchsrvr\bin\eseutil /mh "c:\arquivos de programas\exchsrvr\mdbdata\nome do banco de dados.edb do Exchange"
    Observação Este exemplo presume o seguinte:
    • Os arquivos de programa do Exchange Server foram instalados na pasta c:\arquivos de programa\exchsrvr.
    • Seu banco de dados está na pasta c:\arquivos de programa\exchsrvr\mdbdata.
  3. Leia o atributo de contagem de reparo. Se o atributo de contagem de reparo for 0 (zero), o comando eseutil /p não terá sido executado. Se o atributo for um número diferente de 0, o comando eseutil /p terá sido executado no banco de dados.
Se os bancos de dados públicos e particulares estiverem em um estado consistente ou de desligamento limpo, será possível mover os arquivos de log de transação para outra pasta. Para determinar se os bancos de dados estão em um estado consistente ou de desligamento limpo, execute as seguintes etapas:
  1. Clique em Iniciar, em Executar, digite cmd e clique em OK.
  2. Para examinar o armazenamento de informações particulares, digite o seguinte:
    c:\arquivos de programas\exchsrvr\bin>eseutil /mh "unidade:\arquivos de programas\exchsrvr\mdbdata\priv1.edb"
  3. Para examinar o armazenamento de informações públicas, digite o seguinte:
    c:\arquivos de programas\exchsrvr\bin>eseutil /mh "unidade:\arquivos de programas\exchsrvr\mdbdata\pub1.edb"
    Observação Estes exemplos presumem o seguinte:
    • Os arquivos de programa do Exchange Server foram instalados na pasta c:\arquivos de programa\exchsrvr.
    • Seu banco de dados está na pasta c:\arquivos de programa\exchsrvr\mdbdata.
  4. Revise os resultados da verificação de consistência. Se um banco de dados estiver consistente (estado = desligamento limpo), todos os arquivos de log terão sido enviados ao armazenamento de informações. Se o banco de dados não estiver consistente (estado = desligamento sujo), o banco de dados poderá estar corrompido. Possivelmente, os arquivos de log ainda não terão sido enviados ao banco de dados.
  5. Se o estado reportar o desligamento limpo, mova todos os arquivos de log de todos os diretórios mdbdata para uma pasta de backup.
  6. Monte os bancos de dados.

Resolução 4

Use a opção correta para executar com êxito o comando. Os nomes de base comuns do arquivo de log são e00, e01, e02 e e03. Por exemplo, o seguinte comando contém um nome de base de arquivo de log correto:
eseutil /r e00
Observação Se nenhuma dessas resoluções funcionar, entre em contato com o Atendimento Microsoft (PSS). Para obter informações adicionais sobre como entrar em contato com o Atendimento Microsoft, visite o seguinte site da Microsoft:

Referências

Para obter informações adicionais sobre a recuperação de dados no Exchange Server 2003 e no Exchange 2000 Server, visite o seguinte site da Microsoft (em inglês):
http://technet.microsoft.com/en-us/library/f9a66c19-b1e0-46c4-a6a1-276a569a08bf.aspx
Para obter informações sobre como entrar em contato com fornecedor do software, clique no número apropriado na seguinte lista para ler o artigo na Base de Dados de Conhecimento da Microsoft:
65416 Lista de informações para contato de fornecedores de hardware e software de terceiros, de A a K

60781 Informações para contato com fornecedores de hardware e software de L a P

60782 Informações para contato com fornecedores de hardware e software de Q a Z
Para obter informações adicionais sobre este problema, clique nos números abaixo para ler os artigos na Base de Dados de Conhecimento Microsoft (alguns artigos podem estar em inglês):
170091 Local do utilitário Eseutil
Para obter informações adicionais, clique nos números abaixo para ler os artigos na Base de Dados de Conhecimento Microsoft (alguns artigos podem estar em inglês):
245822 Recomendações para a solução de problemas em um computador com o Exchange com software antivírus instalado
244525 Como executar o Eseutil em um computador sem o Exchange Server
317014 Opções de linha de comando Eseutil do Exchange 2000 Server
261947 Como determinar se um reparo (Eseutil /p) foi executado em um banco de dados
255224 Você recebe "Erro de uso: Argumento inválido" se o nome da pasta do grupo de armazenamento no caminho contiver espaços ao executar o Eseutil no Exchange 2000 Server

Propriedades

ID do artigo: 896143 - Última revisão: segunda-feira, 3 de dezembro de 2007 - Revisão: 3.3
A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Enterprise Server
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Palavras-chave: 
kbtshoot kbprb KB896143

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