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The RSH command does not accept input that is piped from a file in Windows XP Professional with Service Pack 2 and in Windows Server 2003 with Service Pack 1

Article ID:896336
Last Review:November 3, 2007
Revision:3.7
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SYMPTOMS

When you use the RSH command on a computer that is running Microsoft Windows XP Professional with Service Pack 2 (SP2), the RSH command does not accept input that is piped from a file.

For example, this behavior occurs when you use the following command to read input from a text file instead of from the keyboard:
rsh HostName -l User_Name Command < Input_File_Name.txt
Note Command specifies the command that you want to run on the remote host.

Additionally, you may receive an error message that is similar to the following:
Terminal read: The handle is invalid.

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CAUSE

This problem occurs because the RSH command accepts input only from the keyboard in Windows XP SP2.

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RESOLUTION

Windows Server 2003

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Windows Server 2003 service pack information

To resolve this problem, obtain the latest service pack for Windows Server 2003. For more information, click the following article number to view the article in the Microsoft Knowledge Base:
889100 (http://support.microsoft.com/kb/889100/) How to obtain the latest service pack for Windows Server 2003

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Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix has no prerequisites.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows Server 2003, x86-based versions
Date         Time   Version         Size    File name 
-------------------------------------------------------------- 
21-Sep-2005  01:09  5.2.3790.2532  13,824   Rexec.exe 
21-Sep-2005  01:09  5.2.3790.2532  14,848   Rsh.exe
Windows Server 2003, Itanium-based versions
Date         Time   Version         Size    File name 
-------------------------------------------------------------- 
20-Sep-2005  11:54  5.2.3790.2532  26,624   Rexec.exe IA-64 
20-Sep-2005  11:54  5.2.3790.2532  28,672   Rsh.exe IA-64 
20-Sep-2005  11:54  5.2.3790.2532  13,824   Wrexec.exe x86 
20-Sep-2005  11:54  5.2.3790.2532  14,848   Wrsh.exe x86
Windows Server 2003, x64-based versions
Date         Time   Version          Size   File name 
-------------------------------------------------------------- 
20-Sep-2005  11:54  5.2.3790.2532   18,432  Rsh.exe 
20-Sep-2005  11:54  5.2.3790.2532   13,824  Wrexec.exe 
20-Sep-2005  11:54  5.2.3790.2532   14,848  Wrsh.exe

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Windows XP

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Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

This hotfix has no prerequisites.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace any other hotfixes.

File information

The English version of this hotfix has the file attributes (or later file attributes) that are listed in the following table. The dates and times for these files are listed in Coordinated Universal Time (UTC). When you view the file information, it is converted to local time. To find the difference between UTC and local time, use the Time Zone tab in the Date and Time tool in Control Panel.
Windows XP SP2
Date        Time   Version       Size    File name
----------------------------------------------------
30-Mar-2005 01:01 5.1.2600.2643  13,824  Rexec.exe
30-Mar-2005 01:01 5.1.2600.2643  14,848  Rsh.exe
25-Feb-2005 03:53 6.1.22.4      371,936  Updspapi.dll

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STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section. This problem was first corrected in Microsoft Windows Server 2003 Service Pack 2.

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MORE INFORMATION

For more information, click the following article number to view the article in the Microsoft Knowledge Base:
824684 (http://support.microsoft.com/kb/824684/) Description of the standard terminology that is used to describe Microsoft software updates

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APPLIES TO
Microsoft Windows XP Service Pack 2, when used with:
  Microsoft Windows XP Professional
Microsoft Windows Server 2003 Service Pack 1, when used with:
  Microsoft Windows Server 2003, Enterprise Edition (32-bit x86)
  Microsoft Windows Server 2003, Standard Edition (32-bit x86)
  Microsoft Windows Server 2003, Enterprise Edition for Itanium-based Systems
Microsoft Windows Server 2003, Standard x64 Edition
Microsoft Windows Server 2003, Enterprise x64 Edition

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Keywords: 
kbautohotfix kbwinserv2003sp2fix kbqfe kbhotfixserver kbfix kbbug KB896336

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